summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBienChen2021-04-01 16:49:07 +0800
committerBienChen2021-04-01 16:49:07 +0800
commitea5de2cd646b74be0a3dd1656bbf70f5fc91ced6 (patch)
tree7871479550cdec1618f8d38a9f3d9914dee063dc
downloadaur-ea5de2cd646b74be0a3dd1656bbf70f5fc91ced6.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--gcc-nuclei-bin.install7
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b22869bd0d56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gcc-nuclei-bin
+ pkgdesc = GNU Compiler Collection for RISC-V processor from Nuclei System Technology (official build).
+ pkgver = 2020.08
+ pkgrel = 1
+ url = https://nucleisys.com/download.php
+ install = gcc-nuclei-bin.install
+ arch = x86_64
+ license = GPL LGPL FDL custom
+ noextract = nuclei_riscv_newlibc_prebuilt_linux64_2020.08.tar.bz2
+ source = https://nucleisys.com/upload/files/toochain/gcc/nuclei_riscv_newlibc_prebuilt_linux64_2020.08.tar.bz2
+ sha256sums = 398c25b9385b8122d2e864bf71e47b1d871f6c326c21d0ae6d3afd2858f36041
+
+pkgname = gcc-nuclei-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88c9b60af31f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: BienChen <binchan at gmx dot com>
+
+pkgname=gcc-nuclei-bin
+_pkgname=Nuclei-Toolchain
+pkgver=2020.08
+pkgrel=1
+pkgdesc='GNU Compiler Collection for RISC-V processor from Nuclei System Technology (official build).'
+arch=('x86_64')
+url='https://nucleisys.com/download.php'
+license=('GPL LGPL FDL custom')
+install="${pkgname}.install"
+source=("https://nucleisys.com/upload/files/toochain/gcc/nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2")
+sha256sums=('398c25b9385b8122d2e864bf71e47b1d871f6c326c21d0ae6d3afd2858f36041')
+noextract=("nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2")
+
+prepare() {
+ mkdir -p "${srcdir}/opt/${_pkgname}"
+ bsdtar -xf "nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2" \
+ -C "${srcdir}/opt/${_pkgname}"
+}
+
+package() {
+ mv "${srcdir}/opt" "${pkgdir}/"
+}
diff --git a/gcc-nuclei-bin.install b/gcc-nuclei-bin.install
new file mode 100644
index 000000000000..6be88bd6ea4d
--- /dev/null
+++ b/gcc-nuclei-bin.install
@@ -0,0 +1,7 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+post_install() {
+ echo "add ${bold}export NUCLEI_TOOL_ROOT=/opt/Nuclei-Toolchain${all_off}"
+ echo "and ${bold}export PATH=\$NUCLEI_TOOL_ROOT/gcc/bin:\$NUCLEI_TOOL_ROOT/openocd/bin:\$PATH${all_off}"
+ echo "to ${bold}~/.bashrc${all_off} and ${bold}source ~/.bashrc${all_off} before compile any project."
+}