summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM1cha2017-09-30 20:58:17 +0200
committerM1cha2017-09-30 20:58:17 +0200
commit638ce2cf0effa8e855c1186981f9089c0b46775a (patch)
tree0e7d5be5e56a8ff71753949cc0cf55c068480dbc
downloadaur-638ce2cf0effa8e855c1186981f9089c0b46775a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb497868016f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gcc-xtensa-esp32-elf-bin
+ pkgdesc = ESP32 Toolchain
+ pkgver = 1.22.0_73_ge28a011_5.2.0
+ pkgrel = 1
+ url = https://esp-idf.readthedocs.io/en/latest/get-started/linux-setup.html
+ arch = x86_64
+ license = custom
+ depends = glibc
+ options = !strip
+ options = staticlibs
+ source = https://dl.espressif.com/dl/xtensa-esp32-elf-linux64-1.22.0-73-ge28a011-5.2.0.tar.gz
+ sha256sums = 3763dbed9fd43901c07757622e9c46d29e89eda812b83627df5cb9d019cae0e5
+
+pkgname = gcc-xtensa-esp32-elf-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3456cb3cd3e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Michael Zimmermann <sigmaepsilon92@gmail.com>
+# Contributor: James Duley <jagduley gmail>
+# Contributor: 2bluesc <2bluesc gmail.com>
+# Contributor: Vadzim Dambrouski <pftbest gmail.com>
+pkgname=gcc-xtensa-esp32-elf-bin
+pkgver=1.22.0_73_ge28a011_5.2.0
+pkgrel=1
+pkgdesc="ESP32 Toolchain"
+arch=('x86_64')
+depends=('glibc')
+url="https://esp-idf.readthedocs.io/en/latest/get-started/linux-setup.html"
+source=("https://dl.espressif.com/dl/xtensa-esp32-elf-linux64-1.22.0-73-ge28a011-5.2.0.tar.gz")
+license=('custom')
+options=(!strip staticlibs)
+sha256sums=('3763dbed9fd43901c07757622e9c46d29e89eda812b83627df5cb9d019cae0e5')
+
+package() {
+ mkdir -p $pkgdir/usr
+ cd $srcdir/xtensa-esp32-elf/
+ cp -a * $pkgdir/usr
+ rm -rf $pkgdir/usr/include
+ rm -rf $pkgdir/usr/share
+}