summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2022-05-09 12:17:39 +0100
committerJonathon Fernyhough2022-05-09 12:17:39 +0100
commitc07ae0266d75e44e2c18632c654564e765cb820c (patch)
tree9d0f48a977d166b4412d828b2f1c8ce0d3cb0563
downloadaur-c07ae0266d75e44e2c18632c654564e765cb820c.tar.gz
Initial commit for 11.2.0
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD239
-rw-r--r--c8910
-rw-r--r--c9910
4 files changed, 316 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34926f47a941
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,57 @@
+pkgbase = gcc11
+ pkgdesc = The GNU Compiler Collection (11.x.x)
+ pkgver = 11.2.0
+ pkgrel = 1
+ url = https://gcc.gnu.org
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = FDL
+ license = custom
+ checkdepends = dejagnu
+ checkdepends = inetutils
+ makedepends = binutils
+ makedepends = doxygen
+ makedepends = git
+ makedepends = libmpc
+ makedepends = python
+ options = !emptydirs
+ options = !lto
+ source = https://sourceware.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz
+ source = https://sourceware.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz.sig
+ source = https://mirror.sobukus.de/files/src/isl/isl-0.24.tar.xz
+ source = c89
+ source = c99
+ validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
+ validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
+ validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
+ validpgpkeys = D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62
+ b2sums = 69b61234ac436edfea2933df68c434a2ce7aa4454ef4da573e82587e1a42dc420189e949cfdadaf4cb37fc0de9674822210a95b77ff03aca0dbedfe67df19cc6
+ b2sums = SKIP
+ b2sums = 39cbfd18ad05778e3a5a44429261b45e4abc3efe7730ee890674d968890fe5e52c73bc1f8d271c7c3bc72d5754e3f7fcb209bd139e823d19cb9ea4ce1440164d
+ b2sums = 9298d353fbbb3a136211eace67c3acb1989fcf225549c921902a8303590b51c91736bb4584d32c577b1b1dc4f5e4d6125b4e039cc400c4767f01827667d15533
+ b2sums = 221f7e8e3850e39ed2d8562596f7fe30d22b9a32fd8d9e681f7f62bdd428f477f4c0d62d4826b695949508cf9da4fc4ffa87b9dc1c77537862c6e5de9d4f062f
+
+pkgname = gcc11
+ pkgdesc = The GNU Compiler Collection - C and C++ frontends (11.x.x)
+ depends = gcc11-libs=11.2.0-1
+ depends = binutils>=2.28
+ depends = libmpc
+ depends = zstd
+ options = !emptydirs
+ options = staticlibs
+
+pkgname = gcc11-libs
+ pkgdesc = Runtime libraries shipped by GCC (11.x.x)
+ depends = glibc>=2.27
+ provides = libgfortran.so
+ provides = libubsan.so
+ provides = libasan.so
+ provides = libtsan.so
+ provides = liblsan.so
+ options = !emptydirs
+ options = !strip
+
+pkgname = gcc11-fortran
+ pkgdesc = Fortran front-end for GCC (11.x.x)
+ depends = gcc11=11.2.0-1
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db15d1b053bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,239 @@
+# Maintainer: Jonathon Fernyhough <jonathon+m2x+dev>
+# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: Frederik Schwan <freswa at archlinux dot org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Daniel Kozak <kozzi11@gmail.com>
+
+pkgbase=gcc11
+pkgname=($pkgbase gcc11-libs gcc11-fortran)
+pkgver=11.2.0
+_majorver=${pkgver%%.*}
+_islver=0.24
+pkgrel=1
+pkgdesc='The GNU Compiler Collection (11.x.x)'
+arch=(x86_64)
+license=(GPL LGPL FDL custom)
+url='https://gcc.gnu.org'
+makedepends=(binutils doxygen git libmpc python)
+checkdepends=(dejagnu inetutils)
+options=(!emptydirs !lto)
+_libdir=usr/lib/gcc/$CHOST/${pkgver%%+*}
+source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig}
+ https://mirror.sobukus.de/files/src/isl/isl-${_islver}.tar.xz
+ c89 c99
+)
+validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
+ 86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
+ 13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
+ D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
+b2sums=('69b61234ac436edfea2933df68c434a2ce7aa4454ef4da573e82587e1a42dc420189e949cfdadaf4cb37fc0de9674822210a95b77ff03aca0dbedfe67df19cc6'
+ 'SKIP'
+ '39cbfd18ad05778e3a5a44429261b45e4abc3efe7730ee890674d968890fe5e52c73bc1f8d271c7c3bc72d5754e3f7fcb209bd139e823d19cb9ea4ce1440164d'
+ '9298d353fbbb3a136211eace67c3acb1989fcf225549c921902a8303590b51c91736bb4584d32c577b1b1dc4f5e4d6125b4e039cc400c4767f01827667d15533'
+ '221f7e8e3850e39ed2d8562596f7fe30d22b9a32fd8d9e681f7f62bdd428f477f4c0d62d4826b695949508cf9da4fc4ffa87b9dc1c77537862c6e5de9d4f062f')
+
+prepare() {
+ [[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
+ cd gcc
+
+ # link isl for in-tree build
+ ln -s ../isl-${_islver} isl
+
+ # Do not run fixincludes
+ sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
+
+ # Arch Linux installs x86_64 libraries /lib
+ sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
+
+ mkdir -p "$srcdir/gcc-build"
+}
+
+build() {
+ local _confflags="--prefix=/usr \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-bugurl=https://bugs.archlinux.org/ \
+ --with-isl \
+ --with-linker-hash-style=gnu \
+ --with-system-zlib \
+ --enable-__cxa_atexit \
+ --enable-cet=auto \
+ --enable-checking=release \
+ --enable-clocale=gnu \
+ --enable-default-pie \
+ --enable-default-ssp \
+ --enable-gnu-indirect-function \
+ --enable-gnu-unique-object \
+ --enable-linker-build-id \
+ --enable-lto \
+ --disable-multilib \
+ --enable-plugin \
+ --enable-shared \
+ --enable-threads=posix \
+ --disable-libssp \
+ --disable-libstdcxx-pch \
+ --disable-werror \
+ --with-build-config=bootstrap-lto \
+ --enable-link-serialization=1 \
+ --program-suffix=-${_majorver} \
+ --enable-version-specific-runtime-libs"
+
+ cd gcc-build
+
+ # Credits @allanmcrae
+ # https://github.com/allanmcrae/toolchain/blob/f18604d70c5933c31b51a320978711e4e6791cf1/gcc/PKGBUILD
+ # TODO: properly deal with the build issues resulting from this
+ CFLAGS=${CFLAGS/-Werror=format-security/}
+ CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
+
+ "$srcdir/gcc/configure" \
+ --enable-languages=c,c++,fortran,lto \
+ --enable-bootstrap \
+ --with-pkgversion="Arch Linux $pkgver-$pkgrel" \
+ $_confflags
+
+ # see https://bugs.archlinux.org/task/71777 for rationale re *FLAGS handling
+ make -O STAGE1_CFLAGS="-O2" \
+ BOOT_CFLAGS="$CFLAGS" \
+ BOOT_LDFLAGS="$LDFLAGS" \
+ LDFLAGS_FOR_TARGET="$LDFLAGS" \
+ profiledbootstrap
+
+ # make documentation
+ make -O -C $CHOST/libstdc++-v3/doc doc-man-doxygen
+
+ # see https://bugs.archlinux.org/task/71777 for rationale re *FLAGS handling
+ make -O STAGE1_CFLAGS="-O2" \
+ BOOT_CFLAGS="$CFLAGS" \
+ BOOT_LDFLAGS="$LDFLAGS" \
+ LDFLAGS_FOR_TARGET="$LDFLAGS" \
+ all-gcc
+
+ cp -a gcc/libgccjit.so* ../gcc-build/gcc/
+}
+
+check() {
+ cd gcc-build
+
+ # disable libphobos test to avoid segfaults and other unfunny ways to waste my time
+ sed -i '/maybe-check-target-libphobos \\/d' Makefile
+
+ # do not abort on error as some are "expected"
+ make -O -k check || true
+ "$srcdir/gcc/contrib/test_summary"
+}
+
+package_gcc11-libs() {
+ pkgdesc="Runtime libraries shipped by GCC (11.x.x)"
+ depends=('glibc>=2.27')
+ options=(!emptydirs !strip)
+ provides=(libgfortran.so libubsan.so libasan.so libtsan.so liblsan.so)
+
+ cd gcc-build
+ make -C $CHOST/libgcc DESTDIR="$pkgdir" install-shared
+ mv "${pkgdir}/${_libdir}"/../lib/* "${pkgdir}/${_libdir}"
+ rmdir "${pkgdir}/${_libdir}"/../lib
+ rm -f "$pkgdir/$_libdir/libgcc_eh.a"
+
+ for lib in libatomic \
+ libgfortran \
+ libgomp \
+ libitm \
+ libquadmath \
+ libsanitizer/{a,l,ub,t}san \
+ libstdc++-v3/src \
+ libvtv; do
+ make -C $CHOST/$lib DESTDIR="$pkgdir" install-toolexeclibLTLIBRARIES
+ done
+
+ make -C $CHOST/libstdc++-v3/po DESTDIR="$pkgdir" install
+
+ # Install Runtime Library Exception
+ install -Dm644 "$srcdir/gcc/COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/${pkgname}/RUNTIME.LIBRARY.EXCEPTION"
+
+ # remove conflicting files
+ rm -rf "${pkgdir}"/usr/share/locale
+}
+
+package_gcc11() {
+ pkgdesc="The GNU Compiler Collection - C and C++ frontends (11.x.x)"
+ depends=("${pkgbase}-libs=$pkgver-$pkgrel" 'binutils>=2.28' libmpc zstd)
+ options=(!emptydirs staticlibs)
+
+ cd gcc-build
+
+ make -C gcc DESTDIR="$pkgdir" install-driver install-cpp install-gcc-ar \
+ c++.install-common install-headers install-plugin install-lto-wrapper
+
+ install -m755 -t "$pkgdir/${_libdir}/" gcc/{cc1,cc1plus,collect2,lto1,gcov{,-tool}}
+
+ make -C $CHOST/libgcc DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}/${_libdir}"/../lib
+
+ make -C $CHOST/libstdc++-v3/src DESTDIR="$pkgdir" install
+ make -C $CHOST/libstdc++-v3/include DESTDIR="$pkgdir" install
+ make -C $CHOST/libstdc++-v3/libsupc++ DESTDIR="$pkgdir" install
+ make -C $CHOST/libstdc++-v3/python DESTDIR="$pkgdir" install
+ rm -f "${pkgdir}/${_libdir}"/libstdc++.so*
+
+ make DESTDIR="$pkgdir" install-fixincludes
+ make -C gcc DESTDIR="$pkgdir" install-mkheaders
+
+ make -C lto-plugin DESTDIR="$pkgdir" install
+ install -dm755 "$pkgdir"/${_libdir}/bfd-plugins/
+ ln -s /${_libdir}/liblto_plugin.so \
+ "$pkgdir/${_libdir}/bfd-plugins/"
+
+ make -C $CHOST/libgomp DESTDIR="$pkgdir" install-nodist_{libsubinclude,toolexeclib}HEADERS
+ make -C $CHOST/libitm DESTDIR="$pkgdir" install-nodist_toolexeclibHEADERS
+ make -C $CHOST/libquadmath DESTDIR="$pkgdir" install-nodist_libsubincludeHEADERS
+ make -C $CHOST/libsanitizer DESTDIR="$pkgdir" install-nodist_{saninclude,toolexeclib}HEADERS
+ make -C $CHOST/libsanitizer/asan DESTDIR="$pkgdir" install-nodist_toolexeclibHEADERS
+ make -C $CHOST/libsanitizer/tsan DESTDIR="$pkgdir" install-nodist_toolexeclibHEADERS
+ make -C $CHOST/libsanitizer/lsan DESTDIR="$pkgdir" install-nodist_toolexeclibHEADERS
+
+ make -C libcpp DESTDIR="$pkgdir" install
+ make -C gcc DESTDIR="$pkgdir" install-po
+
+ # many packages expect this symlink
+ ln -s gcc-${_majorver} "$pkgdir"/usr/bin/cc-${_majorver}
+
+ # POSIX conformance launcher scripts for c89 and c99
+ install -Dm755 "$srcdir/c89" "$pkgdir/usr/bin/c89-${_majorver}"
+ install -Dm755 "$srcdir/c99" "$pkgdir/usr/bin/c99-${_majorver}"
+
+ # byte-compile python libraries
+ python -m compileall "$pkgdir/usr/share/gcc-${pkgver%%+*}/"
+ python -O -m compileall "$pkgdir/usr/share/gcc-${pkgver%%+*}/"
+
+ # Install Runtime Library Exception
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s /usr/share/licenses/${pkgbase}-libs/RUNTIME.LIBRARY.EXCEPTION \
+ "$pkgdir/usr/share/licenses/$pkgname/"
+
+ # Remove conflicting files
+ rm -rf "$pkgdir"/usr/share/locale
+}
+
+package_gcc11-fortran() {
+ pkgdesc='Fortran front-end for GCC (11.x.x)'
+ depends=("${pkgbase}=$pkgver-$pkgrel")
+
+ cd gcc-build
+ make -C $CHOST/libgfortran DESTDIR="$pkgdir" install-cafexeclibLTLIBRARIES \
+ install-{toolexeclibDATA,nodist_fincludeHEADERS,gfor_cHEADERS}
+ make -C $CHOST/libgomp DESTDIR="$pkgdir" install-nodist_fincludeHEADERS
+ make -C gcc DESTDIR="$pkgdir" fortran.install-common
+ install -Dm755 gcc/f951 "$pkgdir/${_libdir}/f951"
+
+ ln -s gfortran-${_majorver} "$pkgdir/usr/bin/f95-${_majorver}"
+
+ # Install Runtime Library Exception
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s /usr/share/licenses/${pkgbase}-libs/RUNTIME.LIBRARY.EXCEPTION \
+ "$pkgdir/usr/share/licenses/$pkgname/"
+}
diff --git a/c89 b/c89
new file mode 100644
index 000000000000..31f8cb28f659
--- /dev/null
+++ b/c89
@@ -0,0 +1,10 @@
+#!/bin/sh
+fl="-std=c89"
+for opt; do
+ case "$opt" in
+ -ansi|-std=c89|-std=iso9899:1990) fl="";;
+ -std=*) echo "`basename $0` called with non ANSI/ISO C option $opt" >&2
+ exit 1;;
+ esac
+done
+exec gcc-11 $fl ${1+"$@"}
diff --git a/c99 b/c99
new file mode 100644
index 000000000000..22a3b9b9425d
--- /dev/null
+++ b/c99
@@ -0,0 +1,10 @@
+#!/bin/sh
+fl="-std=c99"
+for opt; do
+ case "$opt" in
+ -std=c99|-std=iso9899:1999) fl="";;
+ -std=*) echo "`basename $0` called with non ISO C99 option $opt" >&2
+ exit 1;;
+ esac
+done
+exec gcc-11 $fl ${1+"$@"}