summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibele2021-07-06 17:36:52 -0500
committerlibele2021-07-06 17:36:52 -0500
commit7d410165aacd83ca855208c48d3eeb3e17ee82ea (patch)
tree9523a39511acbd8406a42b7b384424b943973ddf
parent17b28dc45f20c5493f92cac85cb03892a85ee027 (diff)
downloadaur-7d410165aacd83ca855208c48d3eeb3e17ee82ea.tar.gz
add i386
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4050247f83dc..1dfe25ec987a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = gcc34-bin
pkgdesc = Compatibility GNU Compiler Collection.
pkgver = 3.4.6.4.1
- pkgrel = 2
+ pkgrel = 3
url = https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/repoview/compat-gcc-34.html
+ arch = i386
arch = x86_64
license = GPL2
license = LGPL
makedepends = rpmextract
depends = libf2c
provides = gcc34
- noextract = https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/compat-gcc-34-3.4.6-4.1.x86_64.rpm
+ noextract = compat-gcc-34-3.4.6-4.1.x86_64.rpm
options = !strip
- source = https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/compat-gcc-34-3.4.6-4.1.x86_64.rpm
- md5sums = 39584eda9be14f39194f8961482cf25c
+ source_i386 = https://linuxsoft.cern.ch/cern/slc5X/i386/yum/updates/compat-gcc-34-3.4.6-4.1.i386.rpm
+ md5sums_i386 = 75f5ec691a739ce7228fcac872bc25a0
+ source_x86_64 = https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/compat-gcc-34-3.4.6-4.1.x86_64.rpm
+ md5sums_x86_64 = 39584eda9be14f39194f8961482cf25c
pkgname = gcc34-bin
diff --git a/PKGBUILD b/PKGBUILD
index 30953257f0b2..b934745e5ebf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,24 @@
pkgname=gcc34-bin
pkgver=3.4.6.4.1
_rpmver="3.4.6-4.1"
-pkgrel=2
+pkgrel=3
pkgdesc="Compatibility GNU Compiler Collection."
-arch=('x86_64')
+arch=('i386' 'x86_64')
url="https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/repoview/compat-gcc-34.html"
license=('GPL2' 'LGPL')
options=(!strip)
provides=('gcc34')
depends=('libf2c')
makedepends=('rpmextract')
-source=("https://linuxsoft.cern.ch/cern/slc5X/${arch}/yum/updates/compat-gcc-34-${_rpmver}.${arch}.rpm")
-md5sums=('39584eda9be14f39194f8961482cf25c')
-noextract=("https://linuxsoft.cern.ch/cern/slc5X/${arch}/yum/updates/compat-gcc-34-${_rpmver}.${arch}.rpm")
+source_i386=("https://linuxsoft.cern.ch/cern/slc5X/i386/yum/updates/compat-gcc-34-${_rpmver}.i386.rpm")
+source_x86_64=("https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/compat-gcc-34-${_rpmver}.x86_64.rpm")
+md5sums_i386=('75f5ec691a739ce7228fcac872bc25a0')
+md5sums_x86_64=('39584eda9be14f39194f8961482cf25c')
+noextract=("compat-gcc-34-${_rpmver}.${CARCH}.rpm")
prepare() {
cd "${srcdir}"
- rpmextract.sh "compat-gcc-34-${_rpmver}.${arch}.rpm"
+ rpmextract.sh "compat-gcc-34-${_rpmver}.${CARCH}.rpm"
}
package() {