summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Nariyoshi2015-06-08 15:34:00 -0400
committerPedro Nariyoshi2015-06-08 15:34:00 -0400
commitf05be3e0cbd172615011677fce87f6e02c931ad7 (patch)
tree46a719cdb35c4cee6596da871edc2b0687491d5b
downloadaur-f05be3e0cbd172615011677fce87f6e02c931ad7.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD96
-rw-r--r--gcc_pure64.patch26
-rw-r--r--siginfo_t_fix.patch14
4 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0f7505308cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = gcc43
+ pkgdesc = The GNU Compiler Collection
+ pkgver = 4.3.6
+ pkgrel = 8
+ url = http://gcc.gnu.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = setconf
+ depends = binutils
+ depends = mpfr
+ depends = cloog
+ depends = zlib
+ depends = elfutils
+ options = !libtool
+ options = !buildflags
+ options = staticlibs
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.3.6/gcc-core-4.3.6.tar.bz2
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.3.6/gcc-g++-4.3.6.tar.bz2
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.3.6/gcc-fortran-4.3.6.tar.bz2
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.3.6/gcc-objc-4.3.6.tar.bz2
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.3.6/gcc-java-4.3.6.tar.bz2
+ source = gcc_pure64.patch
+ source = siginfo_t_fix.patch
+ md5sums = 43df9ad8b4bb314a46bac12f5aefaec2
+ md5sums = ee7dc01b6e1a6a92a6e8d66adb8d2ab9
+ md5sums = c6eeee73007015c52043716fbe8ffdc7
+ md5sums = 3fdb8158eabb765d1711f894bf71f7f5
+ md5sums = b5c12ad38048c354686747d640f5d621
+ md5sums = 4030ee1c08dd1e843c0225b772360e76
+ md5sums = edce21b2ce295478d14d5dd988eb3287
+
+pkgname = gcc43
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0e5ed6a4e2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Pedro Nariyoshi <pedro.nariyoshi@gmail.com>
+# Prev-Maintainer: Carson Reynolds <carson@k2.t.u-tokyo.ac.jp>
+# Contributor: kristianlm2 <kristanlein@gmail.com>
+# Contributor: progtologist <arissynod@gmail.com>
+
+pkgname=gcc43
+_ver=4.3
+pkgver=4.3.6
+pkgrel=8
+pkgdesc="The GNU Compiler Collection"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL')
+url="http://gcc.gnu.org"
+depends=('binutils' 'mpfr' 'cloog' 'zlib' 'elfutils')
+makedepends=('setconf')
+options=('!libtool' '!buildflags' 'staticlibs')
+
+source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++,fortran,objc,java}-${pkgver}.tar.bz2
+ gcc_pure64.patch
+ siginfo_t_fix.patch)
+
+md5sums=('43df9ad8b4bb314a46bac12f5aefaec2'
+ 'ee7dc01b6e1a6a92a6e8d66adb8d2ab9'
+ 'c6eeee73007015c52043716fbe8ffdc7'
+ '3fdb8158eabb765d1711f894bf71f7f5'
+ 'b5c12ad38048c354686747d640f5d621'
+ '4030ee1c08dd1e843c0225b772360e76'
+ 'edce21b2ce295478d14d5dd988eb3287')
+
+prepare() {
+ cd ${srcdir}/gcc-${pkgver}
+ # Don't install libiberty
+ sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
+
+ # Disables generating documentation (new texinfo does not like the old .texi files)
+ echo "MAKEINFO = :" >> ${srcdir}/gcc-${pkgver}/Makefile.in
+
+ patch -Np1 -i "$srcdir/siginfo_t_fix.patch"
+ if [[ "$CARCH" == "x86_64" ]]; then
+ patch -Np1 -i "$srcdir/gcc_pure64.patch"
+ fi
+ echo "$pkgver" > gcc/BASE-VER
+
+ # Don't run fixincludes
+ sed -i -e 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
+
+ rm -rf build
+ mkdir build
+}
+
+build()
+{
+ cd ${srcdir}/gcc-${pkgver}/build
+ ../configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --program-suffix=-${_ver} \
+ --enable-shared \
+ --enable-languages=c,c++ \
+ --enable-__cxa_atexit \
+ --disable-libstdcxx-pch \
+ --disable-multilib \
+ --enable-libgomp \
+ --disable-libmudflap \
+ --disable-libssp \
+ --enable-clocale=gnu \
+ --with-tune=generic \
+ --with-cloog \
+ --with-ppl \
+ --with-system-zlib \
+ --disable-werror
+ # --enable-checking=release \
+ make || return 1
+
+}
+
+package() {
+ cd "$srcdir/gcc-$pkgver/build"
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/usr/share/man/man7"
+ rm -rf "$pkgdir/usr/share/locale"
+ mv "$pkgdir"/usr/lib/lib* \
+ "$pkgdir/usr/lib/gcc/$CHOST/$pkgver/"
+
+ # Create links for gcc-4.3 build environment (useful for CUDA)
+ mkdir -p "$pkgdir/opt/gcc-$_ver"
+ ln -s /usr/bin/gcc-4.3 "$pkgdir/opt/gcc-$_ver/gcc"
+ ln -s /usr/bin/g++-4.3 "$pkgdir/opt/gcc-$_ver/g++"
+ # Avoid file conflicts when enabling libgomp
+ rm -rf "$pkgdir/usr/share/info"
+}
+
diff --git a/gcc_pure64.patch b/gcc_pure64.patch
new file mode 100644
index 000000000000..8c0baf8e2c0e
--- /dev/null
+++ b/gcc_pure64.patch
@@ -0,0 +1,26 @@
+diff -Naur gcc-4.2.0.orig/gcc/config/i386/linux64.h gcc-4.2.0/gcc/config/i386/linux64.h
+--- gcc-4.2.0.orig/gcc/config/i386/linux64.h 2007-05-16 19:21:19.000000000 -0400
++++ gcc-4.2.0/gcc/config/i386/linux64.h 2007-05-18 17:04:05.000000000 -0400
+@@ -49,8 +49,8 @@
+ When the -shared link option is used a final link is not being
+ done. */
+
+-#define GLIBC_DYNAMIC_LINKER32 "/lib/ld-linux.so.2"
+-#define GLIBC_DYNAMIC_LINKER64 "/lib64/ld-linux-x86-64.so.2"
++#define GLIBC_DYNAMIC_LINKER32 "/lib32/ld-linux.so.2"
++#define GLIBC_DYNAMIC_LINKER64 "/lib/ld-linux-x86-64.so.2"
+
+ #undef LINK_SPEC
+ #define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} \
+diff -Naur gcc-4.2.0.orig/gcc/config/i386/t-linux64 gcc-4.2.0/gcc/config/i386/t-linux64
+--- gcc-4.2.0.orig/gcc/config/i386/t-linux64 2007-05-16 19:21:19.000000000 -0400
++++ gcc-4.2.0/gcc/config/i386/t-linux64 2007-05-18 17:04:36.000000000 -0400
+@@ -6,7 +6,7 @@
+
+ MULTILIB_OPTIONS = m64/m32
+ MULTILIB_DIRNAMES = 64 32
+-MULTILIB_OSDIRNAMES = ../lib64 $(if $(wildcard $(shell echo $(SYSTEM_HEADER_DIR))/../../usr/lib32),../lib32,../lib)
++MULTILIB_OSDIRNAMES = ../lib ../lib32
+
+ LIBGCC = stmp-multilib
+ INSTALL_LIBGCC = install-multilib
diff --git a/siginfo_t_fix.patch b/siginfo_t_fix.patch
new file mode 100644
index 000000000000..d39f316f4ed8
--- /dev/null
+++ b/siginfo_t_fix.patch
@@ -0,0 +1,14 @@
+--- a/gcc/config/i386/linux-unwind.h 2011-01-03 20:52:22.000000000 +0000
++++ b/gcc/config/i386/linux-unwind.h 2012-07-06 12:23:51.562859470 +0100
+@@ -133,9 +133,9 @@
+ {
+ struct rt_sigframe {
+ int sig;
+- struct siginfo *pinfo;
++ siginfo_t *pinfo;
+ void *puc;
+- struct siginfo info;
++ siginfo_t info;
+ struct ucontext uc;
+ } *rt_ = context->cfa;
+ /* The void * cast is necessary to avoid an aliasing warning. \ No newline at end of file