summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2021-09-29 13:25:36 -0400
committerChris Severance2021-09-29 13:25:36 -0400
commite63cfc59b375e91dce7ab16e9ca7015360822cf6 (patch)
treef2f56a1cb27f82cf57ae71ad1eeea7430b58a4b9
parentdaa0687e83ea9148535d84f46d64deee413fe969 (diff)
downloadaur-e63cfc59b375e91dce7ab16e9ca7015360822cf6.tar.gz
autu: Update to 4.5.4-3 Long term compile fix
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD81
2 files changed, 41 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b186b61554bd..3191e8df5739 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Mon Mar 11 03:13:24 UTC 2019
pkgbase = gcc45
pkgdesc = The GNU Compiler Collection (4.5.x)
pkgver = 4.5.4
@@ -23,11 +21,17 @@ pkgbase = gcc45
conflicts = gcc45-multilib
options = staticlibs
options = !libtool
+ options = !buildflags
source = http://www.mirrorservice.org/sites/sourceware.org/pub/gcc/releases/gcc-4.5.4/gcc-4.5.4.tar.bz2
source = http://isl.gforge.inria.fr/isl-0.12.2.tar.bz2
source = http://www.bastoul.net/cloog/pages/download/cloog-0.18.1.tar.gz
source = gcc-hash-style-both.patch
source = gcc_pure64.patch
+ md5sums = 27e459c2566b8209ab064570e1b378f7
+ md5sums = e039bfcfb6c2ab039b8ee69bf883e824
+ md5sums = e34fca0540d840e5d0f6427e98c92252
+ md5sums = 6fd395bacbd7b6e47c7b74854b478363
+ md5sums = 4030ee1c08dd1e843c0225b772360e76
sha256sums = eef3f0456db8c3d992cbb51d5d32558190bc14f3bc19383dd93acc27acc6befc
sha256sums = f4b3dbee9712850006e44f0db2103441ab3d13b406f77996d1df19ee89d11fb4
sha256sums = 02500a4edd14875f94fe84cbeda4290425cb0c1c2474c6f75d75a303d64b4196
@@ -35,4 +39,3 @@ pkgbase = gcc45
sha256sums = 2d369cf93c6e15c3559c3560bce581e0ae5f1f34dc86bca013ac67ef1c1a9ff9
pkgname = gcc45
-
diff --git a/PKGBUILD b/PKGBUILD
index f70d1e9efae2..c993ce3ec649 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ depends=('glibc' 'binutils' 'gmp' 'mpfr' 'libmpc' 'ppl' 'elfutils') #'isl' 'cloo
makedepends=('flex' 'bison' 'setconf')
#makedepends+=('gcc49')
conflicts=("gcc${_pkgver//\./}-multilib")
-options=('staticlibs' '!libtool')
+options=('staticlibs' '!libtool' '!buildflags')
source=(
"http://www.mirrorservice.org/sites/sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
"http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
@@ -26,12 +26,16 @@ source=(
'gcc-hash-style-both.patch'
'gcc_pure64.patch'
)
+md5sums=('27e459c2566b8209ab064570e1b378f7'
+ 'e039bfcfb6c2ab039b8ee69bf883e824'
+ 'e34fca0540d840e5d0f6427e98c92252'
+ '6fd395bacbd7b6e47c7b74854b478363'
+ '4030ee1c08dd1e843c0225b772360e76')
sha256sums=('eef3f0456db8c3d992cbb51d5d32558190bc14f3bc19383dd93acc27acc6befc'
'f4b3dbee9712850006e44f0db2103441ab3d13b406f77996d1df19ee89d11fb4'
'02500a4edd14875f94fe84cbeda4290425cb0c1c2474c6f75d75a303d64b4196'
'a600550d3d2b2fb8ee6a547c68c3a08a2af7579290b340c35ee5598c9bb305a5'
'2d369cf93c6e15c3559c3560bce581e0ae5f1f34dc86bca013ac67ef1c1a9ff9')
-PKGEXT='.pkg.tar.gz'
if [ -n "${_snapshot:-}" ]; then
_basedir="gcc-${_snapshot}"
@@ -57,6 +61,7 @@ prepare() {
patch -Np0 -i "${srcdir}/gcc-hash-style-both.patch"
+ # fix build with glibc 2.26
sed -e 's:\bstruct ucontext\b:ucontext_t:g' -i $(grep --include '*.[ch]' --include '*.cc' -lre '\bstruct ucontext\b')
sed -e 's:\bstruct sigaltstack\b:stack_t:g' -i $(grep --include '*.[ch]' --include '*.cc' -lre '\bstruct sigaltstack\b')
@@ -79,57 +84,41 @@ build() {
if [ ! -s "${_basedir}/gcc-build/Makefile" ]; then
cd "${_basedir}"
- # Doesn't like FORTIFY_SOURCE
- CPPFLAGS="${CPPFLAGS//-D_FORTIFY_SOURCE=?/}"
-
- # Doesn't like -fstack-protector-strong
- CFLAGS="${CFLAGS//-fstack-protector-strong/-fstack-protector}"
- CXXFLAGS="${CXXFLAGS//-fstack-protector-strong/-fstack-protector}"
-
- # using -pipe causes spurious test-suite failures
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS="${CFLAGS/-pipe/}"
- CXXFLAGS="${CXXFLAGS/-pipe/}"
-
- # Flags from new compilers that old compilers don't recognize
- CFLAGS="${CFLAGS/-fno-plt/}"
- CXXFLAGS="${CXXFLAGS/-fno-plt/}"
-
- CFLAGS="${CFLAGS/-Wformat-overflow=[0-9]/}"
- CXXFLAGS="${CXXFLAGS/-Wformat-overflow=[0-9]/}"
-
cd 'gcc-build'
# The following options are one per line, mostly sorted so they are easy to diff compare to other gcc packages.
- ../configure \
- --build="${CHOST}" \
- --disable-libgomp \
- --disable-libmudflap \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-multilib \
- --enable-__cxa_atexit \
- --enable-clocale='gnu' \
- --enable-cloog-backend='isl' \
- --enable-languages='c,c++,fortran,objc,obj-c++' \
- --enable-shared \
- --enable-version-specific-runtime-libs \
- --infodir='/usr/share/info' \
- --libdir='/usr/lib' \
- --libexecdir='/usr/lib' \
- --mandir='/usr/share/man' \
- --program-suffix="-${_pkgver}" \
- --with-cloog \
- --with-ppl \
- --with-system-zlib \
- --with-tune='generic' \
+ local _conf=(
+ --build="${CHOST}"
+ --disable-libgomp
+ --disable-libmudflap
+ --disable-libssp
+ --disable-libstdcxx-pch
+ --disable-multilib
+ --enable-__cxa_atexit
+ --enable-clocale='gnu'
+ --enable-cloog-backend='isl'
+ --enable-languages='c,c++,fortran,objc,obj-c++'
+ --enable-shared
+ --enable-version-specific-runtime-libs
+ --infodir='/usr/share/info'
+ --libdir='/usr/lib'
+ --libexecdir='/usr/lib'
+ --mandir='/usr/share/man'
+ --program-suffix="-${_pkgver}"
+ --with-cloog
+ --with-ppl
+ --with-system-zlib
+ --with-tune='generic'
--prefix='/usr'
-# CXX='g++-4.9' CC='gcc-4.9'
+ #CXX='g++-4.9' CC='gcc-4.9'
+ )
+ ../configure "${_conf[@]}"
+
+ sed -e 's/^STAGE1_CXXFLAGS.*$/& -std=gnu++11/' -i 'Makefile'
fi
cd "${srcdir}/${_basedir}/gcc-build"
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
#LD_PRELOAD='/usr/lib/libstdc++.so' \\
- nice make -j "${_nproc}"
+ nice make -s
set +u
}