summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-10-09 23:06:54 -0400
committerChris Severance2016-10-09 23:06:54 -0400
commit6ecef523d7ea3f8f3728b15b9c4f6e31da91e9cf (patch)
tree5aca98541e97ccb72b6c50e55582eb7aaee1531e
parent3bf13c127b52df0bf45b98a83876c9bf7ba81cd3 (diff)
downloadaur-6ecef523d7ea3f8f3728b15b9c4f6e31da91e9cf.tar.gz
Fix compile for texinfo>=6.3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
-rw-r--r--gcc.texi.49.patch44
3 files changed, 62 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81cd00940ae..025fb4111aa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jun 13 21:27:26 UTC 2016
+# Mon Oct 10 03:06:13 UTC 2016
pkgbase = gcc48
pkgdesc = The GNU Compiler Collection - C and C++ frontends (4.8.x)
pkgver = 4.8.5
@@ -17,14 +17,17 @@ pkgbase = gcc48
makedepends = libmpc
makedepends = doxygen
makedepends = cloog
+ makedepends = texinfo
depends = zlib
options = !emptydirs
options = staticlibs
options = !libtool
source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.8.5/gcc-4.8.5.tar.bz2
source = gcc-4.9-fix-build-with-gcc-6.patch
+ source = gcc.texi.49.patch
sha256sums = 22fb1e7e0f68a63cee631d85b20461d1ea6bda162f03096350e38c8d427ecf23
sha256sums = d775a053fad367f5490111038fde7c875b4e842919d2d197f95b915e1ae562a9
+ sha256sums = 93b8865cb61f455df807de90f852dc488753d4309d7a1d8f7e7f1a4efe37ffa4
pkgname = gcc48
diff --git a/PKGBUILD b/PKGBUILD
index 1f0524d58608..70525a6e168c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,15 +19,17 @@ url='http://gcc.gnu.org'
license=('GPL' 'LGPL' 'FDL' 'custom')
depends=('zlib')
makedepends=('binutils>=2.24' 'libmpc' 'doxygen')
-makedepends+=('cloog')
+makedepends+=('cloog' 'texinfo')
checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs' 'staticlibs' '!libtool')
source=(
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
- "gcc-4.9-fix-build-with-gcc-6.patch"
+ 'gcc-4.9-fix-build-with-gcc-6.patch'
+ 'gcc.texi.49.patch'
)
sha256sums=('22fb1e7e0f68a63cee631d85b20461d1ea6bda162f03096350e38c8d427ecf23'
- 'd775a053fad367f5490111038fde7c875b4e842919d2d197f95b915e1ae562a9')
+ 'd775a053fad367f5490111038fde7c875b4e842919d2d197f95b915e1ae562a9'
+ '93b8865cb61f455df807de90f852dc488753d4309d7a1d8f7e7f1a4efe37ffa4')
PKGEXT='.pkg.tar.gz'
_basedir="gcc-${pkgver}"
@@ -44,6 +46,9 @@ prepare() {
# fix build with GCC 6
patch -p1 < "${srcdir}/gcc-4.9-fix-build-with-gcc-6.patch"
+ # Update gcc.texi to gcc49 version, needed as of texinfo>=6.3 and possibly texinfo=6.2
+ patch -p0 -c < "${srcdir}/gcc.texi.49.patch"
+
# Arch Linux installs x86_64 libraries /lib
case "${CARCH}" in
'x86_64') sed -i -e '/m64=/s/lib64/lib/' 'gcc/config/i386/t-linux64' ;;
@@ -106,6 +111,7 @@ prepare() {
--with-system-zlib \
--prefix='/usr'
# CXX='g++-4.9' CC='gcc-4.9'
+
set +u
}
@@ -140,6 +146,7 @@ package() {
set -u
cd "${_basedir}/gcc-build"
+ #LD_PRELOAD='/usr/lib/libstdc++.so' \\
make -s -j1 DESTDIR="${pkgdir}" install
## Lazy way of dealing with conflicting man and info pages and locales...
@@ -147,7 +154,10 @@ package() {
find "${pkgdir}/" -name '*iberty*' | xargs rm
# Move potentially conflicting stuff to version specific subdirectory
- mv "${pkgdir}/usr/lib/gcc/${CHOST}"/lib*/ "${pkgdir}/usr/lib/gcc/${CHOST}/${pkgver}/" || : # Not needed for 32 bit compile
+ case "${CARCH}" in
+ 'x86_64') mv "${pkgdir}/usr/lib/gcc/${CHOST}"/lib*/ "${pkgdir}/usr/lib/gcc/${CHOST}/${pkgver}/" ;;
+ esac
+ #mv ${pkgdir}/usr/lib/lib* "${pkgdir}/usr/lib/gcc/${CHOST}/${pkgver}/"
# Install Runtime Library Exception
install -Dpm644 '../COPYING.RUNTIME' \
diff --git a/gcc.texi.49.patch b/gcc.texi.49.patch
new file mode 100644
index 000000000000..056853ddb101
--- /dev/null
+++ b/gcc.texi.49.patch
@@ -0,0 +1,44 @@
+*** gcc/doc/gcc.texi Tue Jun 23 03:35:08 2015
+--- gcc/doc/gcc.texi.49 Fri Jun 26 13:47:23 2015
+***************
+*** 83,93 ****
+ Published by:
+ @multitable @columnfractions 0.5 0.5
+ @item GNU Press
+! @tab Website: www.gnupress.org
+ @item a division of the
+! @tab General: @tex press@@gnu.org @end tex
+ @item Free Software Foundation
+! @tab Orders: @tex sales@@gnu.org @end tex
+ @item 51 Franklin Street, Fifth Floor
+ @tab Tel 617-542-5942
+ @item Boston, MA 02110-1301 USA
+--- 83,93 ----
+ Published by:
+ @multitable @columnfractions 0.5 0.5
+ @item GNU Press
+! @tab Website: @uref{http://www.gnupress.org}
+ @item a division of the
+! @tab General: @email{press@@gnu.org}
+ @item Free Software Foundation
+! @tab Orders: @email{sales@@gnu.org}
+ @item 51 Franklin Street, Fifth Floor
+ @tab Tel 617-542-5942
+ @item Boston, MA 02110-1301 USA
+***************
+*** 140,146 ****
+ * Gcov:: @command{gcov}---a test coverage program.
+ * Trouble:: If you have trouble using GCC.
+ * Bugs:: How, why and where to report bugs.
+! * Service:: How to find suppliers of support for GCC.
+ * Contributing:: How to contribute to testing and developing GCC.
+
+ * Funding:: How to help assure funding for free software.
+--- 140,146 ----
+ * Gcov:: @command{gcov}---a test coverage program.
+ * Trouble:: If you have trouble using GCC.
+ * Bugs:: How, why and where to report bugs.
+! * Service:: How To Get Help with GCC
+ * Contributing:: How to contribute to testing and developing GCC.
+
+ * Funding:: How to help assure funding for free software.