summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwtx2019-06-16 08:29:51 +0200
committerwtx2019-06-16 12:28:07 +0200
commita2c5d52a18fe0d6242dc9b35ed7c0806302e8d87 (patch)
treeff9f60d4045bb10ea1c28a26326af97d590d8ff1
parentf91557b10e2979605175b3628efdac1b960a8940 (diff)
downloadaur-a2c5d52a18fe0d6242dc9b35ed7c0806302e8d87.tar.gz
Update to gcc-4.9.4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
-rw-r--r--ustat.patch31
3 files changed, 46 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 013711536655..d318575a6eaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Dec 18 06:40:38 UTC 2015
pkgbase = gcc49-alternative
pkgdesc = The GNU Compiler Collection 4.9 for multilib
- pkgver = 4.9.3
- pkgrel = 3
+ pkgver = 4.9.4
+ pkgrel = 2
url = http://gcc.gnu.org
arch = x86_64
license = GPL
@@ -17,10 +15,10 @@ pkgbase = gcc49-alternative
makedepends = doxygen
makedepends = lib32-glibc>=2.20
options = !emptydirs
- source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.9.3/gcc-4.9.3.tar.bz2
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.9.4/gcc-4.9.4.tar.bz2
source = http://isl.gforge.inria.fr/isl-0.12.2.tar.bz2
source = http://www.bastoul.net/cloog/pages/download/cloog-0.18.1.tar.gz
- md5sums = 6f831b4d251872736e8e9cc09746f327
+ md5sums = 87c24a4090c1577ba817ec6882602491
md5sums = e039bfcfb6c2ab039b8ee69bf883e824
md5sums = e34fca0540d840e5d0f6427e98c92252
@@ -28,18 +26,18 @@ pkgname = gcc49-alternative-multilib
pkgdesc = The GNU Compiler Collection 4.9 - C and C++ frontends for multilib
install = gcc49-alternative.install
groups = multilib-devel
- depends = gcc49-alternative-libs-multilib=4.9.3-2
+ depends = gcc49-alternative-libs-multilib=4.9.4-2
depends = binutils>=2.25
depends = libmpc
- provides = gcc49=4.9.3-2
+ provides = gcc49=4.9.4-2
options = staticlibs
pkgname = gcc49-alternative-libs-multilib
pkgdesc = Runtime GCC 4.9 libraries for multilib
install = gcc49-alternative-libs.install
depends = glibc>=2.20
- depends = lib32-gcc49-alternative-libs=4.9.3-2
- provides = gcc49-alternative-libs=4.9.3-2
+ depends = lib32-gcc49-alternative-libs=4.9.4-2
+ provides = gcc49-alternative-libs=4.9.4-2
options = !emptydirs
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 0d28234d87a6..232a6f246f94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# NOTE: libtool requires rebuilt with each new gcc version
pkgname=('gcc49-alternative-multilib' 'gcc49-alternative-libs-multilib' 'lib32-gcc49-alternative-libs')
-pkgver=4.9.3
+pkgver=4.9.4
_pkgver=4.9
_islver=0.12.2
_cloogver=0.18.1
@@ -24,7 +24,7 @@ source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
http://www.bastoul.net/cloog/pages/download/cloog-${_cloogver}.tar.gz)
-md5sums=('6f831b4d251872736e8e9cc09746f327'
+md5sums=('87c24a4090c1577ba817ec6882602491'
'e039bfcfb6c2ab039b8ee69bf883e824'
'e34fca0540d840e5d0f6427e98c92252')
@@ -55,10 +55,14 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- patch -p1 -i ${startdir}/cfns.h.diff
+# patch -p1 -i ${startdir}/cfns.h.diff
patch -p1 -i ${startdir}/ucontext_t.patch
patch -p1 -i ${startdir}/sigaltstack.patch
patch -p1 -i ${startdir}/libsanitizer.patch
+ patch -p1 -i ${startdir}/ustat.patch
+
+ (cd libgcc; ln -sf gthr-posix.h gthr-default.h)
+ (cd libgcc; ln -sf config/i386/linux-unwind.h md-unwind-support.h)
mkdir -p ${srcdir}/gcc-build
}
diff --git a/ustat.patch b/ustat.patch
new file mode 100644
index 000000000000..7d01c7e67696
--- /dev/null
+++ b/ustat.patch
@@ -0,0 +1,31 @@
+--- gcc-4.9.4/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2013-12-19 13:54:11.000000000 +0100
++++ gcc-4.9.4/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2018-09-16 15:23:46.141733145 +0200
+@@ -81,7 +81,6 @@
+ #include <sys/statvfs.h>
+ #include <sys/timex.h>
+ #include <sys/user.h>
+-#include <sys/ustat.h>
+ #include <linux/cyclades.h>
+ #include <linux/if_eql.h>
+ #include <linux/if_plip.h>
+@@ -163,7 +162,19 @@
+ unsigned struct_old_utsname_sz = sizeof(struct old_utsname);
+ unsigned struct_oldold_utsname_sz = sizeof(struct oldold_utsname);
+ unsigned struct_itimerspec_sz = sizeof(struct itimerspec);
+- unsigned struct_ustat_sz = sizeof(struct ustat);
++ // Use pre-computed size of struct ustat to avoid <sys/ustat.h> which
++ // has been removed from glibc 2.28.
++#if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \
++ || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \
++ || defined(__x86_64__)
++#define SIZEOF_STRUCT_USTAT 32
++#elif defined(__arm__) || defined(__i386__) || defined(__mips__) \
++ || defined(__powerpc__) || defined(__s390__) || defined(__sparc__)
++#define SIZEOF_STRUCT_USTAT 20
++#else
++#error Unknown size of struct ustat
++#endif
++ unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT;
+ #endif // SANITIZER_LINUX
+
+ #if SANITIZER_LINUX && !SANITIZER_ANDROID