summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-09-03 00:29:03 +0300
committerDrobot Viktor2019-09-03 00:29:03 +0300
commitd50466d606d5f418571d8f826e0d7dd4742a67c1 (patch)
tree8737d2623dc4b829a1f39ec4360806da6bddbf47
parent8abd6db00a969d8315080ee517c2fbee24778046 (diff)
downloadaur-d50466d606d5f418571d8f826e0d7dd4742a67c1.tar.gz
Fixed issue with libtool
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb5ebbe4290d..34c22b8c4d26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcc6
pkgdesc = The GNU Compiler Collection (6.x.x)
pkgver = 6.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://gcc.gnu.org/gcc-6/
arch = x86_64
license = GPL
@@ -28,7 +28,7 @@ pkgbase = gcc6
pkgname = gcc6
pkgdesc = The GNU Compiler Collection - C and C++ frontends
- depends = gcc6-libs=6.5.0-2
+ depends = gcc6-libs=6.5.0-3
depends = binutils>=2.28
depends = libmpc
options = staticlibs
@@ -41,12 +41,12 @@ pkgname = gcc6-libs
pkgname = gcc6-fortran
pkgdesc = Fortran front-end for GCC
- depends = gcc6=6.5.0-2
+ depends = gcc6=6.5.0-3
options = !emptydirs
pkgname = gcc6-gcj
pkgdesc = Java front-end for GCC
- depends = gcc6=6.5.0-2
+ depends = gcc6=6.5.0-3
replaces = gcc-gcj
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index f4260f7dbc5e..5e465efe0183 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
# Contributor: frankspace
# Contributor: Renan Manola <rmanola@gmail.com>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
@@ -12,7 +13,7 @@ pkgver=6.5.0
_ver=6
_islver=0.18
_cloogver=0.18.4
-pkgrel=2
+pkgrel=3
pkgdesc="The GNU Compiler Collection (6.x.x)"
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -51,6 +52,8 @@ prepare() {
}
build() {
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
# using -pipe causes spurious test-suite failures
@@ -104,6 +107,8 @@ package_gcc6-libs() {
depends=('glibc>=2.25')
options=('!emptydirs' '!strip')
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
make -C $CHOST/libgcc DESTDIR=${pkgdir} install-shared
rm ${pkgdir}/${_libdir}/libgcc_eh.a
@@ -147,6 +152,8 @@ package_gcc6() {
depends=("gcc6-libs=${pkgver}-${pkgrel}" 'binutils>=2.28' 'libmpc')
options=('staticlibs')
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
make -C gcc DESTDIR=${pkgdir} install-driver install-cpp install-gcc-ar \
@@ -248,6 +255,8 @@ package_gcc6-fortran() {
depends=("gcc6=$pkgver-$pkgrel")
options=('!emptydirs')
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
make -C $CHOST/libgfortran DESTDIR=$pkgdir install-cafexeclibLTLIBRARIES \
install-{toolexeclibDATA,nodist_fincludeHEADERS}
@@ -268,6 +277,8 @@ package_gcc6-gcj() {
replaces=('gcc-gcj')
options=('!emptydirs')
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
# Install libjava.
cd gcc-build
make -j1 DESTDIR=${pkgdir} install-target-libjava