summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2015-06-11 15:10:14 -0400
committerJoey Dumont2015-06-11 15:10:14 -0400
commita0d0e1480b73b3cd5b7c18ecf862852bce753eac (patch)
treeee17c0f950b5708832be0ff53782606080d3cc51
downloadaur-a0d0e1480b73b3cd5b7c18ecf862852bce753eac.tar.gz
Pushed package to AUR4.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD22
-rwxr-xr-xecj15
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bff85a57501
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gcc-gcj-ecj
+ pkgdesc = A fork of the Eclipse Java bytecode compiler for GCJ
+ pkgver = 4.9
+ pkgrel = 1
+ url = http://gcc.gnu.org/java/
+ arch = any
+ license = EPL
+ provides = eclipse-ecj
+ conflicts = eclipse-ecj
+ source = http://mirrors.kernel.org/sources.redhat.com/java/ecj-4.9.jar
+ source = ecj1
+ md5sums = 7339f199ba11c941890031fd9981d7be
+ md5sums = 1bb97ba733268e8850a2610559d21c19
+
+pkgname = gcc-gcj-ecj
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67f8c18f0637
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+*.jar
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dbd8c19480f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Joey Dumont <joey.dumont@gmail.com>
+# Contributor: Pierre Bourdon <delroth@gmail.com>
+# Contributor: larsrh <hupel@in.tum.de>
+
+pkgname=gcc-gcj-ecj
+pkgver=4.9
+pkgrel=1
+pkgdesc="A fork of the Eclipse Java bytecode compiler for GCJ"
+depends=()
+provides=('eclipse-ecj')
+conflicts=('eclipse-ecj')
+arch=('any')
+license=('EPL')
+url="http://gcc.gnu.org/java/"
+source=(http://mirrors.kernel.org/sources.redhat.com/java/ecj-${pkgver}.jar ecj1)
+
+package() {
+ install -D -m644 $srcdir/ecj-${pkgver}.jar $pkgdir/usr/share/java/eclipse-ecj.jar
+ install -D -m755 $srcdir/ecj1 $pkgdir/usr/bin/ecj1
+}
+md5sums=('7339f199ba11c941890031fd9981d7be'
+ '1bb97ba733268e8850a2610559d21c19')
diff --git a/ecj1 b/ecj1
new file mode 100755
index 000000000000..f455b93f2126
--- /dev/null
+++ b/ecj1
@@ -0,0 +1,5 @@
+#!/bin/sh
+gij -cp /usr/share/java/eclipse-ecj.jar \
+ org.eclipse.jdt.internal.compiler.batch.GCCMain \
+ ${1+"$@"}
+