summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Alvarez2021-06-30 10:34:04 +0200
committerDavid Alvarez2021-06-30 10:34:04 +0200
commited24c614c9429ccfdc295707e49977b20102a9cc (patch)
tree837e7c053aebd1018d453c573792ae2460967edc
parentf234e903cf4351cf6a5f729fe46d03b7beda67db (diff)
downloadaur-ed24c614c9429ccfdc295707e49977b20102a9cc.tar.gz
Fix compilation errors in modern GCCs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 541059e11165..10f8f93d8f95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcc7
pkgdesc = The GNU Compiler Collection (7.x.x)
pkgver = 7.5.0
- pkgrel = 2
+ pkgrel = 3
url = http://gcc.gnu.org
arch = x86_64
license = GPL
@@ -26,7 +26,7 @@ pkgbase = gcc7
pkgname = gcc7
pkgdesc = The GNU Compiler Collection - C and C++ frontends (7.x.x)
- depends = gcc7-libs=7.5.0-2
+ depends = gcc7-libs=7.5.0-3
depends = binutils>=2.28
depends = libmpc
options = !emptydirs
@@ -40,6 +40,6 @@ pkgname = gcc7-libs
pkgname = gcc7-fortran
pkgdesc = Fortran front-end for GCC (7.x.x)
- depends = gcc7=7.5.0-2
+ depends = gcc7=7.5.0-3
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 288d96f2ce29..a0029d56cc63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: David (ReyJamonico) < david at rjamo dot dev >
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
# Contributor: Konstantin Gizdov <arch@kge.pw>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
@@ -13,7 +14,7 @@ pkgver=7.5.0
_pkgver=7
_majorver=${pkgver:0:1}
_islver=0.18
-pkgrel=2
+pkgrel=3
pkgdesc='The GNU Compiler Collection (7.x.x)'
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -83,8 +84,15 @@ build() {
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS=${CFLAGS/-pipe/}
- CXXFLAGS=${CXXFLAGS/-pipe/}
+ # -Werror=format-security causes compilation errors with GCC>10
+ # And protection flags leave libgcc unusable
+ banned_compile_options=("-pipe" "-Werror=format-security" "-fstack-clash-protection" "-fcf-protection")
+
+ for option in "${banned_compile_options[@]}"
+ do
+ CFLAGS=${CFLAGS/$option/}
+ CXXFLAGS=${CXXFLAGS/$option/}
+ done
"$srcdir/gcc/configure" --prefix=/usr \
--libdir=/usr/lib \