summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-05-13 21:42:04 +0100
committerJonathon Fernyhough2021-05-13 21:42:04 +0100
commit39fdd75fb9a445a48d3ed7f9825004ca589a2a99 (patch)
tree63cfd51ad7422fe574fcb8d15787b8eb264b1aed
parent7852e39068f1bb54798ed4b9a1c9d4d979bc9bfe (diff)
downloadaur-39fdd75fb9a445a48d3ed7f9825004ca589a2a99.tar.gz
Work around build failure caused by -Werror=format-security
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49c1a80db8b3..3c2e3c17ac45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,6 +55,10 @@ build() {
CFLAGS=${CFLAGS/-pipe/}
CXXFLAGS=${CXXFLAGS/-pipe/}
+ # Force this for now, doesn't seem to be picked up via patch from https://bugs.archlinux.org/task/70701
+ CFLAGS+=" -Wno-format -Wno-format-security"
+ CXXFLAGS+=" -Wno-format -Wno-format-security"
+
"$srcdir/gcc/configure" --prefix=/usr \
--libdir=/usr/lib \
--libexecdir=/usr/lib \