summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWestly Ward2020-09-21 19:44:41 -0600
committerWestly Ward2020-09-21 19:44:41 -0600
commitf2a8fe2b89991fedf5645f82af2f54c063f657c7 (patch)
tree4c1cb24b070577ec2c3ad435de15d213eed41d7a
parentcf6e7eed7aa3e6e60ee689d954e2fc4e08f10e96 (diff)
downloadaur-f2a8fe2b89991fedf5645f82af2f54c063f657c7.tar.gz
Failed to compile xmrig. Had to change a few options to make it work
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--fix.patch30
3 files changed, 9 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb056fd42961..42f774f5cf09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = gcc81-raspi4-xmrig
pkgdesc = This package is meant to be a dependency for xmrig-raspi4-donateless because it will not compile with gcc 10. It only includes C and C++
pkgver = 8.1.0
- pkgrel = 1
+ pkgrel = 2
arch = aarch64
license = GPL3
options = !buildflags
+ options = staticlibs
+ options = !strip
source = https://ftpmirror.gnu.org/gcc/gcc-8.1.0/gcc-8.1.0.tar.gz
source = fix.patch
md5sums = 6a1fabd167fe98c11857181c210fc743
- md5sums = a0bb00114182d8095e0eb255ddf0c767
+ md5sums = c6fe49a2334ccd59635694a1655d3a09
pkgname = gcc81-raspi4-xmrig
diff --git a/PKGBUILD b/PKGBUILD
index b9d18d2333e1..461c1396264e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Westly Ward <sonicrules1234 at gmail dot com>
pkgname=gcc81-raspi4-xmrig
pkgver=8.1.0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="This package is meant to be a dependency for xmrig-raspi4-donateless because it will not compile with gcc 10. It only includes C and C++"
arch=('aarch64')
@@ -16,23 +16,20 @@ provides=()
conflicts=()
replaces=()
backup=()
-options=(!buildflags)
+options=(!buildflags staticlibs !strip)
install=
changelog=
source=("https://ftpmirror.gnu.org/gcc/gcc-8.1.0/gcc-8.1.0.tar.gz"
"fix.patch")
noextract=()
md5sums=('6a1fabd167fe98c11857181c210fc743'
- 'a0bb00114182d8095e0eb255ddf0c767')
+ 'c6fe49a2334ccd59635694a1655d3a09')
validpgpkeys=()
prepare() {
cd "gcc-8.1.0"
./contrib/download_prerequisites
- #mv gcc-8.1.0 gcc-8.1.0.orig
- #cp -r gcc-8.1.0.orig gcc-8.1.0.new
- #cd gcc-8.1.0.new
- patch --strip=1 --input="../fix.patch"
+ patch --strip=1 --input="../avoid_ustat.patch"
cd "../"
mkdir -p build
}
diff --git a/fix.patch b/fix.patch
index b6d825f3fdb2..8fcd0ab19efd 100644
--- a/fix.patch
+++ b/fix.patch
@@ -1,34 +1,6 @@
-diff --unified --recursive --text gcc-8.1.0.orig/gcc/gimple-fold.c gcc-8.1.0.new/gcc/gimple-fold.c
---- gcc-8.1.0.orig/gcc/gimple-fold.c 2018-04-20 23:43:51.000000000 +0000
-+++ gcc-8.1.0.new/gcc/gimple-fold.c 2020-09-20 23:38:08.592114777 +0000
-@@ -2654,6 +2654,7 @@
- return false;
-
- gimple_seq stmts = NULL;
-+ len = force_gimple_operand (len, &stmts, true, NULL_TREE);
- len = gimple_convert (&stmts, loc, size_type_node, len);
- len = gimple_build (&stmts, loc, PLUS_EXPR, size_type_node, len,
- build_int_cst (size_type_node, 1));
-diff --unified --recursive --text gcc-8.1.0.orig/gcc/tree-ssa-strlen.c gcc-8.1.0.new/gcc/tree-ssa-strlen.c
---- gcc-8.1.0.orig/gcc/tree-ssa-strlen.c 2018-03-12 18:04:16.000000000 +0000
-+++ gcc-8.1.0.new/gcc/tree-ssa-strlen.c 2020-09-20 23:45:48.304795200 +0000
-@@ -2533,6 +2533,13 @@
- len = force_gimple_operand_gsi (gsi, len, true, NULL_TREE, true,
- GSI_SAME_STMT);
- }
-+ if (objsz)
-+ {
-+ objsz = fold_build2_loc (loc, MINUS_EXPR, TREE_TYPE (objsz),
-+ objsz, unshare_expr (dstlen));
-+ objsz = force_gimple_operand_gsi (gsi, objsz, true, NULL_TREE, true,
-+ GSI_SAME_STMT);
-+ }
- if (endptr)
- dst = fold_convert_loc (loc, TREE_TYPE (dst), unshare_expr (endptr));
- else
diff --unified --recursive --text gcc-8.1.0.orig/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc gcc-8.1.0.new/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
--- gcc-8.1.0.orig/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2017-10-19 11:23:59.000000000 +0000
-+++ gcc-8.1.0.new/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2020-09-20 23:31:33.498439014 +0000
++++ gcc-8.1.0.new/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2020-09-20 17:45:49.165998729 +0000
@@ -157,7 +157,6 @@
# include <sys/procfs.h>
#endif