summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002022-12-25 18:59:54 +0100
committermyself6002022-12-25 18:59:54 +0100
commit1ba2e612ebf5b5408b82f36822713bf869091a64 (patch)
tree09b621ffdd50e3f9159a4d1ac3141c2abe954544
parentb67675e41a3feb7fc52a0a0cf608baf14f4770fd (diff)
downloadaur-1ba2e612ebf5b5408b82f36822713bf869091a64.tar.gz
Check distribution
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b91cc82591af..54de9f7be943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = gcc9-bin
pkgdesc = The GNU Compiler Collection (series 9.x)
pkgver = 9.5.0_1ubuntu3
pkgrel = 2
- url = https://packages.ubuntu.com/kinetic/g++-9
+ url = https://packages.ubuntu.com/lunar/g++-9
arch = x86_64
arch = aarch64
license = GPL
@@ -12,7 +12,11 @@ pkgbase = gcc9-bin
depends = libisl
provides = gcc9
conflicts = gcc9
- noextract = *.deb
+ noextract = cpp-9_9.5.0-1ubuntu3_arm64.deb
+ noextract = g++-9_9.5.0-1ubuntu3_arm64.deb
+ noextract = gcc-9_9.5.0-1ubuntu3_arm64.deb
+ noextract = libgcc-9-dev_9.5.0-1ubuntu3_arm64.deb
+ noextract = libstdc++-9-dev_9.5.0-1ubuntu3_arm64.deb
source = http://ports.ubuntu.com/pool/universe/g/gcc-9/cpp-9_9.5.0-1ubuntu3_arm64.deb
source = http://ports.ubuntu.com/pool/universe/g/gcc-9/g++-9_9.5.0-1ubuntu3_arm64.deb
source = http://ports.ubuntu.com/pool/universe/g/gcc-9/gcc-9_9.5.0-1ubuntu3_arm64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 7e549ec648b7..bdb7264324cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
pkgname=gcc9-bin
pkgver=9.5.0_1ubuntu3
-_pkgver=`curl -s --retry 5 https://packages.ubuntu.com/kinetic/gcc-9|grep Package:|cut -d\( -f2|cut -d\) -f1|tr - _`
+_web=https://packages.ubuntu.com
+_dist=`curl -sL --retry 5 $_web/g++-9\&exact=1|grep resultlink|cut -d\" -f2|tail -1`
+_pkgver=`curl -s --retry 5 $_web/$_dist/g++-9|grep Package:|cut -d\( -f2|cut -d\) -f1|tr - _`
pkgrel=2
pkgdesc="The GNU Compiler Collection (series 9.x)"
arch=(x86_64 aarch64)
_arch=`uname -m|sed s/x86_/amd/\;s/arch/rm/`
-url=https://packages.ubuntu.com/kinetic/g++-9
+url=$_web/$_dist/g++-9
license=({,L}GPL FDL custom)
depends=(libisl)
provides=(gcc9)
conflicts=(gcc9)
source=(http://`[ $_arch = amd64 ] && echo archive.ubuntu.com/ubuntu || echo ports.ubuntu.com`/pool/universe/g/gcc-9/{{cpp,g++,gcc}-9,lib{gcc,stdc++}-9-dev}_${_pkgver/_/-}_$_arch.deb)
noextract=(*.deb)
-md5sums=($(for I in {{cpp,g++,gcc}-9,lib{gcc,stdc++}-9-dev};do curl -s --retry 5 https://packages.ubuntu.com/kinetic/$_arch/$I/download|grep MD5|cut -d\> -f6|cut -d\< -f1;done))
+md5sums=($(for I in {{cpp,g++,gcc}-9,lib{gcc,stdc++}-9-dev};do curl -s --retry 5 $_web/$_dist/$_arch/$I/download|grep MD5|cut -d\> -f6|cut -d\< -f1;done))
pkgver(){
echo $_pkgver
}