summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002023-11-30 14:49:21 +0100
committermyself6002023-11-30 14:49:21 +0100
commitb35904b721790e3ddb462347be25b81c2f2325df (patch)
tree8e5f658146deae7eda540130bdb09f672c937205
parent1ba2e612ebf5b5408b82f36822713bf869091a64 (diff)
downloadaur-b35904b721790e3ddb462347be25b81c2f2325df.tar.gz
Add gfortran, split gcc/g++, fix aarch64
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD60
2 files changed, 72 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54de9f7be943..9f8d145f7e5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,43 @@
pkgbase = gcc9-bin
- pkgdesc = The GNU Compiler Collection (series 9.x)
- pkgver = 9.5.0_1ubuntu3
- pkgrel = 2
- url = https://packages.ubuntu.com/lunar/g++-9
+ pkgdesc = The GNU Compiler Collection - C frontend (series 9.x)
+ pkgver = 9.5.0_3ubuntu1
+ pkgrel = 1
+ url = https://packages.ubuntu.com/lunar/source/gcc-9
arch = x86_64
arch = aarch64
license = GPL
license = LGPL
license = FDL
license = custom
+ noextract = cpp-9_9.5.0-3ubuntu1_arm64.deb
+ noextract = gcc-9_9.5.0-3ubuntu1_arm64.deb
+ noextract = libgcc-9-dev_9.5.0-3ubuntu1_arm64.deb
+ noextract = g++-9_9.5.0-3ubuntu1_arm64.deb
+ noextract = libstdc++-9-dev_9.5.0-3ubuntu1_arm64.deb
+ noextract = gfortran-9_9.5.0-3ubuntu1_arm64.deb
+ source = http://ports.ubuntu.com/pool/universe/g/gcc-9/cpp-9_9.5.0-3ubuntu1_arm64.deb
+ source = http://ports.ubuntu.com/pool/universe/g/gcc-9/gcc-9_9.5.0-3ubuntu1_arm64.deb
+ source = http://ports.ubuntu.com/pool/universe/g/gcc-9/libgcc-9-dev_9.5.0-3ubuntu1_arm64.deb
+ source = http://ports.ubuntu.com/pool/universe/g/gcc-9/g++-9_9.5.0-3ubuntu1_arm64.deb
+ source = http://ports.ubuntu.com/pool/universe/g/gcc-9/libstdc++-9-dev_9.5.0-3ubuntu1_arm64.deb
+ source = http://ports.ubuntu.com/pool/universe/g/gcc-9/gfortran-9_9.5.0-3ubuntu1_arm64.deb
+ sha256sums = 913fac987229d6eae7387bb31bc5813d86efd8f6b0ea1bad5b731589df9ce08c
+ sha256sums = c18a03d2b309199f8eb21730244b2a15e6580800d35e6c25354f28413c45b3e7
+ sha256sums = d33b63abf92587e674bae3603db9e09542e3442a842cbb6b1d4bb28b50beef17
+ sha256sums = 6d1f73789c7f1e8a482ae52740d760e4c66859c2ba5a6feddbfa6a62099c963a
+ sha256sums = d2dfc6f615661a58faace56cf33d7a50b5dd25f4ceb10cb5df535352441b0d83
+ sha256sums = ba172ba744e237fefc94144e4949c82524922fca1ac29cc8ba47c5f64e59f066
+
+pkgname = gcc9-bin
depends = libisl
provides = gcc9
conflicts = gcc9
- noextract = cpp-9_9.5.0-1ubuntu3_arm64.deb
- noextract = g++-9_9.5.0-1ubuntu3_arm64.deb
- noextract = gcc-9_9.5.0-1ubuntu3_arm64.deb
- noextract = libgcc-9-dev_9.5.0-1ubuntu3_arm64.deb
- noextract = libstdc++-9-dev_9.5.0-1ubuntu3_arm64.deb
- source = http://ports.ubuntu.com/pool/universe/g/gcc-9/cpp-9_9.5.0-1ubuntu3_arm64.deb
- source = http://ports.ubuntu.com/pool/universe/g/gcc-9/g++-9_9.5.0-1ubuntu3_arm64.deb
- source = http://ports.ubuntu.com/pool/universe/g/gcc-9/gcc-9_9.5.0-1ubuntu3_arm64.deb
- source = http://ports.ubuntu.com/pool/universe/g/gcc-9/libgcc-9-dev_9.5.0-1ubuntu3_arm64.deb
- source = http://ports.ubuntu.com/pool/universe/g/gcc-9/libstdc++-9-dev_9.5.0-1ubuntu3_arm64.deb
- md5sums = 2cc44d2b7c98ba2aa36daed0196fcfd4
- md5sums = cc7aee9ed4c6c6e0e7da7b79cf6420fb
- md5sums = bb62f45a6ef6864b073eafcb2d1ab989
- md5sums = d9f4bb881faef5b5d5e6bf10e6290acc
- md5sums = e7e3c3c4369644978015f61514ac5cb4
-pkgname = gcc9-bin
+pkgname = g++9-bin
+ pkgdesc = The GNU Compiler Collection - C++ frontend (series 9.x)
+ depends = gcc9-bin
+
+pkgname = gfortran9-bin
+ pkgdesc = Fortran front-end for GCC (series 9.x)
+ depends = gcc9-bin
+ conflicts = gcc9-fortran
diff --git a/PKGBUILD b/PKGBUILD
index bdb7264324cd..59d5e5690b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,48 @@
-pkgname=gcc9-bin
-pkgver=9.5.0_1ubuntu3
+pkgbase=gcc9-bin
+pkgname=(g{cc,++,fortran}9-bin)
+pkgver=9.5.0_3ubuntu1
+_arch=`uname -m|sed s/x86_/amd/\;s/arch/rm/`
_web=https://packages.ubuntu.com
-_dist=`curl -sL --retry 5 $_web/g++-9\&exact=1|grep resultlink|cut -d\" -f2|tail -1`
-_pkgver=`curl -s --retry 5 $_web/$_dist/g++-9|grep Package:|cut -d\( -f2|cut -d\) -f1|tr - _`
-pkgrel=2
-pkgdesc="The GNU Compiler Collection (series 9.x)"
+_curl(){
+ curl -LsS --retry 3 $_web/$1
+}
+[ $_dist. = . ] && _dist=`[ $_arch = amd64 ] && _curl gcc-9\&exact=1|grep resultlink|cut -d\" -f2|tail -1 || echo lunar` # mantic needs glibc 2.38
+[ $_pkgver. = . ] && _pkgver=`_curl $_dist/gcc-9|grep Package:|cut -d\( -f2|cut -d\) -f1`
+pkgrel=1
+pkgdesc='The GNU Compiler Collection - C frontend (series 9.x)'
arch=(x86_64 aarch64)
-_arch=`uname -m|sed s/x86_/amd/\;s/arch/rm/`
-url=$_web/$_dist/g++-9
+url=$_web/$_dist/source/gcc-9
license=({,L}GPL FDL custom)
-depends=(libisl)
-provides=(gcc9)
-conflicts=(gcc9)
-source=(http://`[ $_arch = amd64 ] && echo archive.ubuntu.com/ubuntu || echo ports.ubuntu.com`/pool/universe/g/gcc-9/{{cpp,g++,gcc}-9,lib{gcc,stdc++}-9-dev}_${_pkgver/_/-}_$_arch.deb)
-noextract=(*.deb)
-md5sums=($(for I in {{cpp,g++,gcc}-9,lib{gcc,stdc++}-9-dev};do curl -s --retry 5 $_web/$_dist/$_arch/$I/download|grep MD5|cut -d\> -f6|cut -d\< -f1;done))
+_pkgs='cpp-9 gcc-9 libgcc-9-dev'
+_pkgs2=g++-9\ libstdc++-9-dev
+_pkgs3=gfortran-9
+source=(`for _i in $_pkgs{,2,3};do echo http://$([ $_arch = amd64 ] && echo archive.ubuntu.com/ubuntu ||
+ echo ports.ubuntu.com)/pool/universe/g/gcc-9/${_i}_${_pkgver}_$_arch.deb;done`)
+noextract=(${source[@]##*/})
+sha256sums=(`for _i in $_pkgs{,2,3};do _curl $_dist/$_arch/$_i/download|grep SHA256|cut -d\> -f6|cut -d\< -f1;done`)
pkgver(){
- echo $_pkgver
+ echo ${_pkgver/-/_}
}
-build(){
- for I in *.deb;do bsdtar xfO $I data.tar.zst|bsdtar xf - --exclude=usr/share/{lintian,doc/{{cpp,g++,gcc}-9,lib{gcc,stdc++}-9-dev}};done
- rm -fr usr/share/doc/gcc9-bin
+_package(){
+ for _i in $@;do bsdtar xfO ${_i}_${_pkgver}_$_arch.deb data.tar.*|bsdtar xf - `for _i in $(echo $@|tr \ '\n'|sed s,^,doc/,) lintian
+ do echo --exclude=usr/share/$_i;done`;done
mv usr/share/doc/gcc{-9-base,9-bin}
+ mv usr "$pkgdir"
+}
+package_gcc9-bin(){
+ depends=(libisl)
+ provides=(gcc9)
+ conflicts=(gcc9)
+ _package $_pkgs
+}
+package_g++9-bin(){
+ pkgdesc=${pkgdesc/C /C++ }
+ depends=(gcc9-bin)
+ _package $_pkgs2
}
-package(){
- cp -r usr "$pkgdir"
+package_gfortran9-bin(){
+ pkgdesc='Fortran front-end for GCC (series 9.x)'
+ depends=(gcc9-bin)
+ conflicts=(gcc9-fortran)
+ _package $_pkgs3
}