summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Lansdowne2023-01-17 23:23:53 +0000
committerJoseph Lansdowne2023-01-17 23:23:53 +0000
commit6736076432866ace29e65c9f8ccf69025cab250e (patch)
tree93580e076794dc42ec3c7c22594ec1e8ef74ec65
parentc69205e1ac6d5a7b0cb771fb1695a2fded645df2 (diff)
downloadaur-6736076432866ace29e65c9f8ccf69025cab250e.tar.gz
gcedit 0.4.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc5b9ba47305..26501bcade13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = gcedit
pkgdesc = GameCube disk image editor
- pkgver = 0.4.2
+ pkgver = 0.4.3
pkgrel = 1
url = http://ikn.org.uk/app/gcedit
arch = any
license = GPL3
depends = python>=3.2
- depends = python-gobject
- source = https://launchpad.net/gcedit/trunk/0.4.2/+download/gcedit-0.4.2.tar.gz
- md5sums = 9ea7e502cca9555a09fa0d695a87e7e5
+ depends = python-gobject>=3.11
+ source = https://launchpad.net/gcedit/trunk/0.4.3/+download/gcedit-0.4.3.tar.gz
+ sha256sums = 44762ef524db10fac0a00f4e75c16dc34f7113a6c0a9ebe7d8ca38bee51fa314
pkgname = gcedit
-
diff --git a/PKGBUILD b/PKGBUILD
index 59604d04a5f9..507f27eec164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Joseph Lansdowne <J49137@gmail.com>
pkgname=gcedit
-pkgver=0.4.2
+pkgver=0.4.3
pkgrel=1
pkgdesc="GameCube disk image editor"
arch=(any)
url=http://ikn.org.uk/app/gcedit
license=(GPL3)
-depends=("python>=3.2" python-gobject)
+depends=("python>=3.2" "python-gobject>=3.11")
source=(https://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz)
-md5sums=('9ea7e502cca9555a09fa0d695a87e7e5')
+sha256sums=('44762ef524db10fac0a00f4e75c16dc34f7113a6c0a9ebe7d8ca38bee51fa314')
build () {
cd "$srcdir/${pkgname}-$pkgver"
- ./configure
make
}
package () {
cd "$srcdir/${pkgname}-$pkgver"
- make DESTDIR="$pkgdir" prefix=/usr install
+ local python_path="$(./get_python_lib "$pkgdir/usr")"
+ PYTHONPATH="$PYTHONPATH:$python_path" \
+ make DESTDIR="$pkgdir" prefix=/usr install
}