summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevninja2016-04-18 12:53:23 -0400
committerdevninja2016-04-18 12:53:23 -0400
commit6d624ded1742e71f92af3b13adc6408305916c9a (patch)
tree4d4c7730ae3756da2ef79c7f321390b2a66c9ce1
downloadaur-6d624ded1742e71f92af3b13adc6408305916c9a.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD78
-rw-r--r--gcipher-1.1.tar.gzbin0 -> 20137 bytes
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..292d286665ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Apr 18 16:53:08 UTC 2016
+pkgbase = gcipher
+ pkgdesc = Encode/Decode Caeser, Vignere, and ROT13 ciphers
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://gcipher.sourceforge.net/
+ arch = any
+ license = any
+ makedepends = python2
+ makedepends = gzip
+ depends = python2
+ depends = libglade
+ source = gcipher-1.1.tar.gz
+ sha256sums = 2f55367bd837baa614779ec9b5aca76c8b1f0866bd648b4bd30fe7db15cd3a7b
+
+pkgname = gcipher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c11c328725f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+
+# This program encrypts/decrypts Caeser, ROT13 and Vigenere ciphers.
+# These are classic pre-computer ciphers and while vignere is the most "secure".
+# All of them can be easily broken, and none of them are secure. However:
+
+# They are all still widely used for fun, and in contests where a contestant
+# with low to moderate skill is expected to crack a code in short order.
+
+# port of redhat package
+
+pkgname=gcipher
+pkgver=1.1
+pkgrel=1
+pkgdesc="Encode/Decode Caeser, Vignere, and ROT13 ciphers"
+arch=('any')
+url="http://gcipher.sourceforge.net/"
+license=('any')
+depends=('python2' 'libglade')
+makedepends=('python2' 'gzip')
+source=("$pkgname-$pkgver.tar.gz")
+sha256sums=('2f55367bd837baa614779ec9b5aca76c8b1f0866bd648b4bd30fe7db15cd3a7b')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ local line
+ local replace
+
+ # script uses python2, which is not default anymore
+ sed -i 's/python/python2/' src/gcipher
+
+ #uncomment the library path designed for installed packages.
+ line='# sys.path.append("\/usr\/share\/gcipher\/lib")'
+ sed -i "/${line}/ s/# *//" src/gcipher
+
+ # change GLADEDIR. needed if the script is run from a diffrent location than
+ # the library
+ line='GLADEDIR = "."'
+ replace='GLADEDIR = "\/usr\/share\/gcipher\/lib"'
+ sed -i "s/${line}/${replace}/" src/Const.py
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ python2 /usr/lib/python2.7/compileall.py src
+ gzip gcipher.1
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p \
+ ${pkgdir}/usr/bin \
+ ${pkgdir}/usr/share/applications \
+ ${pkgdir}/usr/share/man/man1 \
+ ${pkgdir}/usr/share/gcipher/lib/cipher \
+ ${pkgdir}/usr/share/gcipher/lib/ciphergui \
+ ${pkgdir}/usr/share/gcipher/plugins/cipher \
+ ${pkgdir}/usr/share/gcipher/plugins/ciphergui
+ install -m 644 gcipher.1.gz "${pkgdir}/usr/share/man/man1"
+
+ cd src
+ install -m 755 gcipher "${pkgdir}/usr/bin/gcipher"
+ install -m 644 gcipher.desktop "${pkgdir}/usr/share/applications/gcipher.desktop"
+ install -m 644 *.py *.pyc *.glade "${pkgdir}/usr/share/gcipher/lib"
+
+ cd cipher
+ install -m 644 *.py *.pyc "${pkgdir}/usr/share/gcipher/lib/cipher"
+
+ cd ../ciphergui
+ install -m 644 *.py *.pyc *.glade "${pkgdir}/usr/share/gcipher/lib/ciphergui"
+
+ cd ../../plugins/cipher
+ install -m 644 *.py "${pkgdir}/usr/share/gcipher/plugins/cipher"
+
+ cd ../ciphergui
+ install -m 644 *.py "${pkgdir}/usr/share/gcipher/plugins/ciphergui"
+}
+
diff --git a/gcipher-1.1.tar.gz b/gcipher-1.1.tar.gz
new file mode 100644
index 000000000000..61596d8aeaa8
--- /dev/null
+++ b/gcipher-1.1.tar.gz
Binary files differ