summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlec Snyder2019-02-25 19:27:58 -0800
committerAlec Snyder2019-02-25 19:27:58 -0800
commit0e89cf4d42b89a08adc2d65cf919b1b671d6cb2e (patch)
tree1ffc43cd1d4b4c276d81ded12a3a26ef6b5f0b5f
downloadaur-0e89cf4d42b89a08adc2d65cf919b1b671d6cb2e.tar.gz
gclone: init at v0.5.0
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
-rw-r--r--gclone.install29
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7718f4cd1b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gclone
+ pkgdesc = A git-based project helper
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/allonsy/gclone
+ install = gclone.install
+ arch = x86_64
+ license = MIT
+ depends = git
+ source = gclone::https://github.com/allonsy/gclone/releases/download/v0.5.0/gclone-bin-linux-v0.5.0
+ source = https://github.com/allonsy/gclone/releases/download/v0.5.0/gclone.fish
+ source = https://github.com/allonsy/gclone/releases/download/v0.5.0/_gclone
+ source = https://raw.githubusercontent.com/allonsy/gclone/master/LICENSE
+ sha256sums = 1ebc38ff0096cbee81636b226bd73864b89446b00a82ace7f961c69120cf1d53
+ sha256sums = 610dc043b1a44e4037a7f12b3e8667fc95baec4afed4dcf54dfade5822b0016e
+ sha256sums = 37aad94a217fef36960d9e0068cb7075d22e382b8819489c6681433c0a721d40
+ sha256sums = 42b152633a50a3618415203384e4e4e31e3388dffb4fad3fb753019ad31bc73b
+
+pkgname = gclone
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..30d74d258442
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+test \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c23573aa383
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Allonsy < linuxbash8 [at@at] gmail [dot.dot] com >
+pkgname=gclone
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="A git-based project helper"
+url="https://github.com/allonsy/gclone"
+arch=('x86_64')
+license=('MIT')
+depends=('git')
+install=$pkgname.install
+source=("$pkgname"::"https://github.com/allonsy/gclone/releases/download/v$pkgver/gclone-bin-linux-v$pkgver"
+ "https://github.com/allonsy/gclone/releases/download/v$pkgver/gclone.fish"
+ "https://github.com/allonsy/gclone/releases/download/v$pkgver/_gclone"
+ "https://raw.githubusercontent.com/allonsy/gclone/master/LICENSE")
+sha256sums=('1ebc38ff0096cbee81636b226bd73864b89446b00a82ace7f961c69120cf1d53'
+ '610dc043b1a44e4037a7f12b3e8667fc95baec4afed4dcf54dfade5822b0016e'
+ '37aad94a217fef36960d9e0068cb7075d22e382b8819489c6681433c0a721d40'
+ '42b152633a50a3618415203384e4e4e31e3388dffb4fad3fb753019ad31bc73b')
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/zsh/functions/Completion/Unix
+ mkdir -p "$pkgdir"/usr/share/fish/vendor_completions.d
+ mkdir -p "$pkgdir"/usr/share/licenses/gclone
+ install -m755 gclone "$pkgdir"/usr/bin/gclone-bin
+ install -m644 _gclone "$pkgdir"/usr/share/zsh/functions/Completion/Unix
+ install -m644 gclone.fish "$pkgdir"/usr/share/fish/vendor_completions.d
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/gclone
+}
diff --git a/gclone.install b/gclone.install
new file mode 100644
index 000000000000..21369b7e6eb9
--- /dev/null
+++ b/gclone.install
@@ -0,0 +1,29 @@
+# Colored makepkg-like functions
+# Shamelessly ripped off of google-chrome's install file
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "you may want to add a function to your shell rc file (~/.bashrc, ~/.zshrc, ~/.config/fish/config.fish)"
+
+ note "for bash/zsh, add the following: "
+ echo 'function gclone {'
+ echo ' cd `gclone-bin $@`'
+ echo '}'
+
+ note "for fish, add the following: "
+ echo 'function gclone'
+ echo ' cd (gclone-bin $argv)'
+ echo 'end'
+}
+