summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Daniel2022-09-25 11:10:51 -0300
committerJoão Daniel2022-09-25 11:10:56 -0300
commit8e268f526f7e8e8607f82db13a7c926fbe21ab5d (patch)
tree8d2e1ca5850e6807c41ef8146aefa4ff47b11a8a
downloadaur-8e268f526f7e8e8607f82db13a7c926fbe21ab5d.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD45
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..667f31841580
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gcommit-git
+ pkgdesc = A git-plugin that eases pair-programming commits
+ pkgver = v0.1.2.r4.g4c66353
+ pkgrel = 1
+ url = https://github.com/jooaodanieel/GCommit
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = libxcrypt
+ source = git+https://github.com/jooaodanieel/GCommit
+ md5sums = SKIP
+
+pkgname = gcommit-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73e43f808786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: João Daniel <jotaf.daniel@gmail.com>
+pkgname=gcommit-git
+pkgver=v0.1.2.r4.g4c66353
+pkgrel=1
+epoch=
+pkgdesc="A git-plugin that eases pair-programming commits"
+arch=(x86_64)
+url="https://github.com/jooaodanieel/GCommit"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(git libxcrypt)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+"$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd GCommit
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd GCommit
+ ./gradlew build
+}
+
+package() {
+ cd GCommit
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -rf * ${pkgdir}/opt/${pkgname}
+ mkdir -p ${pkgdir}/usr/local/bin/git-gcommit
+ cp build/bin/native/releaseExecutable/g-commit.kexe ${pkgdir}/usr/local/bin/git-gcommit
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}