summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2016-05-30 00:42:44 -0600
committerBrian Bidulock2016-05-30 00:42:44 -0600
commit9844b3d3d6d07d6447fb7b190e868b3b52a52e48 (patch)
tree583fd7affcfbf0e13dff7c5bd2f9f5b9d0dd1e70
parent97d2d8caec20fe9d8ddc3821b55e8ab6b4090f87 (diff)
downloadaur-9844b3d3d6d07d6447fb7b190e868b3b52a52e48.tar.gz
version 3.2.6-4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--gconf-install.hook11
-rw-r--r--gconf-remove.hook10
-rw-r--r--gconf.install5
5 files changed, 39 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5896490cc92..7cf4116a0a12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gconf-gtk2
pkgdesc = A configuration database system compiled for GTK2
pkgver = 3.2.6
- pkgrel = 3
+ pkgrel = 4
url = http://www.gnome.org
install = gconf.install
arch = i686
@@ -17,15 +17,19 @@ pkgbase = gconf-gtk2
depends = gtk2
provides = gconf=3.2.6
conflicts = gconf
- source = http://ftp.gnome.org/pub/gnome/sources/GConf/3.2/GConf-3.2.6.tar.xz
+ source = https://download.gnome.org/sources/GConf/3.2/GConf-3.2.6.tar.xz
source = gconf-merge-schema
source = gconfpkg
source = gconf-reload.patch
+ source = gconf-install.hook
+ source = gconf-remove.hook
source = 01_xml-gettext-domain.patch
sha256sums = 1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c
sha256sums = ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028
sha256sums = bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898
sha256sums = 567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694
+ sha256sums = 2732b2a6b187c5620105a036bde12edee99669605f70cbde56fe5f39619c3dc0
+ sha256sums = 436a65ff290095bc3d35d7d6297cf4d647f61e9f9922cea7ef9f1e251b447ff7
sha256sums = c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8
pkgname = gconf-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 39749ac256c5..3156ee9c31db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 197971 2013-10-30 12:00:18Z allan $
+# $Id: PKGBUILD 266210 2016-04-27 12:18:24Z allan $
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Jan de Groot <jan@archlinux.org>
pkgname=gconf-gtk2
pkgver=3.2.6
-pkgrel=3
+pkgrel=4
pkgdesc="A configuration database system compiled for GTK2"
arch=(i686 x86_64)
license=('LGPL')
@@ -14,15 +14,18 @@ depends=('libxml2' 'polkit' 'libldap' 'dbus-glib' 'gtk2')
makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
install=gconf.install
url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/gnome/sources/GConf/3.2/GConf-$pkgver.tar.xz
+source=(https://download.gnome.org/sources/GConf/3.2/GConf-$pkgver.tar.xz
gconf-merge-schema
gconfpkg
gconf-reload.patch
+ gconf-{install,remove}.hook
01_xml-gettext-domain.patch)
sha256sums=('1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c'
'ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028'
'bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898'
'567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694'
+ '2732b2a6b187c5620105a036bde12edee99669605f70cbde56fe5f39619c3dc0'
+ '436a65ff290095bc3d35d7d6297cf4d647f61e9f9922cea7ef9f1e251b447ff7'
'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8')
prepare() {
@@ -42,7 +45,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/GConf \
- --disable-static --enable-defaults-service --with-gtk=2.0 \
+ --disable-static --enable-defaults-service \
+ --with-gtk=2.0 \
--disable-orbit
make pkglibdir=/usr/lib/GConf
@@ -55,4 +59,7 @@ package() {
install -m755 -d "$pkgdir/etc/gconf/gconf.xml.system"
install -m755 "$srcdir/gconf-merge-schema" "$pkgdir/usr/bin/"
install -m755 "$srcdir/gconfpkg" "$pkgdir/usr/bin/gconfpkg"
+
+ install -dm755 "$pkgdir"/usr/share/libalpm/hooks/
+ install -m644 "$srcdir"/gconf-{install,remove}.hook "$pkgdir"/usr/share/libalpm/hooks/
}
diff --git a/gconf-install.hook b/gconf-install.hook
new file mode 100644
index 000000000000..999185458bf4
--- /dev/null
+++ b/gconf-install.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = usr/share/gconf/schemas/*.schemas
+
+[Action]
+Description = Installing GConf schemas...
+When = PostTransaction
+Exec = /bin/bash -c 'while read -r f; do f=$(basename "$f" .schemas); /usr/bin/gconfpkg --install $f; done'
+NeedsTargets
diff --git a/gconf-remove.hook b/gconf-remove.hook
new file mode 100644
index 000000000000..8206d1e29d83
--- /dev/null
+++ b/gconf-remove.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = File
+Operation = Remove
+Target = usr/share/gconf/schemas/*.schemas
+
+[Action]
+Description = Uninstalling GConf schemas...
+When = PreTransaction
+Exec = /bin/bash -c 'while read -r f; do f=$(basename "$f" .schemas); /usr/bin/gconfpkg --uninstall $f; done'
+NeedsTargets
diff --git a/gconf.install b/gconf.install
index f7945d165612..a5ea777a5870 100644
--- a/gconf.install
+++ b/gconf.install
@@ -9,10 +9,7 @@ post_upgrade() {
chmod 755 etc/gconf/gconf.xml.system
usr/bin/gio-querymodules usr/lib/gio/modules
- PID=`pidof gconfd-2`
- if [ ! -z "${PID}" ]; then
- kill ${PID}
- fi
+ pkill /usr/lib/GConf/gconfd-2 || return 0
}
post_remove() {