summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmalyshev2016-10-10 23:48:20 +0300
committerkmalyshev2016-10-10 23:54:57 +0300
commitadc5b9bb0eb990a6b1202b3cb95eaa5c885a0463 (patch)
treeaa6986e72464cf4ed8c5d5c5be1b2022e9902562
downloadaur-adc5b9bb0eb990a6b1202b3cb95eaa5c885a0463.tar.gz
initial no-gtk version
-rw-r--r--.SRCINFO28
-rw-r--r--10-gcr.conf3
-rw-r--r--PKGBUILD53
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c7963aaf4a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Mon Oct 10 20:48:02 UTC 2016
+pkgbase = gcr-nogtk
+ pkgdesc = A library for bits of crypto UI and parsing
+ pkgver = 3.20.0
+ pkgrel = 2
+ url = https://git.gnome.org/browse/gcr
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ makedepends = gobject-introspection
+ makedepends = python
+ makedepends = vala
+ makedepends = libxslt
+ depends = dconf
+ depends = libgcrypt
+ depends = p11-kit
+ provides = gvfs
+ conflicts = gvfs
+ options = !makeflags
+ source = http://download.gnome.org/sources/gcr-nogtk/3.20/gcr-nogtk-3.20.0.tar.xz
+ source = 10-gcr.conf
+ sha256sums = 90572c626d8a708225560c42b4421f7941315247fa1679d4ef569bde7f4bb379
+ sha256sums = 5f2eda7175ae9f23ee0e09d2beceb24fd2f6daafd7bddfcc1c1f5a3734eb60fc
+
+pkgname = gcr-nogtk
+
diff --git a/10-gcr.conf b/10-gcr.conf
new file mode 100644
index 000000000000..0394220f9ba2
--- /dev/null
+++ b/10-gcr.conf
@@ -0,0 +1,3 @@
+@users - memlock 1024
+
+# vim:set ft=limits:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb019a5d687d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 272552 2016-07-28 08:50:18Z heftig $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=gcr-nogtk
+pkgver=3.20.0
+pkgrel=2
+pkgdesc="A library for bits of crypto UI and parsing"
+arch=(i686 x86_64)
+url="https://git.gnome.org/browse/gcr"
+license=('GPL2')
+depends=('dconf' 'libgcrypt' 'p11-kit')
+makedepends=('intltool' 'gobject-introspection' 'python' 'vala' 'libxslt')
+options=('!makeflags')
+source=(http://download.gnome.org/sources/gcr/${pkgver:0:4}/gcr-$pkgver.tar.xz
+ 10-gcr.conf)
+sha256sums=('90572c626d8a708225560c42b4421f7941315247fa1679d4ef569bde7f4bb379'
+ '5f2eda7175ae9f23ee0e09d2beceb24fd2f6daafd7bddfcc1c1f5a3734eb60fc')
+provides=(gcr)
+conflicts=(gcr)
+
+prepare() {
+ mkdir -p path
+ ln -f -s /usr/bin/python2 path/python
+}
+
+build() {
+ cd "gcr-$pkgver"
+ ./configure --prefix=/usr \
+ --libexec=/usr/lib/gcr \
+ --disable-static \
+ --disable-update-mime \
+ --disable-schemas-compile \
+ --without-gtk
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ cd "gcr-$pkgver"
+ PATH="$srcdir/path:$PATH" dbus-run-session make -k check || :
+}
+
+package() {
+ cd "gcr-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ # gcr wants to lock some memory to prevent swapping out private keys
+ # https://bugs.archlinux.org/task/32616
+ # https://bugzilla.gnome.org/show_bug.cgi?id=688161
+ install -Dm644 ../10-gcr.conf "$pkgdir/etc/security/limits.d/10-gcr.conf"
+}
+
+# vim:set ts=2 sw=2 et: