summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2018-11-29 12:13:05 +0900
committeraxionl2018-11-29 12:13:05 +0900
commit2a494336e1ddf514b5912e1880694c4689aa3779 (patch)
treea93059705822a59f2c5e4c3654b34c3b30488474
downloadaur-2a494336e1ddf514b5912e1880694c4689aa3779.tar.gz
[AddPkg] gcsf-bin
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD27
-rw-r--r--gcsf.install5
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c94173398d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = gcsf-bin
+ pkgdesc = a FUSE file system based on Google Drive (Written by Rust)
+ pkgver = 0.1.18
+ pkgrel = 1
+ url = https://github.com/harababurel/gcsf
+ install = gcsf.install
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = rust
+ depends = fuse2
+ depends = openssl-1.0
+ optdepends = ranger: A simple, vim-like file manager
+ provides = gcsf
+ conflicts = gcsf-git
+ conflicts = gcsf
+ source = gcsf-bin-0.1.18.tar.gz::https://github.com/harababurel/gcsf/releases/download/0.1.18/gcsf-0.1.18-x86_64-unknown-linux-gnu.tar.gz
+ source = gcsf.install
+ source = https://raw.githubusercontent.com/harababurel/gcsf/master/LICENSE
+ sha256sums = bbdf4613b10ffed329f341471bf793897e5f3d6dd9ac192e918300317810a82a
+ sha256sums = 379c996c9cf50bfffdd381d1f9f99695b1af5bab17b0ccd14006999d6e0351c1
+ sha256sums = b0925ed614686ab9bfc429f9403e15db176949e0c6cb7473b6a2a8278f672d68
+
+pkgname = gcsf-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9ef2f4865f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ariel AxionL <axionl@aosc.io>
+pkgname=gcsf-bin
+pkgver=0.1.18
+pkgrel=1
+pkgdesc="a FUSE file system based on Google Drive (Written by Rust)"
+arch=('x86_64')
+depends=('fuse2' 'openssl-1.0')
+makedepends=('git' 'rust')
+optdepends=("ranger: A simple, vim-like file manager")
+conflicts=("gcsf-git" "gcsf")
+provides=("gcsf")
+url="https://github.com/harababurel/gcsf"
+license=('MIT')
+install="gcsf.install"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/harababurel/gcsf/releases/download/${pkgver}/gcsf-${pkgver}-x86_64-unknown-linux-gnu.tar.gz"
+ "gcsf.install"
+ "https://raw.githubusercontent.com/harababurel/gcsf/master/LICENSE")
+
+sha256sums=('bbdf4613b10ffed329f341471bf793897e5f3d6dd9ac192e918300317810a82a'
+ '379c996c9cf50bfffdd381d1f9f99695b1af5bab17b0ccd14006999d6e0351c1'
+ 'b0925ed614686ab9bfc429f9403e15db176949e0c6cb7473b6a2a8278f672d68')
+package() {
+ cd ${srcdir}
+ install -Dm755 ./gcsf ${pkgdir}/usr/bin/gcsf
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+# vim set: ts=4 sw=4 et
diff --git a/gcsf.install b/gcsf.install
new file mode 100644
index 000000000000..233188b97a72
--- /dev/null
+++ b/gcsf.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "If you want to use GCSF as a normal user."
+ echo "You should uncomment the 'user_allow_other' on '/etc/fuse.conf'."
+ echo "Url: https://github.com/harababurel/gcsf"
+}