summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortammert2021-02-24 22:48:18 +0100
committertammert2021-02-24 22:48:18 +0100
commit51ca0b90ba0b3e32034f50de9f873bb8a12e84d3 (patch)
tree373142d4ff0ccb01ec7d9f4b4e90973e4bf0945b
parent7e6738bd69a0554b1e03b067ad857b45df348dde (diff)
downloadaur-51ca0b90ba0b3e32034f50de9f873bb8a12e84d3.tar.gz
Fixed build error, no more GOPATH needed due to go.mod
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2d644d8cab9..9bf29b65e53d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcsfuse
pkgdesc = A user-space file system for interacting with Google Cloud Storage
pkgver = 0.33.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/GoogleCloudPlatform/gcsfuse
arch = x86_64
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index f7ffcedc5aad..61ee345419f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gcsfuse
pkgver=0.33.2
-pkgrel=1
+pkgrel=2
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
arch=('x86_64')
@@ -17,21 +17,15 @@ source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archiv
sha256sums=('242d4905613345d4a839b3bad2521596f7bf0e20c8dd5a1f3a6c053376508c6e')
_gourl=github.com/googlecloudplatform/gcsfuse
-prepare() {
- export GOPATH="$srcdir/go"
- mkdir -p "$GOPATH/src/$(dirname $_gourl)"
- ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_gourl"
-}
-
build() {
- export GOPATH="$srcdir/go"
+ cd "${srcdir}/${pkgname}-${pkgver}"
go build "$_gourl"
CGO_ENABLED=1 go build -buildmode=pie -o "mount.gcsfuse" "$_gourl/tools/mount_gcsfuse"
}
package() {
- install -Dm 755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
- install -Dm 755 mount.gcsfuse "${pkgdir}/usr/bin/mount.gcsfuse"
+ install -Dm 755 "${srcdir}/${pkgname}-${pkgver}/gcsfuse" "${pkgdir}/usr/bin/gcsfuse"
+ install -Dm 755 "${srcdir}/${pkgname}-${pkgver}/mount.gcsfuse" "${pkgdir}/usr/bin/mount.gcsfuse"
cd "${pkgdir}/usr/bin" && ln -s mount.gcsfuse mount.fuse.gcsfuse
}