summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortammert2020-12-21 10:09:20 +0100
committertammert2020-12-21 10:09:20 +0100
commita02e38c1f84eee4f3671b2811cb66111fb402415 (patch)
tree9062eb896541a8ffd85bd7ebb08e42bb50ddcbc4
parent2f7d8fd5afc6aaae378f9af0011fc56b5ec969cd (diff)
downloadaur-a02e38c1f84eee4f3671b2811cb66111fb402415.tar.gz
Upgraded to 0.32.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0609d8c33290..a782d74c9967 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gcsfuse
pkgdesc = A user-space file system for interacting with Google Cloud Storage
- pkgver = 0.29.0
- pkgrel = 4
+ pkgver = 0.32.0
+ pkgrel = 1
url = https://github.com/GoogleCloudPlatform/gcsfuse
arch = x86_64
license = APACHE
makedepends = git
- makedepends = go-pie
+ makedepends = go
depends = glibc
depends = fuse
optdepends = google-cloud-sdk: authentication helper
- source = gcsfuse-0.29.0::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v0.29.0.tar.gz
- sha256sums = 4f994d694a12691b7ea5bd293c50ba4a37bc329cf531780015daf0a5fd265b30
+ source = gcsfuse-0.32.0::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v0.32.0.tar.gz
+ sha256sums = b509f55de799aba6bbc1f81d6e4c1495b09644872211e5fd8805b5e0e174ed84
pkgname = gcsfuse
diff --git a/PKGBUILD b/PKGBUILD
index fb784a9d3add..0d64a5a0be58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
-# Maintainer: stocki <mail at firstname lastname dot de>
+# Maintainer: Sebastiaan Tammer <sebastiaantammer at gmail dot com>
+# Contributor: stocki <mail at firstname lastname dot de>
# Contributor: aimileus <me at aimileus dot nl>
# Contributor: zfo <zfoofz1@gmail.com>
+
pkgname=gcsfuse
-pkgver=0.29.0
-pkgrel=4
+pkgver=0.32.0
+pkgrel=1
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
arch=('x86_64')
license=('APACHE')
depends=('glibc' 'fuse')
-makedepends=('git' 'go-pie')
+makedepends=('git' 'go')
optdepends=('google-cloud-sdk: authentication helper')
source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v$pkgver.tar.gz")
-sha256sums=('4f994d694a12691b7ea5bd293c50ba4a37bc329cf531780015daf0a5fd265b30')
+sha256sums=('b509f55de799aba6bbc1f81d6e4c1495b09644872211e5fd8805b5e0e174ed84')
_gourl=github.com/googlecloudplatform/gcsfuse
prepare() {
@@ -28,7 +30,8 @@ build() {
}
package() {
- install -Dm755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
- install -Dm755 mount.gcsfuse "${pkgdir}/usr/bin/mount.gcsfuse"
+ install -Dm 755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
+ install -Dm 755 mount.gcsfuse "${pkgdir}/usr/bin/mount.gcsfuse"
cd "${pkgdir}/usr/bin" && ln -s mount.gcsfuse mount.fuse.gcsfuse
}
+