summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 10:01:02 +0200
committerChristian Hesse2015-06-30 10:01:02 +0200
commit0dc0d30d0cc0af2fb92f6405a0830f4f6ffd0aa4 (patch)
treee7f0c84216b18cc6919391c44c8bcd272a07eb8b
downloadaur-0dc0d30d0cc0af2fb92f6405a0830f4f6ffd0aa4.tar.gz
initial import of gcstatistic 2.0.0b7-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
-rw-r--r--gcstatistic12
-rw-r--r--gcstatistic.desktop10
-rw-r--r--gcstatistic.install15
5 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adc5ff2489d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gcstatistic
+ pkgdesc = Geocaching statistics tool
+ pkgver = 2.0.0b7
+ pkgrel = 1
+ url = http://www.macdefender.org/products/GCStatistic/
+ install = gcstatistic.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = imagemagick
+ source = http://www.macdefender.org/downloads/software/beta/GCStatistic2.0.0b7L.zip
+ source = gcstatistic.png::http://macdefender.org/products/GCStatistic/index_files/ic64_gcstatistic.png
+ source = gcstatistic.desktop
+ source = gcstatistic
+ sha256sums = 029c62841c8df2935dcd784dcb45d7b75304aa5a1850afb5842d9731f5839e1f
+ sha256sums = 11ed02bacb65fd7f7048f7e1e8613cf020a896a5c89476bc14f97a34c451f925
+ sha256sums = 1ae76c1cc8bf75f5d65a56f730caa9fe504a447b67c9549fae2465db03b4213f
+ sha256sums = b5bb81bbac97846571a6d34c2e0fdb90633d1f53870d9ec693272c719bd9bf13
+ depends_i686 = gcc-libs
+
+pkgname = gcstatistic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fd5e19a34f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=gcstatistic
+pkgver=2.0.0b7
+pkgrel=1
+pkgdesc='Geocaching statistics tool'
+arch=('i686' 'x86_64')
+url='http://www.macdefender.org/products/GCStatistic/'
+license=('GPL')
+install=gcstatistic.install
+depends_x86_86=('lib32-gcc-libs')
+depends_i686=('gcc-libs')
+makedepends=('imagemagick')
+#source=("http://www.macdefender.org/downloads/software/GCStatistic${pkgver}L.zip"
+source=("http://www.macdefender.org/downloads/software/beta/GCStatistic${pkgver}L.zip"
+ 'gcstatistic.png::http://macdefender.org/products/GCStatistic/index_files/ic64_gcstatistic.png'
+ 'gcstatistic.desktop'
+ 'gcstatistic')
+sha256sums=('029c62841c8df2935dcd784dcb45d7b75304aa5a1850afb5842d9731f5839e1f'
+ '11ed02bacb65fd7f7048f7e1e8613cf020a896a5c89476bc14f97a34c451f925'
+ '1ae76c1cc8bf75f5d65a56f730caa9fe504a447b67c9549fae2465db03b4213f'
+ 'b5bb81bbac97846571a6d34c2e0fdb90633d1f53870d9ec693272c719bd9bf13')
+
+prepare() {
+ convert -scale 48x48 gcstatistic.png gcstatistic_48.png
+}
+
+package() {
+ #cd "${srcdir}/GCStatistic${pkgver}F/"
+ cd "${srcdir}/GCStatistic${pkgver}/"
+
+ mv 'GCStatistic Libs' 'GCStatistic_Libs'
+ sed -i 's/GCStatistic Libs/GCStatistic_Libs/g' GCStatistic
+
+ for FILE in $(find -type f); do
+ # no permissions here, we take it as is
+ install -D ${FILE} ${pkgdir}/opt/${pkgname}/${FILE#./}
+ done
+
+ install -D -m0755 ${srcdir}/gcstatistic ${pkgdir}/usr/bin/gcstatistic
+
+ install -D -m0644 ${srcdir}/gcstatistic.png ${pkgdir}/usr/share/icons/hicolor/64x64/apps/gcstatistic.png
+ install -D -m0644 ${srcdir}/gcstatistic_48.png ${pkgdir}/usr/share/icons/hicolor/48x48/apps/gcstatistic.png
+
+ install -D -m0644 ${srcdir}/gcstatistic.desktop ${pkgdir}/usr/share/applications/gcstatistic.desktop
+}
+
diff --git a/gcstatistic b/gcstatistic
new file mode 100644
index 000000000000..b647c1744060
--- /dev/null
+++ b/gcstatistic
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+# we need a writeable directory with exec mount option
+cd /tmp
+
+# we want the config file in home directory, so we link it
+if [ ! -e ${HOME}/.GCStatistic.conf ]; then
+ ln -sf ${HOME}/.GCStatistic.conf
+fi
+
+# just execute
+exec /opt/gcstatistic/GCStatistic
diff --git a/gcstatistic.desktop b/gcstatistic.desktop
new file mode 100644
index 000000000000..93928e09c4cd
--- /dev/null
+++ b/gcstatistic.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Terminal=false
+Icon=gcstatistic
+Type=Application
+Categories=Office;
+Exec=gcstatistic
+Name=GCStatistic
+GenericName=GCStatistic
+Comment=Geocaching Statistics Tool
diff --git a/gcstatistic.install b/gcstatistic.install
new file mode 100644
index 000000000000..34d8c65dddfa
--- /dev/null
+++ b/gcstatistic.install
@@ -0,0 +1,15 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+