summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2015-06-08 23:32:11 +0200
committertrya2015-06-08 23:32:11 +0200
commit6b3afe9a5f41ca0540ddab767edf461274a6e804 (patch)
tree279f7f5a0607c58ea8668fc4859c487021e43888
downloadaur-gcube.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f60a2219405
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gcube
+ pkgdesc = A GameCube emulator, part of the devkitPPC project (including various utilities)
+ pkgver = 0.4.0
+ pkgrel = 2
+ url = http://www.devkitpro.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ depends = libgl
+ depends = libjpeg
+ depends = zlib
+ source = http://downloads.sourceforge.net/sourceforge/devkitpro/emulators/gcube%200.4.0/gcube-0.4.0-src.tar.bz2
+ md5sums = 2354b60a9494fe5669addaf915efeda9
+
+pkgname = gcube
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1c07a94c79f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: trya <tryagainprod@gmail.com>
+
+pkgname=gcube
+pkgver=0.4.0
+pkgrel=2
+pkgdesc="A GameCube emulator, part of the devkitPPC project (including various utilities)"
+arch=('i686' 'x86_64')
+url="http://www.devkitpro.org"
+license=('GPL')
+depends=('sdl' 'libgl' 'libjpeg' 'zlib')
+source=("http://downloads.sourceforge.net/sourceforge/devkitpro/emulators/gcube%200.4.0/$pkgname-$pkgver-src.tar.bz2")
+md5sums=('2354b60a9494fe5669addaf915efeda9')
+
+prepare() {
+ cd "$srcdir/gcube"
+ sed -e 's|LIBS=-lz $(OPENGL)|LIBS=-lm -lz $(OPENGL)|' \
+ -i Makefile.rules
+}
+
+build() {
+ cd "$srcdir/gcube"
+ make
+}
+
+package() {
+ cd "$srcdir/gcube"
+ install -D gcube "$pkgdir/usr/bin/gcube"
+ install -D bin2dol "$pkgdir/usr/bin/bin2dol"
+ install -D gcmap "$pkgdir/usr/bin/gcmap"
+ install -D isopack "$pkgdir/usr/bin/isopack"
+ install -D thpview "$pkgdir/usr/bin/thpview"
+ install -D tplx "$pkgdir/usr/bin/tplx"
+
+ mkdir -p "$pkgdir/usr/share/doc/gcube"
+ cp README README.debug ChangeLog "$pkgdir/usr/share/doc/gcube"
+}