summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaultDon2015-08-19 15:50:20 -0700
committerSaultDon2015-08-19 15:50:20 -0700
commita500ca1bddc2a239859929ad63fea0f05092928f (patch)
tree3b8ca4409db58eb990c669e4ef46706280eb5111
parente5c4e9232faf25111f0b5932d175c8af7b7c9914 (diff)
downloadaur-a500ca1bddc2a239859929ad63fea0f05092928f.tar.gz
Update to 2.0-3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
-rw-r--r--gdal-filegdb.changelog9
-rw-r--r--ogr_perl_2.0.0.diff30
4 files changed, 27 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb4e9845377d..f24807225b7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdal-filegdb
pkgdesc = A translator library for vector and raster geospatial data formats (PDF, FileGDB, KMZ support)
pkgver = 2.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.gdal.org/
changelog = gdal-filegdb.changelog
arch = i686
@@ -36,8 +36,10 @@ pkgbase = gdal-filegdb
depends = opencl-headers
depends = filegdb-api
depends = json-c
- depends = libkml-git
+ depends = jdk7-openjdk
depends = libwebp
+ depends = libkml
+ provides = gdal=2.0
conflicts = gdal
source = gdal-2.0::svn+https://svn.osgeo.org/gdal/branches/2.0/gdal
source = gdal-1.5.1-python-install.patch
diff --git a/PKGBUILD b/PKGBUILD
index 84ab426088d7..994e5bfbc7d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=gdal-filegdb
_pkgname=gdal
_pkgver=2.0
pkgver=2.0
-pkgrel=2
+pkgrel=3
pkgdesc="A translator library for vector and raster geospatial data formats (PDF, FileGDB, KMZ support)"
arch=('i686' 'x86_64')
url="http://www.gdal.org/"
@@ -23,19 +23,21 @@ depends=('geos' 'proj'
'opencl-headers'
'filegdb-api'
'json-c'
- 'libkml-git'
- 'libwebp')
+ 'jdk7-openjdk'
+ 'libwebp'
+ 'libkml')
makedepends=('perl'
'swig'
'chrpath'
'svn'
'doxygen')
changelog=$pkgname.changelog
-source=("$_pkgname-$_pkgver::svn+https://svn.osgeo.org/gdal/branches/$_pkgver/gdal"
+source=("$_pkgname-$_pkgver::svn+https://svn.osgeo.org/gdal/branches/${_pkgver}/gdal"
'gdal-1.5.1-python-install.patch')
-conflicts=("$_pkgname")
md5sums=('SKIP'
'81afc1c26d29cee84aadb6924fe33861')
+provides=("$_pkgname=$_pkgver")
+conflicts=("$_pkgname")
pkgver() {
cd "$_pkgname-$_pkgver"
@@ -44,9 +46,9 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_pkgname-$_pkgver"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
- patch -Np0 -i "$srcdir/gdal-1.5.1-python-install.patch"
+ patch -Np0 -i "${srcdir}"/gdal-1.5.1-python-install.patch
# python2 fixes
sed -i 's_python python1.5_python2 python python1.5_' configure
@@ -59,18 +61,20 @@ prepare() {
}
build() {
- cd "$srcdir/$_pkgname-$_pkgver"
- export CFLAGS="$CFLAGS -fno-strict-aliasing"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
+ export CFLAGS+=" -fno-strict-aliasing"
+ export CPPFLAGS+=" -Dlinux"
# bug 23654
- export LDFLAGS="$LDFLAGS -Wl,--as-needed"
+ export LDFLAGS+=" -Wl,--as-needed"
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \
- --with-geotiff --with-mysql --with-python=/usr/bin/python2 \
+ --with-geotiff --with-mysql=/usr/bin/mysql_config --with-python=/usr/bin/python2 --with-jpeg12 \
--without-libtool --with-curl --with-hdf5 --with-perl --with-geos --with-openjpeg \
--with-png --with-poppler --with-spatialite --with-pcre --without-grass --with-liblzma \
- --with-fgdb=/usr/lib/filegdb-api --with-libkml --with-odbc \
- --with-opencl --with-libjson-c --with-webp \
+ --with-fgdb=/usr --with-odbc --with-libkml \
+ --with-opencl --with-libjson-c --with-mdb=yes --with-webp \
+ --with-java=/usr/lib/jvm/java-7-openjdk --with-jvm-lib=/usr/lib/jvm/java-7-openjdk/jre/lib/amd64/server --with-jvm-lib-add-rpath=yes \
# workaround for bug #13646
sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
@@ -79,6 +83,7 @@ build() {
cd swig/perl
make veryclean
make generate
+# make build
cd ../..
make
@@ -86,13 +91,13 @@ build() {
}
package () {
- cd "$srcdir/$_pkgname-$_pkgver"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
make DESTDIR="${pkgdir}" install
make DESTDIR="${pkgdir}" install-man
# install license
- install -D -m644 LICENSE.TXT "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -D -m644 LICENSE.TXT "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
# FS15477 clean up junks
rm -f "${pkgdir}"/usr/bin/*.dox
diff --git a/gdal-filegdb.changelog b/gdal-filegdb.changelog
index ec6a959c03e1..7de2c95c267d 100644
--- a/gdal-filegdb.changelog
+++ b/gdal-filegdb.changelog
@@ -1,10 +1,7 @@
-2015-07-30 SaultDon <sault.don gmail>
+2015-08-19 SaultDon <sault.don gmail>
* 2.0-2
- * removed unneeded perl patch, fixed in upstream
-
-2015-07-02 SaultDon <sault.don gmail>
- * 2.0-1
- * updated to latest release
+ * updated build to find filegdb-api
+ * removed upstream applied patch for ogr_perl building
2015-03-10 SaultDon <sault.don gmail>
* 1.11.2-1
diff --git a/ogr_perl_2.0.0.diff b/ogr_perl_2.0.0.diff
deleted file mode 100644
index 4f0129d78523..000000000000
--- a/ogr_perl_2.0.0.diff
+++ /dev/null
@@ -1,30 +0,0 @@
---- gdal-2.0/swig/include/perl/ogr_perl.i 2015-06-14 14:49:28.709171956 -0700
-+++ ogr_perl.i 2015-06-14 18:18:39.472605848 -0700
-@@ -109,11 +109,11 @@
-
- }
-
--# wrapped data source methods:
-+// wrapped data source methods:
- %rename (_GetDriver) GetDriver;
- %rename (_TestCapability) TestCapability;
-
--# wrapped layer methods:
-+// wrapped layer methods:
- %rename (_ReleaseResultSet) ReleaseResultSet;
- %rename (_CreateLayer) CreateLayer;
- %rename (_DeleteLayer) DeleteLayer;
-@@ -121,11 +121,11 @@
- %rename (_DeleteField) DeleteField;
- %rename (_Validate) Validate;
-
--# wrapped feature methods:
-+// wrapped feature methods:
- %rename (_AlterFieldDefn) AlterFieldDefn;
- %rename (_SetGeometry) SetGeometry;
-
--# wrapped geometry methods:
-+// wrapped geometry methods:
- %rename (_ExportToWkb) ExportToWkb;
-
- %perlcode %{