summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorggranga2018-05-11 17:33:23 +0200
committerggranga2018-05-11 17:33:23 +0200
commit0439f1609540586d103a829c4cc62f2eafb1df7b (patch)
tree2c4711597be6948e8df5181ee3d6362b6eccf250
parent61e8c6f7079a0a1bf7f4288f33caac366fd25690 (diff)
downloadaur-0439f1609540586d103a829c4cc62f2eafb1df7b.tar.gz
Update GDAL version
-rwxr-xr-x.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fef6e58ccc81..4d8065298ebc 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -48,15 +48,15 @@ pkgname = gdal-hdf4
pkgname = python-gdal-hdf4
pkgdesc = Python bindings for GDAL, with support to HDF4 format
- depends = gdal-hdf4=2.2.4
+ depends = gdal=2.2.4
depends = python-numpy
optdepends =
provides = python-gdal
conflicts = python-gdal
pkgname = python2-gdal-hdf4
- pkgdesc = Python bindings for GDAL, with support to HDF4 format
- depends = gdal-hdf4=2.2.4
+ pkgdesc = Python 2 bindings for GDAL, with support to HDF4 format
+ depends = gdal=2.2.4
depends = python2-numpy
optdepends =
provides = python2-gdal
diff --git a/PKGBUILD b/PKGBUILD
index 0dad6da62501..146f6b106dcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Luigi Ranghetti <ggranga@gmail.com>
-pkgname=gdal-hdf4
+pkgbase=gdal-hdf4
pkgname=(gdal-hdf4 python-gdal-hdf4 python2-gdal-hdf4)
_pkgbase=gdal
_pkgname=(gdal python-gdal python2-gdal)
@@ -92,11 +92,11 @@ package_gdal-hdf4 () {
}
package_python-gdal-hdf4 () {
- pkgdesc="Python bindings for GDAL, with support to HDF4 format"
- depends=("gdal-hdf4=$pkgver" 'python-numpy')
- optdepends=()
provides=(python-gdal)
conflicts=(python-gdal)
+ pkgdesc="Python bindings for GDAL, with support to HDF4 format"
+ depends=("gdal=$pkgver" 'python-numpy')
+ optdepends=()
cd "${srcdir}"/$_pkgbase-$pkgver/swig/python
python3 setup.py install --root="$pkgdir" --optimize=1
@@ -107,11 +107,11 @@ package_python-gdal-hdf4 () {
}
package_python2-gdal-hdf4 () {
- pkgdesc="Python bindings for GDAL, with support to HDF4 format"
- depends=("gdal-hdf4=$pkgver" 'python2-numpy')
- optdepends=()
provides=(python2-gdal)
conflicts=(python2-gdal)
+ pkgdesc="Python 2 bindings for GDAL, with support to HDF4 format"
+ depends=("gdal=$pkgver" 'python2-numpy')
+ optdepends=()
cd "${srcdir}"/$_pkgbase-$pkgver/swig/python