summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuigi Ranghetti2019-07-25 12:08:29 +0200
committerLuigi Ranghetti2019-07-25 12:08:29 +0200
commitbc3b23ece85b32f11cbb389bd6d4be13e43a9686 (patch)
tree96b8bff0d63f640d96ac658d412e134dec04a639
parent2d6793b7d691eb1d6a1734684d422d0fec13ef53 (diff)
downloadaur-bc3b23ece85b32f11cbb389bd6d4be13e43a9686.tar.gz
Update to GDAL version 3.0.0
-rwxr-xr-x.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 14 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3477cfa1e4c7..ef38e6c767ff 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdal-hdf4
pkgdesc = A translator library for raster geospatial data formats, with support to HDF4 format (required to use MODIStsp tool: http://github.com/lbusett/MODIStsp)
- pkgver = 2.3.2
- pkgrel = 8.0
+ pkgver = 3.0.0
+ pkgrel = 2.0
url = http://www.gdal.org/
changelog = gdal-hdf4.changelog
arch = x86_64
@@ -37,18 +37,16 @@ pkgbase = gdal-hdf4
provides = gdal
conflicts = gdal
options = !emptydirs
- source = https://download.osgeo.org/gdal/2.3.2/gdal-2.3.2.tar.xz
- source = gdal-poppler-0.69.0.patch::https://github.com/OSGeo/gdal/commit/69e0701253.patch
+ source = https://download.osgeo.org/gdal/3.0.0/gdal-3.0.0.tar.xz
source = gdal-perl-vendor.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/gdal-perl-vendor.patch?h=packages/gdal
- sha256sums = 3f6d78fe8807d1d6afb7bed27394f19467840a82bc36d65e66316fa0aa9d32a4
- sha256sums = cc63ee56e2c62c994a65723d4124171ce9b4e3499c0958be710c04bf82fd4cf5
- sha256sums = a41a0129a878a0d09b8ecf24b8a0b473856d929d52f535afdf4dca95ddd347d3
+ sha256sums = ad316fa052d94d9606e90b20a514b92b2dd64e3142dfdbd8f10981a5fcd5c43e
+ sha256sums = 2103b98f2f15954f042d5620658b30d703125927bde2e5eb671c5facb6c2f5ed
pkgname = gdal-hdf4
pkgname = python-gdal-hdf4
pkgdesc = Python bindings for GDAL, with support to HDF4 format
- depends = gdal-hdf4=2.3.2
+ depends = gdal-hdf4=3.0.0
depends = python-numpy
optdepends =
provides = python-gdal
@@ -56,7 +54,7 @@ pkgname = python-gdal-hdf4
pkgname = python2-gdal-hdf4
pkgdesc = Python 2 bindings for GDAL, with support to HDF4 format
- depends = gdal-hdf4=2.3.2
+ depends = gdal-hdf4=3.0.0
depends = python2-numpy
optdepends =
provides = python2-gdal
diff --git a/PKGBUILD b/PKGBUILD
index 1ec7c745067b..43957f8fd205 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ _pkgbase=gdal
provides=('gdal')
conflicts=('gdal')
pkgname=('gdal-hdf4' 'python-gdal-hdf4' 'python2-gdal-hdf4')
-pkgver=2.3.2
-pkgrel=8.0
+pkgver=3.0.0
+pkgrel=2.0
pkgdesc="A translator library for raster geospatial data formats, with support to HDF4 format (required to use MODIStsp tool: http://github.com/lbusett/MODIStsp)"
arch=('x86_64')
url="http://www.gdal.org/"
@@ -24,46 +24,30 @@ optdepends=('postgresql: postgresql database support'
options=('!emptydirs')
changelog=$pkgbase.changelog
source=(https://download.osgeo.org/${_pkgbase}/${pkgver}/${_pkgbase}-${pkgver}.tar.xz
- gdal-poppler-0.69.0.patch::https://github.com/OSGeo/gdal/commit/69e0701253.patch
gdal-perl-vendor.patch::https://git.archlinux.org/svntogit/community.git/plain/trunk/gdal-perl-vendor.patch?h=packages/gdal)
-sha256sums=('3f6d78fe8807d1d6afb7bed27394f19467840a82bc36d65e66316fa0aa9d32a4'
- 'cc63ee56e2c62c994a65723d4124171ce9b4e3499c0958be710c04bf82fd4cf5'
- 'a41a0129a878a0d09b8ecf24b8a0b473856d929d52f535afdf4dca95ddd347d3')
+sha256sums=('ad316fa052d94d9606e90b20a514b92b2dd64e3142dfdbd8f10981a5fcd5c43e'
+ '2103b98f2f15954f042d5620658b30d703125927bde2e5eb671c5facb6c2f5ed')
prepare() {
cd "${srcdir}"/$_pkgbase-$pkgver
-# Fix build with poppler >= 0.69.0
- patch -Np2 -i ../gdal-poppler-0.69.0.patch
-# Fix build with poppler 0.72
- find frmts/pdf -type f | xargs sed -e 's|GBool|bool|g' -e 's|gFalse|false|g' -e 's|getCString|c_str|g' -i
-# Fix build with poppler 0.73
- sed -e 's|#include <goo/gtypes.h>|typedef unsigned char Guchar;|' -i frmts/pdf/pdfsdk_headers.h
-
# Fix mandir
sed -i "s|^mandir=.*|mandir='\${prefix}/share/man'|" configure
# Fix Perl bindings installation path
- patch -Np1 -i ../gdal-perl-vendor.patch
+ patch -Np0 -i "${srcdir}"/gdal-perl-vendor.patch
}
build() {
cd "${srcdir}"/$_pkgbase-$pkgver
- export CFLAGS="$CFLAGS -fno-strict-aliasing"
-
-# Ignore const-related errors (remove once fixed upstream)
- CXXFLAGS+=' -fpermissive'
-
-# bug #23654
- export LDFLAGS="$LDFLAGS -Wl,--as-needed"
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 --with-geotiff \
--with-mysql --with-curl --with-hdf5 --with-hdf4=/opt/hdf4 --with-perl --with-geos \
--with-png --with-poppler --with-spatialite --with-openjpeg
# workaround for bug #13646
- sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
- sed -i 's/EXE_DEP_LIBS/KILL_EXE_DEP_LIBS/' apps/GNUmakefile
+# sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
+# sed -i 's/EXE_DEP_LIBS/KILL_EXE_DEP_LIBS/' apps/GNUmakefile
make
make man
@@ -82,9 +66,6 @@ package_gdal-hdf4 () {
# install license
install -Dm644 LICENSE.TXT "${pkgdir}"/usr/share/licenses/$_pkgbase/LICENSE
-#FS15477 clean up junks - still present in 2.2.1
-# rm -f "${pkgdir}"/usr/share/man/man1/_build_gdal_src_gdal-${pkgver}_apps_.1
-
# Remove RPATH
eval local $(perl -V:vendorarch)
chrpath --delete "${pkgdir}"${vendorarch}/auto/Geo/OSR/OSR.so