summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlireza |S.N|2023-06-16 14:30:49 +0330
committerAlireza |S.N|2023-06-16 14:30:49 +0330
commit4183581852f641c728203ad868f3a9fa35bba861 (patch)
tree66997a2ced283b6f9589f46fa6797df2404a83c8
parenta80072b73f2f2457120f119cb3ccc5e90dfbe500 (diff)
downloadaur-4183581852f641c728203ad868f3a9fa35bba861.tar.gz
Fix podofo dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f8812938634..1875b278e4b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -39,7 +39,7 @@ pkgbase = gdal-libkml-filegdb
makedepends = openssl
makedepends = pcre2
makedepends = libpng
- makedepends = podofo
+ makedepends = podofo-0.9
makedepends = poppler
makedepends = postgresql-libs
makedepends = qhull
@@ -96,7 +96,7 @@ pkgname = gdal-libkml-filegdb
optdepends = netcdf: netCDF support
optdepends = openexr: EXR support
optdepends = openjpeg2: JP2 support
- optdepends = podofo: PDF support
+ optdepends = podofo-0.9: PDF support
optdepends = poppler: PDF support
optdepends = postgresql-libs: PostgreSQL support
optdepends = libwebp: WebP support
diff --git a/PKGBUILD b/PKGBUILD
index 67e3af469a66..5f819c64c17e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ makedepends=(cmake opencl-headers python-setuptools python-numpy
proj arrow blosc cfitsio curl crypto++ libdeflate expat libfreexl
libgeotiff geos giflib libheif hdf5 libjpeg-turbo json-c libjxl xz
libxml2 lz4 mariadb-libs netcdf unixodbc ocl-icd openexr openjpeg2
- openssl pcre2 libpng podofo poppler postgresql-libs qhull
+ openssl pcre2 libpng podofo-0.9 poppler postgresql-libs qhull
libspatialite sqlite swig libtiff libwebp xerces-c zlib zstd libkml-git)
# armadillo brunsli lerc libkml rasterlite2 sfcgal tiledb
# ogdi
@@ -27,6 +27,11 @@ source=(https://download.osgeo.org/gdal/${pkgver}/gdal-${pkgver}.tar.xz
sha256sums=('af4b26a6b6b3509ae9ccf1fcc5104f7fe015ef2110f5ba13220816398365adce'
'1a1b5c417224e8a4dfd3f7c1f4d1911febf1de38e9b6f93a1e4523a9fce92a91')
+prepare() {
+ # Fix build with podofo-0.9
+ sed -e 's|podofo.h|podofo/podofo.h|' -i gdal-$pkgver/frmts/pdf/pdfsdk_headers.h
+}
+
build() {
tar xzvf FileGDB_API_1_5_1-64gcc51.tar.gz
cp FileGDB_API-64gcc51/lib/libFileGDBAPI.so libFileGDBAPI_gdal.so
@@ -78,6 +83,8 @@ build() {
-DGDAL_USE_ZSTD=ON \
-DGDAL_USE_LIBKML=ON \
-DGDAL_USE_FileGDB=ON \
+ -DPODOFO_INCLUDE_DIR=/usr/include/podofo-0.9 \
+ -DPODOFO_LIBRARY=/usr/lib/podofo-0.9/libpodofo.so \
-DFileGDB_INCLUDE_DIR=FileGDB_API-64gcc51/include \
-DFileGDB_LIBRARY=libFileGDBAPI_gdal.so && \
make -C build -j $(nproc)
@@ -98,7 +105,7 @@ package_gdal-libkml-filegdb () {
'netcdf: netCDF support'
'openexr: EXR support'
'openjpeg2: JP2 support'
- 'podofo: PDF support'
+ 'podofo-0.9: PDF support'
'poppler: PDF support'
'postgresql-libs: PostgreSQL support'
'libwebp: WebP support')