summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlireza |S.N|2023-06-03 11:48:34 +0330
committerAlireza |S.N|2023-06-03 11:48:34 +0330
commita80072b73f2f2457120f119cb3ccc5e90dfbe500 (patch)
tree17609a3a8fe21d32c8f21b2a89967c9c52f053e5
parentd8c1aa7f538c6ad379779950e4f4389ad8e014d0 (diff)
downloadaur-a80072b73f2f2457120f119cb3ccc5e90dfbe500.tar.gz
Fix FileGDBAPI dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 851900b9f1c7..6f8812938634 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gdal-libkml-filegdb
pkgdesc = A translator library for raster and vector geospatial data formats
- pkgver = 3.6.4
+ pkgver = 3.7.0
pkgrel = 0
url = https://gdal.org/
changelog = gdal.changelog
@@ -53,9 +53,9 @@ pkgbase = gdal-libkml-filegdb
makedepends = zstd
makedepends = libkml-git
provides = gdal
- source = https://download.osgeo.org/gdal/3.6.4/gdal-3.6.4.tar.xz
+ source = https://download.osgeo.org/gdal/3.7.0/gdal-3.7.0.tar.xz
source = https://github.com/Esri/file-geodatabase-api/blob/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz
- sha256sums = 889894cfff348c04ac65b462f629d03efc53ea56cf04de7662fbe81a364e3df1
+ sha256sums = af4b26a6b6b3509ae9ccf1fcc5104f7fe015ef2110f5ba13220816398365adce
sha256sums = 1a1b5c417224e8a4dfd3f7c1f4d1911febf1de38e9b6f93a1e4523a9fce92a91
pkgname = gdal-libkml-filegdb
@@ -106,7 +106,7 @@ pkgname = gdal-libkml-filegdb
pkgname = python-gdal-libkml-filegdb
pkgdesc = Python bindings for GDAL
- depends = gdal-libkml-filegdb=3.6.4
+ depends = gdal-libkml-filegdb=3.7.0
depends = python-numpy
provides = python-gdal
conflicts = python-gdal
diff --git a/PKGBUILD b/PKGBUILD
index 366dfb14d124..67e3af469a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=gdal-libkml-filegdb
pkgname=(gdal-libkml-filegdb python-gdal-libkml-filegdb)
-pkgver=3.6.4
+pkgver=3.7.0
pkgrel=0
provides=('gdal')
pkgdesc="A translator library for raster and vector geospatial data formats"
@@ -22,12 +22,14 @@ makedepends=(cmake opencl-headers python-setuptools python-numpy
# armadillo brunsli lerc libkml rasterlite2 sfcgal tiledb
# ogdi
changelog=gdal.changelog
-source=(https://download.osgeo.org/gdal/${pkgver}/gdal-${pkgver}.tar.xz https://github.com/Esri/file-geodatabase-api/blob/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz)
-sha256sums=('889894cfff348c04ac65b462f629d03efc53ea56cf04de7662fbe81a364e3df1'
- '1a1b5c417224e8a4dfd3f7c1f4d1911febf1de38e9b6f93a1e4523a9fce92a91')
+source=(https://download.osgeo.org/gdal/${pkgver}/gdal-${pkgver}.tar.xz
+ https://github.com/Esri/file-geodatabase-api/blob/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz)
+sha256sums=('af4b26a6b6b3509ae9ccf1fcc5104f7fe015ef2110f5ba13220816398365adce'
+ '1a1b5c417224e8a4dfd3f7c1f4d1911febf1de38e9b6f93a1e4523a9fce92a91')
build() {
tar xzvf FileGDB_API_1_5_1-64gcc51.tar.gz
+ cp FileGDB_API-64gcc51/lib/libFileGDBAPI.so libFileGDBAPI_gdal.so
cmake -B build -S gdal-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_STANDARD=17 \
@@ -77,7 +79,7 @@ build() {
-DGDAL_USE_LIBKML=ON \
-DGDAL_USE_FileGDB=ON \
-DFileGDB_INCLUDE_DIR=FileGDB_API-64gcc51/include \
- -DFileGDB_LIBRARY=FileGDB_API-64gcc51/lib/libFileGDBAPI.so && \
+ -DFileGDB_LIBRARY=libFileGDBAPI_gdal.so && \
make -C build -j $(nproc)
}
@@ -102,6 +104,8 @@ package_gdal-libkml-filegdb () {
'libwebp: WebP support')
make -C build DESTDIR="${pkgdir}" install
+ cp libFileGDBAPI_gdal.so "${pkgdir}"/usr/lib/
+ patchelf --replace-needed "${srcdir}"/libFileGDBAPI_gdal.so libFileGDBAPI_gdal.so "${pkgdir}"/usr/lib/gdalplugins/ogr_FileGDB.so
install -Dm644 gdal-${pkgver}/LICENSE.TXT -t "${pkgdir}"/usr/share/licenses/gdal/
# Move python stuff
mkdir -p {bin,lib}