summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlireza |S.N|2023-08-30 00:28:00 +0330
committerAlireza |S.N|2023-08-30 00:28:18 +0330
commitb47f3d7786e60c1f77665e1de66fa3d7b0ae21d5 (patch)
treeecde24c6a82a48615e1db035c4e41e53196447ef
parent4183581852f641c728203ad868f3a9fa35bba861 (diff)
downloadaur-b47f3d7786e60c1f77665e1de66fa3d7b0ae21d5.tar.gz
Update to 3.7.1 and fix filegdb libs
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--gdal.changelog10
3 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1875b278e4b9..fbad5860c4a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gdal-libkml-filegdb
- pkgdesc = A translator library for raster and vector geospatial data formats
- pkgver = 3.7.0
+ pkgdesc = A translator library for raster and vector geospatial data formats (with libkml and filegdb support)
+ pkgver = 3.7.1
pkgrel = 0
url = https://gdal.org/
changelog = gdal.changelog
@@ -53,9 +53,9 @@ pkgbase = gdal-libkml-filegdb
makedepends = zstd
makedepends = libkml-git
provides = gdal
- source = https://download.osgeo.org/gdal/3.7.0/gdal-3.7.0.tar.xz
- source = https://github.com/Esri/file-geodatabase-api/blob/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz
- sha256sums = af4b26a6b6b3509ae9ccf1fcc5104f7fe015ef2110f5ba13220816398365adce
+ source = https://download.osgeo.org/gdal/3.7.1/gdal-3.7.1.tar.xz
+ source = https://raw.githubusercontent.com/Esri/file-geodatabase-api/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz
+ sha256sums = 9297948f0a8ba9e6369cd50e87c7e2442eda95336b94d2b92ef1829d260b9a06
sha256sums = 1a1b5c417224e8a4dfd3f7c1f4d1911febf1de38e9b6f93a1e4523a9fce92a91
pkgname = gdal-libkml-filegdb
@@ -106,7 +106,7 @@ pkgname = gdal-libkml-filegdb
pkgname = python-gdal-libkml-filegdb
pkgdesc = Python bindings for GDAL
- depends = gdal-libkml-filegdb=3.7.0
+ depends = gdal-libkml-filegdb=3.7.1
depends = python-numpy
provides = python-gdal
conflicts = python-gdal
diff --git a/PKGBUILD b/PKGBUILD
index 5f819c64c17e..b7d3761f02ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
pkgbase=gdal-libkml-filegdb
pkgname=(gdal-libkml-filegdb python-gdal-libkml-filegdb)
-pkgver=3.7.0
+pkgver=3.7.1
pkgrel=0
provides=('gdal')
-pkgdesc="A translator library for raster and vector geospatial data formats"
+pkgdesc="A translator library for raster and vector geospatial data formats (with libkml and filegdb support)"
arch=(x86_64)
url="https://gdal.org/"
license=(custom)
@@ -23,8 +23,8 @@ makedepends=(cmake opencl-headers python-setuptools python-numpy
# ogdi
changelog=gdal.changelog
source=(https://download.osgeo.org/gdal/${pkgver}/gdal-${pkgver}.tar.xz
- https://github.com/Esri/file-geodatabase-api/blob/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz)
-sha256sums=('af4b26a6b6b3509ae9ccf1fcc5104f7fe015ef2110f5ba13220816398365adce'
+ https://raw.githubusercontent.com/Esri/file-geodatabase-api/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz)
+sha256sums=('9297948f0a8ba9e6369cd50e87c7e2442eda95336b94d2b92ef1829d260b9a06'
'1a1b5c417224e8a4dfd3f7c1f4d1911febf1de38e9b6f93a1e4523a9fce92a91')
prepare() {
@@ -35,6 +35,7 @@ prepare() {
build() {
tar xzvf FileGDB_API_1_5_1-64gcc51.tar.gz
cp FileGDB_API-64gcc51/lib/libFileGDBAPI.so libFileGDBAPI_gdal.so
+ cp FileGDB_API-64gcc51/lib/libfgdbunixrtl.so libfgdbunixrtl_gdal.so
cmake -B build -S gdal-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_STANDARD=17 \
@@ -111,7 +112,10 @@ package_gdal-libkml-filegdb () {
'libwebp: WebP support')
make -C build DESTDIR="${pkgdir}" install
- cp libFileGDBAPI_gdal.so "${pkgdir}"/usr/lib/
+ patchelf --replace-needed libfgdbunixrtl.so libfgdbunixrtl_gdal.so libFileGDBAPI_gdal.so
+ install -Dm755 libFileGDBAPI_gdal.so -t "${pkgdir}"/usr/lib/
+ install -Dm755 libfgdbunixrtl_gdal.so -t "${pkgdir}"/usr/lib/
+
patchelf --replace-needed "${srcdir}"/libFileGDBAPI_gdal.so libFileGDBAPI_gdal.so "${pkgdir}"/usr/lib/gdalplugins/ogr_FileGDB.so
install -Dm644 gdal-${pkgver}/LICENSE.TXT -t "${pkgdir}"/usr/share/licenses/gdal/
# Move python stuff
diff --git a/gdal.changelog b/gdal.changelog
index 61fe9027ab5a..1e9b44d9a1c7 100644
--- a/gdal.changelog
+++ b/gdal.changelog
@@ -1,3 +1,13 @@
+2022-11-25 Konstantin Gizdov <arch@kge.pw>
+ * gdal 3.6.0-2
+ * revert FS#75749 fix - not an issue
+
+2022-11-24 Konstantin Gizdov <arch@kge.pw>
+ * gdal 3.6.0-1
+ * FS#75749 - upstream plugin architecture requires hard dependencies (implemented) or splitting plugins into a separate package
+ * FS#76649 - recompile with latest arrow
+ * use b2sums
+
2021-07-22 Bruno Pagani <archange@archlinux.org>
* gdal 3.3.1-1
* update url