summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrurigro2011-03-02 00:00:48 -0800
committerThomas Dziedzic2011-03-02 00:00:48 -0800
commit82dbc986f383d798e1ce751c96256b5710aeb8ab (patch)
tree4aff2f122c2de4ae807225e5cad5d210f0e908d7
parent90b946732de8f0a18669a4bf4ba5523791a48b6b (diff)
downloadaur-82dbc986f383d798e1ce751c96256b5710aeb8ab.tar.gz
updated on Wed Mar 2 00:00:48 PST 2011
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1a0550119f4..2d425c6357b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = gdatafs
pkgdesc = Gdatafs is a FUSE implemtation that mount picassa web and youtube to your filesystem
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.0.2
+ pkgrel = 1
url = http://gdatafs.sourceforge.net
arch = i686
arch = x86_64
license = GPL
depends = fuse
depends = jdk
- source = http://voxel.dl.sourceforge.net/sourceforge/gdatafs/gdatafs_1.0.1.tar.gz
- source = http://gdatafs.svn.sourceforge.net/viewvc/gdatafs/trunk/jni/i686/libjavafs.so?revision=25
- md5sums = e838aff1f3fddb275015aff0905d962c
- md5sums = fa641cfd6b9ef75a06dae8ee565d0a1d
+ source = http://sourceforge.net/projects/gdatafs/files/gdatafs%201.0.2.tar.gz
+ md5sums = 77e5207f1b2cfb72307087ebceb7b801
pkgname = gdatafs
diff --git a/PKGBUILD b/PKGBUILD
index b0a77043b068..62f9d440dd19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Contributor: Prurigro
# Maintainer: Prurigro
pkgname=gdatafs
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.0.2
+pkgrel=1
pkgdesc="Gdatafs is a FUSE implemtation that mount picassa web and youtube to your filesystem"
url="http://gdatafs.sourceforge.net"
license="GPL"
depends=('fuse' 'jdk')
-source=(http://voxel.dl.sourceforge.net/sourceforge/gdatafs/gdatafs_$pkgver.tar.gz
- http://gdatafs.svn.sourceforge.net/viewvc/gdatafs/trunk/jni/i686/libjavafs.so?revision=25)
-md5sums=('e838aff1f3fddb275015aff0905d962c'
- 'fa641cfd6b9ef75a06dae8ee565d0a1d')
+source=(http://sourceforge.net/projects/gdatafs/files/gdatafs%20$pkgver.tar.gz)
+md5sums=('77e5207f1b2cfb72307087ebceb7b801')
arch=('i686' 'x86_64')
build() {
- pushd ${srcdir}/gdatafs\ $pkgver || return 1
- install -d $pkgdir/opt/gdatafs || return 1
- find . -type f -exec install -D '{}' $pkgdir/opt/gdatafs/'{}' \; || return 1
- install -d $pkgdir/opt/gdatafs/jni/i686 || return 1
- install -D "../libjavafs.so?revision=25" $pkgdir/opt/gdatafs/jni/i686/libjavafs.so || return 1
- install -d $pkgdir/usr/bin || return 1
- echo -e "#! /bin/sh\n\npushd /opt/gdatafs > /dev/null\n\t/opt/gdatafs/gdatafs \"\$1\" \"\$2\" \"\$3\"\npopd > /dev/null" > $pkgdir/usr/bin/gdatafs || return 1
- chmod 755 $pkgdir/usr/bin/gdatafs || return 1
+ pushd "$srcdir"/gdatafs || return 1
+ find . -type f | sed -e 's/\.\///g' | while read file; do
+ if [ $(echo "$file" | grep ".svn" -i -c) = 0 -a $(echo "$file" | grep ".project" -i -c) = 0 -a $(echo "$file" | grep ".classpath" -i -c) = 0 -a $(echo "$file" | grep "src" -i -c) = 0 ]; then
+ install -D "$file" "$pkgdir"/opt/gdatafs/"$file" || return 1
+ fi || return 1
+ done || return 1
+ install -d "$pkgdir"/usr/bin || return 1
+ echo -e "#! /bin/sh\n\npushd /opt/gdatafs > /dev/null\n\t/opt/gdatafs/gdatafs \"\$1\" \"\$2\" \"\$3\"\npopd > /dev/null" > "$pkgdir"/usr/bin/gdatafs || return 1
+ chmod 755 "$pkgdir"/usr/bin/gdatafs || return 1
popd || return 1
}