summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2016-05-19 03:24:27 +0200
committerFrederik “Freso” S. Olesen2016-05-19 03:24:27 +0200
commitfd8673374d4135a0b59d16f4cf9a67e6d16071c5 (patch)
treea0aac679c1515d99cd239ab9b71981aaf975f4d9
parentee45bab4365601cc2eb4380ac4b4895ece9e0c13 (diff)
downloadaur-fd8673374d4135a0b59d16f4cf9a67e6d16071c5.tar.gz
gdatafs: Replace "if grep" with improved `find`.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 292db4f7c23a..f8664eb7b7a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu May 19 01:08:31 UTC 2016
+# Thu May 19 01:24:27 UTC 2016
pkgbase = gdatafs
pkgdesc = FUSE implementation that mounts Picasa, YouTube, and Google Docs on your filesystem
pkgver = 1.0.2
diff --git a/PKGBUILD b/PKGBUILD
index 2a5628b8ee7a..45fa0a4dc2c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,8 @@ arch=('any')
package() {
cd "$srcdir"/gdatafs
- find . -type f | sed -e 's/\.\///g' | while read file; do
- if [ $(echo "$file" | grep '.svn' -i -c) = 0 -a $(echo "$file" | grep '.project' -i -c) = 0 -a $(echo "$file" | grep '.classpath' -i -c) = 0 -a $(echo "$file" | grep 'src' -i -c) = 0 ]; then
- install -D "$file" "$pkgdir"/opt/gdatafs/"$file"
- fi
+ find . -type f -not \( -path "*/.svn/*" -o -path "*/.project" -o -path "*/.classpath" -o -path "*/src*/*" \) | sed -e 's/\.\///g' | while read file; do
+ install -D "$file" "$pkgdir"/opt/gdatafs/"$file"
done
install -Dm755 "$srcdir"/gdatafs.sh "$pkgdir"/usr/bin/gdatafs
}