summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-12-15 21:48:44 +0100
committerhaawda2022-12-15 21:48:44 +0100
commit11054f89b7cfd284967c4558f35b43e69b349ad0 (patch)
tree1e626537c933dedf35394cb65f520df7dbdf31a5
parent16fc22abfd0106cc75dce45c9233ab85b877d654 (diff)
downloadaur-11054f89b7cfd284967c4558f35b43e69b349ad0.tar.gz
new (make-)dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a8c74328cd3..d03337420881 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gdb-git
pkgdesc = The GNU Debugger from git
- pkgver = 111892.2756004fe78
+ pkgver = 112405.2e55fbce03a
pkgrel = 1
url = http://www.gnu.org/software/gdb/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = source-highlight
provides = gdb-common
provides = gdb
conflicts = gdb-common
@@ -18,7 +19,7 @@ pkgbase = gdb-git
pkgname = gdb-git
depends = expat
- depends = guile3
+ depends = guile
depends = ncurses
depends = xz
depends = python
@@ -32,7 +33,7 @@ pkgname = gdb-git
backup = etc/gdb/gdbinit
pkgname = gdb-common-git
- depends = python
- depends = guile3
+ depends = python-pygments
+ depends = guile
provides = gdb-common
conflicts = gdb-common
diff --git a/PKGBUILD b/PKGBUILD
index 89495bad879f..2f8da243a8ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=('gdb-git' 'gdb-common-git')
-pkgver=111892.2756004fe78
+pkgver=112405.2e55fbce03a
pkgrel=1
pkgdesc="The GNU Debugger from git"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/gdb/"
license=('GPL3')
-makedepends=('git')
+makedepends=('git' 'source-highlight')
provides=('gdb-common' 'gdb')
conflicts=('gdb-common' 'gdb')
backup=('etc/gdb/gdbinit')
@@ -49,12 +49,12 @@ build() {
}
package_gdb-git() {
- depends=('expat' 'guile3' 'ncurses' 'xz' 'python' 'source-highlight' 'mpfr' 'xxhash' 'libelf' 'gdb-common-git')
+ depends=('expat' 'guile' 'ncurses' 'xz' 'python' 'source-highlight' 'mpfr' 'xxhash' 'libelf' 'gdb-common-git')
provides=('gdb')
conflicts=('gdb')
backup=(etc/gdb/gdbinit)
cd "$srcdir/gdb/build"
-
+
# install only gdb, otherwise it would install files already provided by binutils
make DESTDIR="$pkgdir/" install-gdb
@@ -69,7 +69,7 @@ package_gdb-git() {
package_gdb-common-git() {
provides=('gdb-common')
conflicts=('gdb-common')
- depends=('python' 'guile3')
+ depends=('python-pygments' 'guile')
cd "$srcdir/gdb/build"
make -C gdb/data-directory DESTDIR="$pkgdir" install
}