summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-04-10 19:33:42 +0200
committerhaawda2022-04-10 19:33:42 +0200
commit8535d5c286b5663df96eca4712d5278dec7c23d0 (patch)
tree30e614edfa5b0d36a12f8cea9b8799d34e09f850
parent220e1d0b4dfeab5445a10543895cf45916cb2a44 (diff)
downloadaur-8535d5c286b5663df96eca4712d5278dec7c23d0.tar.gz
adopted and fixed
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63e5b61a1767..3585b2e18f98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = gdb-git
- pkgdesc = The GNU Debugger
- pkgver = 78972.bbad633
+ pkgdesc = The GNU Debugger from git
+ pkgver = 109622.f190d13c78b
pkgrel = 1
url = http://www.gnu.org/software/gdb/
- install = gdb.install
arch = i686
arch = x86_64
license = GPL3
@@ -11,14 +10,17 @@ pkgbase = gdb-git
depends = expat
depends = guile
depends = ncurses
- depends = python2
depends = xz
+ depends = python
+ depends = source-highlight
+ depends = mpfr
+ depends = xxhash
+ depends = libelf
provides = gdb
conflicts = gdb
options = !libtool
backup = etc/gdb/gdbinit
- source = gdb::git+git://sourceware.org/git/binutils-gdb.git
- md5sums = SKIP
+ source = gdb::git+https://sourceware.org/git/binutils-gdb.git
+ sha256sums = SKIP
pkgname = gdb-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bfeefcdaeb06..6b46524c43b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=gdb-git
-pkgver=78972.bbad633
+pkgver=109622.f190d13c78b
pkgrel=1
-pkgdesc="The GNU Debugger"
+pkgdesc="The GNU Debugger from git"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/gdb/"
license=('GPL3')
-depends=('expat' 'guile' 'ncurses' 'python2' 'xz')
+depends=('expat' 'guile' 'ncurses' 'xz' 'python' 'source-highlight' 'mpfr' 'xxhash' 'libelf')
makedepends=('git')
provides=('gdb')
conflicts=('gdb')
backup=('etc/gdb/gdbinit')
options=('!libtool')
-install=gdb.install
-source=('gdb::git+git://sourceware.org/git/binutils-gdb.git')
-md5sums=('SKIP')
+source=('gdb::git+https://sourceware.org/git/binutils-gdb.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/gdb"
@@ -32,18 +33,24 @@ prepare() {
build() {
cd "$srcdir/gdb"
-
- ./configure --prefix=/usr --disable-nls \
- --disable-werror \
- --with-system-readline \
- --with-python=/usr/bin/python2 \
- --with-system-gdbinit=/etc/gdb/gdbinit
-
+
+ [[ -d build ]] || mkdir -p build
+ cd build
+ CFLAGS+=" -fcommon" ../configure \
+ --prefix=/usr \
+ --disable-nls \
+ --disable-gprofng \
+ --enable-source-highlight \
+ --enable-tui \
+ --with-system-readline \
+ --with-python=/usr/bin/python \
+ --with-guile=guile-2.2 \
+ --with-system-gdbinit=/etc/gdb/gdbinit
make
}
package() {
- cd "$srcdir/gdb"
+ cd "$srcdir/gdb/build"
# install only gdb, otherwise it would install files already provided by binutils
make DESTDIR="$pkgdir/" install-gdb