summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-13 02:40:03 -0400
committerJames P. Harvey2018-10-13 02:55:41 -0400
commitbc44852cbd00978479a44ba8f721c12e177aed3a (patch)
tree692d4939513b6b6a5fb8d7abfe3a8ab1771104df
parent0ebf37804757808c5b64cce76b907a39498c17e0 (diff)
downloadaur-bc44852cbd00978479a44ba8f721c12e177aed3a.tar.gz
Mirrored extra's changes from 7.10.1-1 to 7.11.1-2.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 43 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cafa82941e4f..9b682505142f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,33 @@
pkgbase = gdb-trunk
pkgdesc = The GNU Debugger
- pkgver = 7.11.r87190.94af22593b
+ pkgver = 7.11.1.r88081.fc177366b0
pkgrel = 1
url = http://www.gnu.org/software/gdb/
arch = i686
arch = x86_64
license = GPL3
makedepends = texinfo
+ makedepends = python
+ makedepends = guile
+ makedepends = ncurses
+ makedepends = expat
+ makedepends = xz
makedepends = git
+ source = git+https://sourceware.org/git/binutils-gdb.git
+ sha1sums = SKIP
+
+pkgname = gdb-trunk
depends = ncurses
depends = expat
- depends = python
depends = xz
- depends = guile
+ depends = gdb-common=7.11.1.r88081.fc177366b0
provides = gdb
conflicts = gdb
backup = etc/gdb/gdbinit
- source = git+https://sourceware.org/git/binutils-gdb.git
- sha1sums = SKIP
-pkgname = gdb-trunk
+pkgname = gdb-trunk-common
+ depends = python
+ depends = guile
+ provides = gdb-common
+ conflicts = gdb-common
diff --git a/PKGBUILD b/PKGBUILD
index 26259e87ff6a..4bb32f4c259a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,22 @@
# Modifications to Use Git Master Source
# ======================================
# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * This PKGFILE as closely as possible matches extra's binutils 7.11-1
+# * This PKGFILE as closely as possible matches extra's binutils 7.11.1-2
# * Installs some things to /usr/$CHOST/... {/usr/x86_64-unknown-linux-gnu/...) rather than /usr/...
# * Investigating to determine if this is desired, or if they need to be moved
-pkgname=gdb-trunk
+pkgbase=gdb-trunk
+# gdb-trunk-common is a package that contains files common for all cross compiled versions
+# of gdb (for arm/avr/...)
+pkgname=(gdb-trunk gdb-trunk-common)
_pkgname=binutils-gdb
-pkgver=7.11.r87190.94af22593b
+pkgver=7.11.1.r88081.fc177366b0
pkgrel=1
pkgdesc='The GNU Debugger'
arch=(i686 x86_64)
url='http://www.gnu.org/software/gdb/'
license=(GPL3)
-depends=(ncurses expat python xz guile)
-makedepends=(texinfo git)
-provides=(gdb)
-conflicts=(gdb)
-backup=(etc/gdb/gdbinit)
+makedepends=(texinfo python guile ncurses expat xz git)
source=(git+https://sourceware.org/git/binutils-gdb.git)
sha1sums=('SKIP')
@@ -51,11 +50,30 @@ build() {
make
}
-package() {
+package_gdb-trunk-common() {
+ depends=(python guile)
+ provides=(gdb-common)
+ conflicts=(gdb-common)
+
+ cd $_pkgname
+ make DESTDIR=$pkgdir install
+
+ rm -r $pkgdir/usr/{bin,include,lib,share/info,share/man}
+}
+
+package_gdb-trunk() {
+ depends=(ncurses expat xz gdb-common=$pkgver)
+ backup=(etc/gdb/gdbinit)
+ provides=(gdb)
+ conflicts=(gdb)
+
cd $_pkgname
make DESTDIR=$pkgdir install
# install "custom" system gdbinit
install -dm755 $pkgdir/etc/gdb
touch $pkgdir/etc/gdb/gdbinit
+
+ # comes from gdb-common
+ rm -r $pkgdir/usr/share/gdb/
}