summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2023-04-18 12:46:42 +0200
committerkleintux2023-04-18 12:46:42 +0200
commit072fd61b97c162485266b5c441833209fbae4894 (patch)
tree665e047b492d298f701798d0d92ff311483555ae
parent03ffd791ebfedeea0faa656f13245585696db0a8 (diff)
downloadaur-072fd61b97c162485266b5c441833209fbae4894.tar.gz
added missing boost dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1deb17effd94..24a76a3e6ab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdb11
pkgdesc = GNU debugger (version 11) for compability with clion remote debugging
pkgver = 11.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/gdb
arch = x86_64
license = GPL
@@ -10,6 +10,8 @@ pkgbase = gdb11
depends = xz
depends = libmpc
depends = gdb
+ depends = boost
+ depends = boost-libs
conflicts = i686-elf-gdb
replaces = i686-elf-gdb
source = https://ftp.gnu.org/gnu/gdb/gdb-11.2.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 0d3e5bd480cb..abbc01cdc2b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=gdb11
pkgver=11.2
-pkgrel=1
+pkgrel=2
pkgdesc="GNU debugger (version 11) for compability with clion remote debugging"
arch=(x86_64)
url="https://www.gnu.org/software/gdb"
license=('GPL')
-makedepends=(gmp mpfr)
-depends=(xz libmpc gdb) # GDB is included to prevent conflicts with it - otherwise this package won't function
+makedepends=('gmp' 'mpfr')
+depends=('xz' 'libmpc' 'gdb' 'boost' 'boost-libs') # GDB is included to prevent conflicts with it - otherwise this package won't function
replaces=("i686-elf-gdb")
conflicts=("i686-elf-gdb")
source=("https://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz")
@@ -17,13 +17,13 @@ sha256sums=('1497c36a71881b8671a9a84a0ee40faab788ca30d7ba19d8463c3cc787152e32')
OPTIONS=(!strip)
prepare() {
- mkdir "gdb11-build"
+ mkdir "gdb11-build"
}
build() {
- cd "gdb11-build"
+ cd "gdb11-build"
../gdb-${pkgver}/configure --prefix=/opt/gdb11
- make -j$(nproc)
+ make -j$(nproc)
}
package() {