summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElronnd2017-09-10 18:19:22 -0700
committerElronnd2017-09-10 18:19:22 -0700
commit180f24f56087e84a25e4b421ed588e6eb5dcbfb5 (patch)
tree7ccb48d04171ea4f86514891911a39322eea6f45
parent4157aae070d84b047bd6a14a81ddf5fadc40fd62 (diff)
downloadaur-180f24f56087e84a25e4b421ed588e6eb5dcbfb5.tar.gz
Update to 7.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af77c21d2668..df6b634fe5ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = gdc
- pkgver = 7.1.0
+ pkgver = 7.2.0
pkgrel = 2
url = https://github.com/D-Programming-GDC/GDC
arch = i686
@@ -7,12 +7,12 @@ pkgbase = gdc
license = GPL
makedepends = binutils>=2.26
makedepends = git
- source = https://ftp.gnu.org/pub/gnu/gcc/gcc-7.1.0/gcc-7.1.0.tar.bz2
+ source = https://ftp.gnu.org/pub/gnu/gcc/gcc-7.2.0/gcc-7.2.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.18.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git
source = git+https://github.com/D-Programming-GDC/GDMD.git
source = paths.diff
- sha256sums = 8a8136c235f64c6fef69cac0d73a46a1a09bb250776a050aec8f9fc880bebc17
+ sha256sums = 1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a
sha256sums = 6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 565e01087cf6..603991a55a14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Elijah Stone <elronnd@protonmail.ch>
pkgname=('gdc' 'libgphobos-devel' 'libgphobos')
-pkgver=7.1.0
+pkgver=7.2.0
pkgrel=2
_islver=0.18
arch=('i686' 'x86_64')
@@ -16,14 +16,14 @@ url="https://github.com/D-Programming-GDC/GDC"
makedepends=('binutils>=2.26' 'git')
source=(
- https://ftp.gnu.org/pub/gnu/gcc/gcc-7.1.0/gcc-7.1.0.tar.bz2
+ https://ftp.gnu.org/pub/gnu/gcc/gcc-7.2.0/gcc-7.2.0.tar.xz
http://isl.gforge.inria.fr/isl-$_islver.tar.bz2
gdc::git+https://github.com/D-Programming-GDC/GDC.git
git+https://github.com/D-Programming-GDC/GDMD.git
paths.diff
)
sha256sums=(
- '8a8136c235f64c6fef69cac0d73a46a1a09bb250776a050aec8f9fc880bebc17'
+ '1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a'
'6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
'SKIP'
'SKIP'
@@ -61,8 +61,8 @@ build() {
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS=${CFLAGS/-pipe/}
- CXXFLAGS=${CXXFLAGS/-pipe/}
+ export CFLAGS="${CFLAGS/-pipe/} -O2"
+ export CXXFLAGS="${CXXFLAGS/-pipe/} -O2"
$srcdir/gcc-$pkgver/configure --prefix=/usr \
--libdir=/usr/lib \