summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElronnd2018-02-19 19:54:49 -0700
committerElronnd2018-02-19 19:54:49 -0700
commitbc036917c4076d95a4d0bcaec8ab88aa4f46205b (patch)
tree73864ede298cf725b6427b0049fba792fbcf67f1
parent9238b91c7bb5d067ce4ac4b619c1c6e80b3f8340 (diff)
downloadaur-bc036917c4076d95a4d0bcaec8ab88aa4f46205b.tar.gz
Update to version 7.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--init.diff20
3 files changed, 9 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cb0ac26727e..71eb21ed288f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = gdc
- pkgver = 7.2.0
- pkgrel = 3
+ pkgver = 7.3.0
+ pkgrel = 1
url = https://github.com/D-Programming-GDC/GDC
arch = i686
arch = x86_64
license = GPL
makedepends = binutils>=2.26
makedepends = git
- source = https://ftp.gnu.org/pub/gnu/gcc/gcc-7.2.0/gcc-7.2.0.tar.xz
+ source = https://ftp.gnu.org/gnu/gcc/gcc-7.3.0/gcc-7.3.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.18.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git
source = git+https://github.com/D-Programming-GDC/GDMD.git
source = paths.diff
- source = init.diff
- sha256sums = 1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a
+ sha256sums = 832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c
sha256sums = 6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b
sha256sums = SKIP
sha256sums = SKIP
sha256sums = fefe9298f8d5859758ca63bab084984baa8adbbd85b3b3b8798283731321df7b
- sha256sums = 5f9efcd016389c3940afdc5819c218f44557c816a785f99373d796bebb0e7465
pkgname = gdc
pkgdesc = Compiler for D programming language which uses gcc backend
diff --git a/PKGBUILD b/PKGBUILD
index 2f0516856702..91ccfb754292 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# Contributor: Jerome Berger <jeberger@free.fr>
# Contributor: Jesus Alvarez <jeezusjr@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
-# Contributor: Elijah Stone <elronnd@protonmail.ch>
+# Contributor: Elijah Stone <elronnd@elronnd.net>
pkgname=('gdc' 'libgphobos-devel' 'libgphobos')
-pkgver=7.2.0
-pkgrel=3
+pkgver=7.3.0
+pkgrel=1
_islver=0.18
arch=('i686' 'x86_64')
license=('GPL')
@@ -16,20 +16,18 @@ url="https://github.com/D-Programming-GDC/GDC"
makedepends=('binutils>=2.26' 'git')
source=(
- https://ftp.gnu.org/pub/gnu/gcc/gcc-7.2.0/gcc-7.2.0.tar.xz
+ https://ftp.gnu.org/gnu/gcc/gcc-7.3.0/gcc-7.3.0.tar.xz
http://isl.gforge.inria.fr/isl-$_islver.tar.bz2
gdc::git+https://github.com/D-Programming-GDC/GDC.git
git+https://github.com/D-Programming-GDC/GDMD.git
paths.diff
- init.diff
)
sha256sums=(
- '1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a'
+ '832ca6ae04636adbb430e865a1451adf6979ab44ca1c8374f61fba65645ce15c'
'6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
'SKIP'
'SKIP'
'fefe9298f8d5859758ca63bab084984baa8adbbd85b3b3b8798283731321df7b'
- '5f9efcd016389c3940afdc5819c218f44557c816a785f99373d796bebb0e7465'
)
_libdir="usr/lib/gcc/$CHOST/$pkgver"
@@ -53,7 +51,6 @@ prepare() {
cd $srcdir/gdc
git checkout gdc-7
git apply $srcdir/paths.diff
- git apply $srcdir/init.diff
./setup-gcc.sh ../gcc-$pkgver
mkdir $srcdir/gcc-build
diff --git a/init.diff b/init.diff
deleted file mode 100644
index 90fbbbc5e54b..000000000000
--- a/init.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/gcc/d/expr.cc b/gcc/d/expr.cc
-index 073fe6ff4..1f67936a2 100644
---- a/gcc/d/expr.cc
-+++ b/gcc/d/expr.cc
-@@ -1666,11 +1666,13 @@ class ExprVisitor : public Visitor
- StructLiteralExp *sle = ((StructLiteralExp *) e->e1)->origin;
- gcc_assert (sle != NULL);
-
-- /* Build the reference symbol. */
-+ /* Build the reference symbol, the decl is built first as the
-+ initializer may have recursive references. */
- if (!sle->sym)
- {
- sle->sym = build_artificial_decl (build_ctype (sle->type),
-- build_expr (sle, true), "S");
-+ NULL_TREE, "S");
-+ DECL_INITIAL (sle->sym) = build_expr (sle, true);
- d_pushdecl (sle->sym);
- rest_of_decl_compilation (sle->sym, 1, 0);
- }