summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kozak2018-05-16 11:06:34 +0200
committerDaniel Kozak2018-05-16 11:07:38 +0200
commitcdc730e94864b278e6ed1fcd3b2db4ae00abd0cb (patch)
tree3923737c8bca49ce870ab6eb78b46dd09c1dd65b
parent61ba8593f223389bb3342781e2cd62e6a131c621 (diff)
downloadaur-cdc730e94864b278e6ed1fcd3b2db4ae00abd0cb.tar.gz
Update to version 8.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12596e5babfd..ae6e4adb2904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = gdc
- pkgver = 7.3.1+20180312
+ pkgver = 8.1.0
pkgrel = 1
url = https://github.com/D-Programming-GDC/GDC
arch = i686
@@ -7,12 +7,12 @@ pkgbase = gdc
license = GPL
makedepends = binutils>=2.26
makedepends = git
- source = https://sources.archlinux.org/other/gcc/gcc-7.3.1-20180312.tar.xz
+ source = https://ftp.gnu.org/gnu/gcc/gcc-8.1.0/gcc-8.1.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.18.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git
source = git+https://github.com/D-Programming-GDC/GDMD.git
source = paths.diff
- sha256sums = c52618f656f2102b3544419e7d0a8a4f4e6ff052783865202be73edf1a40e28b
+ sha256sums = 1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153
sha256sums = 6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b
sha256sums = SKIP
sha256sums = SKIP
@@ -24,7 +24,7 @@ pkgname = gdc
depends = perl
depends = binutils
depends = libgphobos-devel
- provides = d-compiler=2.068.2
+ provides = d-compiler=2.076.1
pkgname = libgphobos-devel
pkgdesc = Standard library for D programming language, GDC port
diff --git a/PKGBUILD b/PKGBUILD
index dad540ac5ecc..b456046e99ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Daniel Kozak <kozzi11@gmail.com>
pkgname=('gdc' 'libgphobos-devel' 'libgphobos')
-pkgver=7.3.1+20180312
+pkgver=8.1.0
pkgrel=1
_islver=0.18
arch=('i686' 'x86_64')
@@ -17,14 +17,14 @@ url="https://github.com/D-Programming-GDC/GDC"
makedepends=('binutils>=2.26' 'git')
source=(
- https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz
+ https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
http://isl.gforge.inria.fr/isl-$_islver.tar.bz2
gdc::git+https://github.com/D-Programming-GDC/GDC.git
git+https://github.com/D-Programming-GDC/GDMD.git
paths.diff
)
sha256sums=(
- 'c52618f656f2102b3544419e7d0a8a4f4e6ff052783865202be73edf1a40e28b'
+ '1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153'
'6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b'
'SKIP'
'SKIP'
@@ -51,7 +51,7 @@ prepare() {
# GDC setup
cd $srcdir/gdc
- git checkout gdc-7
+ git checkout gdc-8
git apply $srcdir/paths.diff
./setup-gcc.sh ../gcc
@@ -103,7 +103,7 @@ build() {
package_gdc() {
depends=('gcc' 'perl' 'binutils' 'libgphobos-devel')
- provides=("d-compiler=2.068.2")
+ provides=("d-compiler=2.076.1")
pkgdesc="Compiler for D programming language which uses gcc backend"
# compiler