summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kozak2018-08-16 14:58:00 +0200
committerDaniel Kozak2018-08-16 14:58:00 +0200
commitd6d121f505cf9ea787ae0562a63774360aa09fa6 (patch)
tree702cccd62efd73fd5ee56aa41ad8f44608bf054f
parentf5819e127fdc75431b38e15a12f0d637a15898b7 (diff)
downloadaur-d6d121f505cf9ea787ae0562a63774360aa09fa6.tar.gz
Fixing circular dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec1fa223de6c..986c95a5613a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = gdc
license = GPL
makedepends = binutils>=2.26
makedepends = git
- makedepends = gdc
+ makedepends = gdc-stable
source = https://ftp.gnu.org/gnu/gcc/gcc-8.2.0/gcc-8.2.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.19.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git
@@ -26,6 +26,7 @@ pkgname = gdc
depends = binutils
depends = libgphobos
provides = d-compiler=2.076.1
+ provides = gdc-stable
conflicts = gdc-stable
replaces = gdc-stable
diff --git a/PKGBUILD b/PKGBUILD
index c3de4f16b9f4..e72da3c29655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _islver=0.19
arch=('i686' 'x86_64')
license=('GPL')
url='https://github.com/D-Programming-GDC/GDC'
-makedepends=('binutils>=2.26' 'git' 'gdc')
+makedepends=('binutils>=2.26' 'git' 'gdc-stable')
source=(
https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
@@ -105,7 +105,7 @@ build() {
package_gdc() {
depends=('gcc' 'perl' 'binutils' 'libgphobos')
- provides=('d-compiler=2.076.1')
+ provides=('d-compiler=2.076.1' 'gdc-stable')
pkgdesc="Compiler for D programming language which uses gcc backend"
conflicts=('gdc-stable')
replaces=('gdc-stable')