summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kozak2018-08-16 14:53:47 +0200
committerDaniel Kozak2018-08-16 14:53:47 +0200
commitf5819e127fdc75431b38e15a12f0d637a15898b7 (patch)
treeabe024a75df55eee621b340c563f1afe72aa99a9
parentaeff791b277e14f720f12add31c66cc152751a04 (diff)
downloadaur-f5819e127fdc75431b38e15a12f0d637a15898b7.tar.gz
Move from c++ frontend to new dfrontend (old version is available as gdc-stable)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bd6ea76d3e5..ec1fa223de6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = gdc
license = GPL
makedepends = binutils>=2.26
makedepends = git
+ makedepends = gdc
source = https://ftp.gnu.org/gnu/gcc/gcc-8.2.0/gcc-8.2.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.19.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git
@@ -25,12 +26,16 @@ pkgname = gdc
depends = binutils
depends = libgphobos
provides = d-compiler=2.076.1
+ conflicts = gdc-stable
+ replaces = gdc-stable
pkgname = libgphobos
pkgdesc = Standard library for D programming language, GDC port
provides = d-runtime
provides = d-stdlib
conflicts = libgphobos-devel
+ conflicts = libgphobos-stable
replaces = libgphobos-devel
+ replaces = libgphobos-stable
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 737be919e692..c3de4f16b9f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _islver=0.19
arch=('i686' 'x86_64')
license=('GPL')
url='https://github.com/D-Programming-GDC/GDC'
-makedepends=('binutils>=2.26' 'git')
+makedepends=('binutils>=2.26' 'git' 'gdc')
source=(
https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
@@ -52,7 +52,7 @@ prepare() {
# GDC setup
cd "$srcdir"/gdc
- git checkout gdc-8-stable
+ git checkout gdc-8
git apply "$srcdir"/paths.diff
./setup-gcc.sh ../gcc
@@ -93,6 +93,7 @@ build() {
--enable-default-pie \
--disable-multilib \
--disable-werror \
+ --disable-bootstrap \
--enable-languages=d \
gdc_include_dir=/usr/include/dlang/gdc
@@ -106,6 +107,8 @@ package_gdc() {
depends=('gcc' 'perl' 'binutils' 'libgphobos')
provides=('d-compiler=2.076.1')
pkgdesc="Compiler for D programming language which uses gcc backend"
+ conflicts=('gdc-stable')
+ replaces=('gdc-stable')
# compiler
install -D -m755 "$srcdir"/gcc-build/gcc/gdc "$pkgdir"/usr/bin/gdc
@@ -121,9 +124,9 @@ package_libgphobos() {
pkgdesc="Standard library for D programming language, GDC port"
provides=('d-runtime' 'd-stdlib')
options=('staticlibs')
- conflicts=('libgphobos-devel')
- replaces=('libgphobos-devel')
+ conflicts=('libgphobos-devel' 'libgphobos-stable')
+ replaces=('libgphobos-devel' 'libgphobos-stable')
cd "$srcdir"/gcc-build
make -C $CHOST/libphobos DESTDIR="$pkgdir" install
-} \ No newline at end of file
+}