summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kozak2018-08-30 14:47:51 +0200
committerDaniel Kozak2018-08-30 14:47:51 +0200
commit1a54e6e32839b3f8cc454207d2098daf52fb7935 (patch)
treede11837554d64fe7a54abb9749b368efe2dc1b75
parent8b093ff711891c308d97ebdb31b5b575ceb67689 (diff)
downloadaur-1a54e6e32839b3f8cc454207d2098daf52fb7935.tar.gz
Fix typo in libphobos conflicts and fix gcc url
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 206c4db925e7..f1a79075addb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdc-git
pkgdesc = GCC based D compiler
pkgver = 8.2.0+2.081.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/D-Programming-GDC/GDC
arch = x86_64
arch = i686
@@ -10,7 +10,7 @@ pkgbase = gdc-git
license = GPL3
makedepends = git
makedepends = gdc
- source = ftp://gcc.gnu.org/pub/gcc/snapshots/8.2.0/gcc-8.2.0.tar.xz
+ source = https://ftp.gnu.org/gnu/gcc/gcc-8.2.0/gcc-8.2.0.tar.xz
source = http://isl.gforge.inria.fr/isl-0.19.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git
source = git+https://github.com/D-Programming-GDC/GDMD.git
@@ -36,6 +36,6 @@ pkgname = libgphobos-git
provides = d-runtime
provides = d-stdlib
provides = libgphobos
- conflicts = libgpgobos
+ conflicts = libgphobos
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index e0c5c02e74d8..69508c841556 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,14 @@ _branch=gdc-8 # Change here! pkgver/_gccver/_d_ver will be automatically updated
_islver=0.19 # Change here!
_gccver=$(curl https://raw.githubusercontent.com/D-Programming-GDC/GDC/$_branch/gcc.version)
_d_ver=''
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686')
license=('GPL3')
url="https://github.com/D-Programming-GDC/GDC"
pkgdesc="GCC based D compiler"
groups=('dlang' 'dlang-dmd')
makedepends=('git' 'gdc')
-source=("ftp://gcc.gnu.org/pub/gcc/snapshots/${_gccver#gcc-}/$_gccver.tar.xz"
+source=("https://ftp.gnu.org/gnu/gcc/$_gccver/$_gccver.tar.xz"
"http://isl.gforge.inria.fr/isl-$_islver.tar.bz2"
'gdc::git+https://github.com/D-Programming-GDC/GDC.git'
'git+https://github.com/D-Programming-GDC/GDMD.git'
@@ -131,7 +131,7 @@ package_gdc-git() {
package_libgphobos-git() {
pkgdesc="Standard library for D programming language, GDC port"
provides=('d-runtime' 'd-stdlib' 'libgphobos')
- conflicts=('libgpgobos')
+ conflicts=('libgphobos')
options=('staticlibs')
cd "$srcdir"/gcc-build