summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kozak2018-12-13 10:28:34 +0100
committerDaniel Kozak2018-12-13 10:28:34 +0100
commit7a62fb628b2b417e8b299aa4d970b8c7c014ec70 (patch)
tree3546cd688ae91f34f6b53b5235ec1be6b4205c59
parentcead1eade75ecafa649be349948379aab65f6e78 (diff)
downloadaur-7a62fb628b2b417e8b299aa4d970b8c7c014ec70.tar.gz
Update to latest gcc version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7418cd5dbd5..276b2410efbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gdc-git
pkgdesc = GCC based D compiler
pkgver = 8.2.1+2.081.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/D-Programming-GDC/GDC
arch = x86_64
arch = i686
@@ -9,12 +9,12 @@ pkgbase = gdc-git
license = GPL3
makedepends = git
makedepends = gdc
- source = https://sources.archlinux.org/other/gcc/gcc-8.2.1-20180831.tar.xz
+ source = https://sources.archlinux.org/other/gcc/gcc-8.2.1-20181127.tar.xz
source = http://isl.gforge.inria.fr/isl-0.20.tar.bz2
source = gdc::git+https://github.com/D-Programming-GDC/GDC.git#branch=gdc-8
source = git+https://github.com/D-Programming-GDC/GDMD.git
source = paths.diff
- sha512sums = 0f9f921ae563bf762d05e9d1ad6d551686371e5b2f8925f7b514caedfff15507f39616059a07465e4083b6da3d14343f986b3ec89b1f28ab536f4d68ff26829d
+ sha512sums = 8988e9425a1fb5c2bc7655a8054438060e145d568fa60d19ec2ab4005a8becc06f906cffbfb674ff6c6995a3751af0590d2e6d5694cbb88951633aa8c2667e18
sha512sums = afe2e159b74646a26449268637403d271f9e3f6410d8cc1c9cffca41370c4357b165dea844db0c2a654591f954e54710dda650c8088abd4711406aa6302da950
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4c144dcae259..853ae9d44120 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,9 @@ pkgname=(gdc-git libgphobos-git)
pkgver=8.2.1+2.081.2
_branch=gdc-8 # Change here! pkgver/_gccver/_d_ver will be automatically updated.
_islver=0.20 # Change here!
-_gccver=8.2.1-20180831 # Change here! Should match Arch's GCC version
+_gccver=8.2.1-20181127 # Change here! Should match Arch's GCC version
_d_ver=''
-pkgrel=2
+pkgrel=3
arch=('x86_64' 'i686')
license=('GPL3')
url="https://github.com/D-Programming-GDC/GDC"
@@ -22,13 +22,12 @@ pkgdesc="GCC based D compiler"
groups=('dlang')
makedepends=('git' 'gdc')
source=(
- "https://sources.archlinux.org/other/gcc/gcc-$_gccver.tar.xz"
- #"ftp://gcc.gnu.org/pub/gcc/releases/$_gccver/gcc-$_gccver.tar.xz"
+ "https://sources.archlinux.org/other/gcc/gcc-$_gccver.tar.xz"
"http://isl.gforge.inria.fr/isl-$_islver.tar.bz2"
"gdc::git+https://github.com/D-Programming-GDC/GDC.git#branch=$_branch"
'git+https://github.com/D-Programming-GDC/GDMD.git'
'paths.diff')
-sha512sums=('0f9f921ae563bf762d05e9d1ad6d551686371e5b2f8925f7b514caedfff15507f39616059a07465e4083b6da3d14343f986b3ec89b1f28ab536f4d68ff26829d'
+sha512sums=('8988e9425a1fb5c2bc7655a8054438060e145d568fa60d19ec2ab4005a8becc06f906cffbfb674ff6c6995a3751af0590d2e6d5694cbb88951633aa8c2667e18'
'afe2e159b74646a26449268637403d271f9e3f6410d8cc1c9cffca41370c4357b165dea844db0c2a654591f954e54710dda650c8088abd4711406aa6302da950'
'SKIP'
'SKIP'
@@ -106,7 +105,7 @@ build() {
--with-pkgversion="GDC ${pkgver%+*} based on D v${pkgver#*+} built with ISL $_islver for Arch Linux" \
gdc_include_dir=/usr/include/dlang/gdc
- make
+ make $MAKEFLAGS
}
package_gdc-git() {