summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kozak2019-08-06 09:00:52 +0200
committerDaniel Kozak2019-08-07 14:38:00 +0200
commitfc6139030ab8469515c968370d44fbcc818229fb (patch)
tree1b67cf1856bc5119634aec708727774d0c9ea5b1
parent7a62fb628b2b417e8b299aa4d970b8c7c014ec70 (diff)
downloadaur-fc6139030ab8469515c968370d44fbcc818229fb.tar.gz
Update to latest version
add gdmd and some improvment remove unnecesary files and update SRCINFO
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD147
-rw-r--r--paths.diff39
3 files changed, 85 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 276b2410efbc..d94c32d9fbe7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,20 @@
pkgbase = gdc-git
pkgdesc = GCC based D compiler
- pkgver = 8.2.1+2.081.2
- pkgrel = 3
- url = https://github.com/D-Programming-GDC/GDC
+ pkgver = 10.0.0+v2.086.0
+ pkgrel = 1
+ url = https://gcc.gnu.org/
arch = x86_64
arch = i686
groups = dlang
license = GPL3
makedepends = git
makedepends = gdc
- source = https://sources.archlinux.org/other/gcc/gcc-8.2.1-20181127.tar.xz
- source = http://isl.gforge.inria.fr/isl-0.20.tar.bz2
- source = gdc::git+https://github.com/D-Programming-GDC/GDC.git#branch=gdc-8
+ source = http://isl.gforge.inria.fr/isl-0.21.tar.bz2
+ source = gcc::git+https://github.com/gcc-mirror/gcc.git#branch=ibuclaw/gdc
source = git+https://github.com/D-Programming-GDC/GDMD.git
- source = paths.diff
- sha512sums = 8988e9425a1fb5c2bc7655a8054438060e145d568fa60d19ec2ab4005a8becc06f906cffbfb674ff6c6995a3751af0590d2e6d5694cbb88951633aa8c2667e18
- sha512sums = afe2e159b74646a26449268637403d271f9e3f6410d8cc1c9cffca41370c4357b165dea844db0c2a654591f954e54710dda650c8088abd4711406aa6302da950
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = 841504e9dffe718f7e5a5fbbf03299f2b51acd783d47f99894aa5d411abcc56aedfffd4b16595e3a9446f2206f9eb29cb01e235e82c211796cd24dc23c02b578
+ sha256sums = d18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = gdc-git
pkgdesc = Compiler for D programming language which uses gcc backend
@@ -26,9 +22,10 @@ pkgname = gdc-git
depends = perl
depends = binutils
depends = libgphobos
- provides = d-compiler=2.081.2
+ provides = d-compiler=v2.086.0
provides = gdc
conflicts = gdc
+ conflicts = gcc-gdc
pkgname = libgphobos-git
pkgdesc = Standard library for D programming language, GDC port
@@ -36,5 +33,6 @@ pkgname = libgphobos-git
provides = d-stdlib
provides = libgphobos
conflicts = libgphobos
+ conflicts = gcc-gdc
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 853ae9d44120..42ede331e9e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,116 +9,113 @@
pkgbase=gdc-git
pkgname=(gdc-git libgphobos-git)
-pkgver=8.2.1+2.081.2
-_branch=gdc-8 # Change here! pkgver/_gccver/_d_ver will be automatically updated.
-_islver=0.20 # Change here!
-_gccver=8.2.1-20181127 # Change here! Should match Arch's GCC version
+_gccver=10.0.0
+pkgver=10.0.0+v2.086.0
+
+_branch=ibuclaw/gdc # Change here! pkgver/_gccver/_d_ver will be automatically updated.
+_islver=0.21 # Change here!
_d_ver=''
-pkgrel=3
+pkgrel=1
arch=('x86_64' 'i686')
license=('GPL3')
-url="https://github.com/D-Programming-GDC/GDC"
+url="https://gcc.gnu.org/"
pkgdesc="GCC based D compiler"
groups=('dlang')
makedepends=('git' 'gdc')
source=(
- "https://sources.archlinux.org/other/gcc/gcc-$_gccver.tar.xz"
"http://isl.gforge.inria.fr/isl-$_islver.tar.bz2"
- "gdc::git+https://github.com/D-Programming-GDC/GDC.git#branch=$_branch"
- 'git+https://github.com/D-Programming-GDC/GDMD.git'
- 'paths.diff')
-sha512sums=('8988e9425a1fb5c2bc7655a8054438060e145d568fa60d19ec2ab4005a8becc06f906cffbfb674ff6c6995a3751af0590d2e6d5694cbb88951633aa8c2667e18'
- 'afe2e159b74646a26449268637403d271f9e3f6410d8cc1c9cffca41370c4357b165dea844db0c2a654591f954e54710dda650c8088abd4711406aa6302da950'
- 'SKIP'
+ "gcc::git+https://github.com/gcc-mirror/gcc.git#branch=$_branch"
+ 'git+https://github.com/D-Programming-GDC/GDMD.git')
+sha256sums=('d18ca11f8ad1a39ab6d03d3dcb3365ab416720fcb65b42d69f34f51bf0a0e859'
'SKIP'
- '841504e9dffe718f7e5a5fbbf03299f2b51acd783d47f99894aa5d411abcc56aedfffd4b16595e3a9446f2206f9eb29cb01e235e82c211796cd24dc23c02b578')
+ 'SKIP')
pkgver() {
- if [ -f gdc/gcc/d/verstr.h ]; then
- _d_ver="+$(cat gdc/gcc/d/verstr.h | sed 's|\"||g')"
- elif [ -f gdc/gcc/d/VERSION ]; then
- _d_ver="+$(cat gdc/gcc/d/VERSION | sed 's|\"||g')"
+ if [ -f gcc/gcc/d/dmd/VERSION ]; then
+ _d_ver="+$(cat gcc/gcc/d/dmd/VERSION | sed 's|\"||g')"
fi
-
echo "$(cat gcc/gcc/BASE-VER)$_d_ver"
}
prepare() {
- # Setup paths
- ln -sf "$srcdir"/gcc-$_gccver "$srcdir"/gcc
- ln -sf "$srcdir"/isl-$_islver "$srcdir"/gcc/isl
+ [[ ! -d gcc ]] && ln -s gcc-$_gccver/+/-} gcc
+ cd gcc
+
+ [[ ! -d isl ]] && ln -s ../isl-${_islver} isl
- # Setup gcc
- cd "$srcdir"/gcc
+ # Do not run fixincludes
+ sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
- sed -i 's|\./fixinc\.sh|-c true|' gcc/Makefile.in # Do not run fixincludes
- sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64 # Fix lib64 path
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
+ # Arch Linux installs x86_64 libraries /lib
+ sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
- # Seup gdc
- cd "$srcdir"/gdc
+ # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- git apply "$srcdir"/paths.diff
- ./setup-gcc.sh ../gcc
+ mkdir -p "$srcdir/gcc-build"
- mkdir "$srcdir"/gcc-build
}
build() {
- cd "$srcdir"/gcc-build
+ cd gcc-build
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- export CFLAGS="${CFLAGS/-pipe/} -O2"
- export CXXFLAGS="${CXXFLAGS/-pipe/} -O2"
-
- "$srcdir"/gcc/configure --prefix=/usr \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-languages=d \
- --enable-shared \
- --enable-static \
- --enable-threads=posix \
- --enable-libmpx \
- --with-system-zlib \
- --with-isl \
- --enable-__cxa_atexit \
- --disable-libunwind-exceptions \
- --enable-clocale=gnu \
- --disable-libstdcxx-pch \
- --disable-libssp \
- --enable-gnu-unique-object \
- --enable-linker-build-id \
- --enable-lto \
- --enable-plugin \
- --enable-install-libiberty \
- --with-linker-hash-style=gnu \
- --enable-gnu-indirect-function \
- --disable-multilib \
- --disable-werror \
- --disable-bootstrap \
- --enable-default-pie \
- --enable-default-ssp \
- --with-bugurl=https://bugzilla.gdcproject.org/ \
- --with-pkgversion="GDC ${pkgver%+*} based on D v${pkgver#*+} built with ISL $_islver for Arch Linux" \
- gdc_include_dir=/usr/include/dlang/gdc
-
- make $MAKEFLAGS
+ CFLAGS=${CFLAGS/-pipe/}
+ CXXFLAGS=${CXXFLAGS/-pipe/}
+
+ "$srcdir/gcc/configure" --prefix=/usr \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-bugurl=https://gcc.gnu.org/bugzilla/ \
+ --with-pkgversion="GDC ${pkgver%+*} based on D ${pkgver#*+} built with ISL $_islver for Arch Linux" \
+ --with-system-zlib \
+ --enable-languages=d \
+ --enable-static \
+ --enable-threads=posix \
+ --with-isl \
+ --enable-__cxa_atexit \
+ --disable-libunwind-exceptions \
+ --enable-clocale=gnu \
+ --disable-libstdcxx-pch \
+ --disable-libssp \
+ --enable-gnu-unique-object \
+ --enable-linker-build-id \
+ --enable-lto \
+ --enable-plugin \
+ --enable-install-libiberty \
+ --with-linker-hash-style=gnu \
+ --enable-gnu-indirect-function \
+ --disable-multilib \
+ --disable-werror \
+ --enable-bootstrap \
+ --enable-checking=release \
+ --enable-default-pie \
+ --enable-default-ssp \
+ --enable-cet=auto \
+ --with-target-system-zlib=yes
+
+ make
}
package_gdc-git() {
pkgdesc="Compiler for D programming language which uses gcc backend"
depends=('gcc' 'perl' 'binutils' 'libgphobos')
provides=("d-compiler=${pkgver#*+}" 'gdc')
- conflicts=('gdc')
+ conflicts=('gdc' 'gcc-gdc')
# Binaries
install -Dm 755 gcc-build/gcc/gdc "$pkgdir"/usr/bin/gdc
- install -Dm 755 gcc-build/gcc/cc1d "$pkgdir"/usr/lib/gcc/$CHOST/${pkgver%+*}/cc1d
+ install -Dm 755 gcc-build/gcc/d21 "$pkgdir"/usr/lib/gcc/$CHOST/${pkgver%+*}/d21
install -Dm 755 GDMD/dmd-script "$pkgdir"/usr/bin/gdmd
+ cd gcc-build
+ make -C lto-plugin DESTDIR="$pkgdir" install
+ make -C $CHOST/libgcc DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib{,32}/libgcc_s.so*
+
# Doc
install -Dm 644 "$srcdir"/GDMD/dmd-script.1 "$pkgdir"/usr/share/man/man1/gdmd.1
}
@@ -127,12 +124,16 @@ package_gdc-git() {
package_libgphobos-git() {
pkgdesc="Standard library for D programming language, GDC port"
provides=('d-runtime' 'd-stdlib' 'libgphobos')
- conflicts=('libgphobos')
+ conflicts=('libgphobos' 'gcc-gdc')
options=('staticlibs')
cd "$srcdir"/gcc-build
make -C $CHOST/libphobos DESTDIR="$pkgdir" install
+ mkdir -p -m 755 "$pkgdir"/usr/include/dlang
+
+ ln -s /usr/lib/gcc/$CHOST/${pkgver%+*}/include/d "$pkgdir"/usr/include/dlang/gdc
+
if [ -d "$pkgdir"/usr/lib64 ]; then
mv "$pkgdir"/usr/lib64/* "$pkgdir"/usr/lib
rmdir "$pkgdir"/usr/lib64
diff --git a/paths.diff b/paths.diff
deleted file mode 100644
index e367bbe0a814..000000000000
--- a/paths.diff
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/gcc/d/d-incpath.cc b/gcc/d/d-incpath.cc
-index e6cc314c..2618f571 100644
---- a/gcc/d/d-incpath.cc
-+++ b/gcc/d/d-incpath.cc
-@@ -140,7 +140,7 @@ add_import_paths (const char *iprefix, const char *imultilib, bool stdinc)
- path = xstrdup (p->fname);
-
- /* Add D-specific suffix. */
-- path = concat (path, "/d", NULL);
-+ path = concat (path, "/dlang/gdc", NULL);
-
- /* Ignore duplicate entries. */
- bool found = false;
-diff --git a/libphobos/configure b/libphobos/configure
-index 3fdd8dfd..ac6d77a5 100755
---- a/libphobos/configure
-+++ b/libphobos/configure
-@@ -14547,7 +14547,7 @@ fi
-
-
- # Default case for install directory for D sources files.
-- gdc_include_dir='$(libdir)/gcc/${target_alias}/${gcc_version}/include/d'
-+ gdc_include_dir='/usr/include/dlang/gdc/'
-
-
-
-diff --git a/libphobos/m4/druntime.m4 b/libphobos/m4/druntime.m4
-index 93f01efc..6049eaf9 100644
---- a/libphobos/m4/druntime.m4
-+++ b/libphobos/m4/druntime.m4
-@@ -97,7 +97,7 @@ AC_DEFUN([DRUNTIME_INSTALL_DIRECTORIES],
- AC_SUBST(toolexeclibdir)
-
- # Default case for install directory for D sources files.
-- gdc_include_dir='$(libdir)/gcc/${target_alias}/${gcc_version}/include/d'
-+ gdc_include_dir='/usr/include/dlang/gdc/'
- AC_SUBST(gdc_include_dir)
- ])
-