summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Stengele2018-02-18 20:13:50 +0100
committerDennis Stengele2018-02-18 20:14:42 +0100
commit0b645340407fd45964fa303b546ecc80cc44880f (patch)
tree8725f70ffa9e8243e757563231f8b28a8eaa6e08
downloadaur-0b645340407fd45964fa303b546ecc80cc44880f.tar.gz
Initial commit for gdcp
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c24369501762
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gdcp
+ pkgdesc = scp like tool to interact with Google Drive from the command-line
+ pkgver = 0.7.13
+ pkgrel = 1
+ url = https://github.com/ctberthiaume/gdcp
+ arch = any
+ license = GPL3
+ depends = python2-pydrive
+ depends = python2-backoff
+ source = gdcp-0.7.13.tar.gz::https://github.com/ctberthiaume/gdcp/archive/v0.7.13.tar.gz
+ sha256sums = 909c80d1df04269408efa18150e899107f3b19acc3cac5a05c2c68ba77e2d695
+
+pkgname = gdcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e60fcf55af1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dennis Stengele <dennis@stengele.me>
+
+pkgname=gdcp
+pkgver=0.7.13
+pkgrel=1
+pkgdesc="scp like tool to interact with Google Drive from the command-line"
+arch=('any')
+url="https://github.com/ctberthiaume/gdcp"
+license=('GPL3')
+depends=('python2-pydrive' 'python2-backoff')
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ctberthiaume/gdcp/archive/v${pkgver}.tar.gz")
+sha256sums=('909c80d1df04269408efa18150e899107f3b19acc3cac5a05c2c68ba77e2d695')
+
+package() {
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/gdcp" "${pkgdir}/usr/bin/gdcp"
+}