summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Puertas Ruiz2019-08-01 09:30:33 +0200
committerKevin Puertas Ruiz2019-08-01 09:30:33 +0200
commit569b77d9d32d3fc1baf7c25080489129f19b9dd1 (patch)
treed28f4468255a204f8620d3b7c23f06f87523e1ab
downloadaur-569b77d9d32d3fc1baf7c25080489129f19b9dd1.tar.gz
First bin version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rwxr-xr-xgdevelop.desktop9
-rw-r--r--glogo.pngbin0 -> 5613 bytes
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..004c059381a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gdevelop-bin
+ pkgdesc = Open-source, cross-platform game creator designed to be used by everyone - no programming skills required.
+ pkgver = 5.0.0.beta76
+ pkgrel = 1
+ url = https://gdevelop-app.com/
+ arch = x86_64
+ license = GPL
+ license = MIT
+ license = zlib/png
+ depends = gconf
+ provides = gdevelop
+ conflicts = gdevelop
+ source = https://github.com/4ian/GDevelop/releases/download/v5.0.0-beta76/gdevelop-5.0.0-beta76.tar.gz
+ source = https://github.com/4ian/GDevelop/raw/master/Core/docs/images/glogo.png
+ source = gdevelop.desktop
+ sha256sums = c18998d68492b67cfa8029c723d8769f7c81431bbdf2bd10965b3dfbfe29b9c7
+ sha256sums = 6ec8974d1c073442e1e653ac75d8ab4c1ed1cc1c2d14c6d73d6c50543a4f4b5f
+ sha256sums = 0e445ccbefd17af5d1d1984ba76fbc7b283eed04a0dcacf3a020739180c2d898
+
+pkgname = gdevelop-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a5944efdf16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kevin Puertas <kevinpr@jkanetwork.com>
+# Helper: paulequilibrio
+pkgname=gdevelop-bin
+_pkgname=gdevelop
+pkgver=5.0.0.beta76
+pkgrel=1
+pkgdesc="Open-source, cross-platform game creator designed to be used by everyone - no programming skills required."
+arch=('x86_64')
+url='https://gdevelop-app.com/'
+license=('GPL' 'MIT' 'zlib/png')
+groups=()
+provides=('gdevelop')
+conflicts=('gdevelop')
+depends=('gconf')
+source=("https://github.com/4ian/GDevelop/releases/download/v${pkgver//.b/-b}/gdevelop-${pkgver//.b/-b}.tar.gz"
+ 'https://github.com/4ian/GDevelop/raw/master/Core/docs/images/glogo.png'
+ 'gdevelop.desktop')
+sha256sums=('c18998d68492b67cfa8029c723d8769f7c81431bbdf2bd10965b3dfbfe29b9c7'
+ '6ec8974d1c073442e1e653ac75d8ab4c1ed1cc1c2d14c6d73d6c50543a4f4b5f'
+ '0e445ccbefd17af5d1d1984ba76fbc7b283eed04a0dcacf3a020739180c2d898')
+
+package() {
+ install -dm 755 "$pkgdir"/{opt/${_pkgname},usr/{bin,share/{applications,pixmaps}}}
+ cp -a "${srcdir}/${_pkgname}-${pkgver//.b/-b}/." "${pkgdir}/opt/$_pkgname/"
+ ln -s "/opt/$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -D -m 644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -D -m 644 "${srcdir}/glogo.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+}
diff --git a/gdevelop.desktop b/gdevelop.desktop
new file mode 100755
index 000000000000..65fdef0c1687
--- /dev/null
+++ b/gdevelop.desktop
@@ -0,0 +1,9 @@
+#!/usr/bin/env xdg-open
+
+[Desktop Entry]
+Name=GDevelop
+Comment=GDevelop
+Exec=/opt/gdevelop/gdevelop
+Icon=/usr/share/pixmaps/gdevelop.png
+Categories=Development
+Type=Application
diff --git a/glogo.png b/glogo.png
new file mode 100644
index 000000000000..910b72cf4a28
--- /dev/null
+++ b/glogo.png
Binary files differ