summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseluCross2016-05-29 01:33:55 +0200
committerJoseluCross2016-05-29 01:33:55 +0200
commit4f371c1bb6baaf5ff761780833999b708bd8b9b4 (patch)
tree68f9c0d603c3f6f357bc06fc3646b3bb5664ca4a
parentb66c0d03371ec3bd6199d891e1036a267d9b6c2f (diff)
downloadaur-4f371c1bb6baaf5ff761780833999b708bd8b9b4.tar.gz
daily PKGBUILD update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 042796e773c1..f0abd473604c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gdevelop-git
pkgdesc = A full featured, open source game development software, allowing to create HTML5 and native games without knowing a programming language. All the game logic is made thanks to an intuitive and powerful event based system.
- pkgver = 20160528
+ pkgver = 20160529
pkgrel = 1
url = http://www.compilgames.net
install = gdevelop-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 1e800c3f7941..e424a1bcc6ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: JKA Network <contacto@jkanetwork.com>
# Before maintainer: Todor Imreorov for github <blurymind@gmail.com>
-
pkgname=gdevelop-git
-pkgver=20160528
+pkgver=20160529
pkgrel=1
pkgdesc="A full featured, open source game development software, allowing to create HTML5 and native games without knowing a programming language. All the game logic is made thanks to an intuitive and powerful event based system."
arch=('x86_64')
-url="http://www.compilgames.net"
+url=http://www.compilgames.net
license=('GPL' 'MIT' 'zlib/png')
groups=()
provides=('gdevelop')
@@ -15,23 +14,20 @@ makedepends=('rsync' 'cmake' 'git' 'curl')
depends=('gcc' 'wxgtk' 'openal' 'p7zip' 'glew' 'libsndfile' 'systemd' 'libjpeg-turbo' 'desktop-file-utils' 'gtk-update-icon-cache')
source=('git+https://github.com/4ian/GD.git')
md5sums=(SKIP)
-
build() {
- cd "$srcdir"/GD
+ cd ""/GD
cd Binaries
rm -rf build
mkdir build
cd build
cmake ../..
-
#Build the whole project
make -j4
}
-
package() {
cd "$srcdir"/GD
cd Binaries/build
- make install DESTDIR="$pkgdir"
+ make install DESTDIR=
#Remove sfml installed libs
- rm -rf "$pkgdir"/usr/local
+ rm -rf ""/usr/local
}