summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2019-08-18 17:37:32 -0400
committerVincent Grande2019-08-18 17:37:32 -0400
commit28f8cb165d043fddb3eabd3675f4f99d348140d1 (patch)
tree9bfa6f8416f98134b3e0c1b3dc359ebab12e4ae8
downloadaur-28f8cb165d043fddb3eabd3675f4f99d348140d1.tar.gz
did a thing
-rw-r--r--.SRCINFO27
-rwxr-xr-xPKGBUILD51
-rwxr-xr-xgdk-pixbuf-query-loaders.hook11
-rwxr-xr-xgdk-pixbuf2.install3
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89dc34ad4d44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gdk-pixbuf2-git
+ pkgdesc = An image loading library
+ pkgver = 2.39.2+1+g3249c681f
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/GdkPixbuf
+ install = gdk-pixbuf2.install
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ depends = glib2
+ depends = libpng
+ depends = libtiff
+ depends = libjpeg
+ depends = libx11
+ depends = jasper
+ depends = shared-mime-info
+ provides = gdk-pixbuf2
+ conflicts = gdk-pixbuf2
+ source = git+https://gitlab.gnome.org/GNOME/gdk-pixbuf.git
+ source = gdk-pixbuf-query-loaders.hook
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gdk-pixbuf2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3d384f431f6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=gdk-pixbuf2-git
+pkgver=2.39.2+1+g3249c681f
+pkgrel=1
+pkgdesc="An image loading library"
+arch=(x86_64)
+url="https://wiki.gnome.org/Projects/GdkPixbuf"
+license=(LGPL2.1)
+provides=(gdk-pixbuf2)
+conflicts=(gdk-pixbuf2)
+depends=(glib2 libpng libtiff libjpeg libx11 jasper shared-mime-info)
+makedepends=(gobject-introspection git meson)
+install=gdk-pixbuf2.install
+source=("git+https://gitlab.gnome.org/GNOME/gdk-pixbuf.git"
+ gdk-pixbuf-query-loaders.hook)
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd gdk-pixbuf
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd gdk-pixbuf
+}
+
+build() {
+ arch-meson gdk-pixbuf build \
+ -D jasper=true \
+ -D docs=false \
+ -D man=false \
+ -D installed_tests=false
+ ninja -C build
+}
+
+#check() {
+# cd build
+ # pixbuf-randomly-modified fails randomly
+# meson test -t 3 || :
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gdk-pixbuf-query-loaders.hook b/gdk-pixbuf-query-loaders.hook
new file mode 100755
index 000000000000..3f6a3e43935e
--- /dev/null
+++ b/gdk-pixbuf-query-loaders.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/*.so
+
+[Action]
+Description = Probing GDK-Pixbuf loader modules...
+When = PostTransaction
+Exec = /usr/bin/gdk-pixbuf-query-loaders --update-cache
diff --git a/gdk-pixbuf2.install b/gdk-pixbuf2.install
new file mode 100755
index 000000000000..83fa07cfee54
--- /dev/null
+++ b/gdk-pixbuf2.install
@@ -0,0 +1,3 @@
+pre_remove() {
+ rm -f /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
+}